The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

FreeBSD 4.9 4.10 & 5.2.1 Problem installing Cpanel.

Discussion in 'General Discussion' started by aboyz, Jul 21, 2004.

  1. aboyz

    aboyz Well-Known Member

    Joined:
    Sep 29, 2003
    Messages:
    104
    Likes Received:
    0
    Trophy Points:
    16
    Hi,

    I have tried to install cpanel on a fresh new server using 4.9, 4.10 & 5.2.1. Usually the installation will install smoothly with no error. But here is some of the error I encounter.

    Installing cpanel with 4.9 and 4.10

    I ran the latest and I get the following error.

    Something rsync can't not be installed.. so what I do is install rsync manually under ports. and ran the latest script again. That went well. After the installation is finish.

    I have issues with named as it is not started correctly. I would guess that bind 9.2.3 got to do something with it.

    Error I'm getting. is

    rndc: connection refuse.. or uknown hostname or default.
    also.

    cannot write to /var/run/named.pid

    I did a chmod 777 to /var/run and the named ran fine, but when into the control panel WHM and look at the stats. BIND is RED. So something is not working right here.

    I tried to run /scripts/update & /scripts/fixnamed and /scripts/fixndc

    those doesn't even HELP...

    Once Last thing I did was

    went into /usr/ports/dns/bind9
    deinstall
    reinstall

    As that didn't work as well. Last resouce was download the latest again, and ran that again. On the cpanel installation. I see errrors like named. unknown host or no default.

    What is going on with freebsd and cpanel? did cpanel did something ? Or is it bind9 problem. I have went thru the forums and this is not helping me. Please point me to the right direction??

    Anyone got issues with freebsd??
     
  2. aboyz

    aboyz Well-Known Member

    Joined:
    Sep 29, 2003
    Messages:
    104
    Likes Received:
    0
    Trophy Points:
    16
    Mostly Related with bind9

    Hi,

    The issues is related to bind9. Here is what I found out so far.. But It haven't fix my problem.

    /etc/namedb/rndc.conf missing in FreeBSD 4.9R

    --------------------------------------------------------------------------------

    Whenever I modify a DNS zone in WHM I get the following error:

    Fatal, neither ndc or rndc was found on this server (ns.domain.com)

    I believe the error is caused by the fact that the following files are missing:

    /etc/namedb/rndc.conf
    /etc/namedb/rndc.conf.sample

    Note: /scripts/fixndc does not correct this issue. Any suggestions are appreciated.

    i am getting this error after i rebooted my freebsd 4.9 machine:


    Code:
    rndc: neither /etc/namedb/rndc.conf nor /etc/namedb/rndc.key was found

    not sure whats going on. i read for some other ndc problems there was a script that fixed them. so i ran /scripts/fixndc and here was the output:


    Code:
    su-2.05b# /scripts/fixndc
    Found controls in named.conf ..
    Adding key...
    Restarting bind.....Waiting for named to restart..............finished.

    rndc: no server specified and no default

    named started ok
    Jul 14 22:43:08 backstow named[86939]: starting BIND 9.2.3 -u bind -c /etc/namedb/named.conf
    Jul 14 22:43:08 backstow named[86939]: none:0: open: /etc/namedb/rndc.key: file not found
    Jul 14 22:43:08 backstow named[86939]: /etc/namedb/named.conf:6: couldn't install keys for command channel 127.0.0.1#953: file not found
    Jul 14 22:43:08 backstow named[86939]: /etc/namedb/named.conf:6: couldn't add command channel 127.0.0.1#953: file not found
    Jul 14 22:43:08 backstow named[86939]: couldn't open pid file '/var/run/named.pid': File exists
    Jul 14 22:43:08 backstow named[86939]: exiting (due to early fatal error)
    Done
    All fixed
    su-2.05b#

    I attempted to change the permissions (to 766) on /var/run and that did not fix this same exact problem for me. I'm currently having the tech support team look into this for me, but what's really weird about this is the fact that my RNDC key randomly got deleted. I doubt it was a hack of any sort, because plenty more files would be gone in that case, but I am totally stumped. I don't know if recreating the key will fix the problem or not, but reinstalling the BIND9 port did not fix the issue.
     
  3. aboyz

    aboyz Well-Known Member

    Joined:
    Sep 29, 2003
    Messages:
    104
    Likes Received:
    0
    Trophy Points:
    16
    Yeah, bind 8.4 is running GREAT!!

    Yeah..

    bind 8.4 is running GREAT.. just bind9.2.3 is having issues. I don't know what the issues is . If i do i'll fix it myself :) hahaahah...

    I'm pretty sure it'll work on redhat 9.0 es3 and fedora..
     
  4. aboyz

    aboyz Well-Known Member

    Joined:
    Sep 29, 2003
    Messages:
    104
    Likes Received:
    0
    Trophy Points:
    16
    Still Error running fixndc

    cp# ./fixndc
    Found controls in named.conf ..
    Adding key...
    Adding controls...
    Restarting bind.....Waiting for named to restart..............finished.

    rndc: no server specified and no default

    named started ok
    Jul 21 17:37:05 cp named[10855]: starting BIND 9.2.3 -u bind -c /etc/namedb/named.conf
    Jul 21 17:37:05 cp named[10855]: none:0: open: /etc/namedb/rndc.key: file not found
    Jul 21 17:37:05 cp named[10855]: /etc/namedb/named.conf:4: couldn't install keys for command channel 127.0.0.1#953: file not found
    Jul 21 17:37:05 cp named[10855]: /etc/namedb/named.conf:4: couldn't add command channel 127.0.0.1#953: file not found
    Jul 21 17:37:05 cp named[10855]: couldn't open pid file '/var/run/named.pid': Permission denied
    Jul 21 17:37:05 cp named[10855]: exiting (due to early fatal error)
    Done
    All fixed
     
  5. hicom

    hicom Well-Known Member

    Joined:
    May 23, 2003
    Messages:
    272
    Likes Received:
    0
    Trophy Points:
    16
    Ran /scripts/fixndc and got:

    /scripts/fixndc
    named.conf has already been fixed!

    I still receive that error about missing ndc in WHM whenever I edit the DNS zones. The zones work fine once I restart BIND.
     
  6. sjackson909

    sjackson909 Well-Known Member

    Joined:
    Jun 8, 2004
    Messages:
    113
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Columbus, OH
    Don't run /scripts/fixndc doesn't fix any thing. To fix the pid file just add this line under the options in named.conf

    pid-file "/var/tmp/named.pid";

    also run this.

    rndc-confgen -r /dev/urandom

    This will create keys for you named.conf and also your keys for /etc/namedb/rndc.conf.

    Also when that is done fo this

    ln -s /etc/namedb/rndc.conf /etc/rndc.conf

    Thanks
    -Seth
     
  7. aboyz

    aboyz Well-Known Member

    Joined:
    Sep 29, 2003
    Messages:
    104
    Likes Received:
    0
    Trophy Points:
    16
    its not that.

    damitl
    cpanel is mess up for some reason!!! nothing is working..

    this is a fresh install. anyone experience this???
     
  8. hicom

    hicom Well-Known Member

    Joined:
    May 23, 2003
    Messages:
    272
    Likes Received:
    0
    Trophy Points:
    16
    On our BSD machine, it appears rndc-confgen is not installed.
     
  9. sjackson909

    sjackson909 Well-Known Member

    Joined:
    Jun 8, 2004
    Messages:
    113
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Columbus, OH
    If bind 9+ is install you have to have rndc-confgen installed. That is how keys are made. Check your path.

    Thanks
    -Seth
     
  10. vargalas

    vargalas Member

    Joined:
    Jul 31, 2004
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    I run into this problem during the installation. Installation stopped, when it reached the rndc-confgen line.
    I wrote:rndc-confgen -r /dev/urandom like Seth said and killed the original rndc-confgen process. It seemed to succeeded, because it continued the installation.
     
  11. hicom

    hicom Well-Known Member

    Joined:
    May 23, 2003
    Messages:
    272
    Likes Received:
    0
    Trophy Points:
    16
    It seems everyone was upgraded to BIND 9 except ours. After the cPanel upgrade, we were still on BIND 8.

    So I did a a new installation from the ports and worked fine.
     
  12. bmillett

    bmillett Registered

    Joined:
    Mar 30, 2004
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    California
    Thank you.

    Adding the PID under the options in named.conf and the rndc-confgen -u /dev/urandom saved our skin.

    Wish Cpanel would have tested this before updating.

    Live and learn!!!
     
  13. oSM

    oSM Well-Known Member

    Joined:
    Aug 18, 2001
    Messages:
    46
    Likes Received:
    0
    Trophy Points:
    6
    That did the TRICK. Thanks Seth :D
     
  14. sjackson909

    sjackson909 Well-Known Member

    Joined:
    Jun 8, 2004
    Messages:
    113
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Columbus, OH
    Glad I could help. I just think that it's messed up of cpanel to slid this new bind version without informing or putting it in a Release version first.

    Thanks
    -Seth
     
  15. silentcircuit

    silentcircuit Active Member

    Joined:
    Nov 19, 2002
    Messages:
    40
    Likes Received:
    0
    Trophy Points:
    6
    I am still getting the error. I have done everything I can find in one of these posts. I am getting this error in /var/log/messages.

    "limit files set to fdlimit (1024)
    /etc/namedb/named.conf:8: Ignoring BIND 9 intet control clause
    Ready to answer queries
    check_hints: A records for B.ROOT-SERVERS.NET class 1 do not match hint records"

    any help is very appreciated.
     
  16. iko

    iko Well-Known Member
    PartnerNOC

    Joined:
    Jan 29, 2004
    Messages:
    56
    Likes Received:
    0
    Trophy Points:
    6
    cPanel downgraded bind to 8.4.6. Please do:

    named -v

    and see what version you are using.

    If it is 8.x then do:

    cd /usr/ports/dns/bind9
    make install clean

    Cheers!
     
Loading...

Share This Page