The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Freebsd 5.4 & Bind Problems

Discussion in 'Bind / DNS / Nameserver Issues' started by gloverkarl, Jul 3, 2005.

  1. gloverkarl

    gloverkarl Well-Known Member

    Joined:
    Feb 29, 2004
    Messages:
    53
    Likes Received:
    0
    Trophy Points:
    6
    Hi,

    I have just moved my cPanel box onto FreeBSD, and i have come across a slight problem which i cannot seem to find a fix for when looking up my nameserver i get the following,

    web# host ns1.domain.com
    ns1.domain.com has address xxx.xxx.xx.xxx
    ;; connection timed out; no servers could be reached

    Has anyone any ideas as to how to fix this?

    Regards,
    Karl Glover.
     
  2. AndyReed

    AndyReed Well-Known Member
    PartnerNOC

    Joined:
    May 29, 2004
    Messages:
    2,222
    Likes Received:
    3
    Trophy Points:
    38
    Location:
    Minneapolis, MN
    FreedBSD and BIND are not very friendly and could be pain in the nick. Make sure your /etc/resolve.conf has the right information, the same can be said about /etc/sysconfig/network. Make sure your DNS zones are configured properly.
     
  3. lpmusix

    lpmusix Member

    Joined:
    Feb 28, 2005
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    I don't remember exactly what you have to move, but if you run named by hand (named -u bind -c /etc/namedb/named.conf) in a root shell, it'll complain about it not finding a file, you'll have to move that file from /var/etc/named or something to the location it's looking for it at. Sorry I can't be more specific
     
  4. gloverkarl

    gloverkarl Well-Known Member

    Joined:
    Feb 29, 2004
    Messages:
    53
    Likes Received:
    0
    Trophy Points:
    6
    logs

    Right, ive been playing for hours now ive searched for ages on the forums and none of the fixes appear to work im now getting the following;

    Jul 4 11:50:29 web named[41829]: starting (/etc/namedb/named.conf). named 8.3.7-REL Mon Jul 4 01:15:15 BST 2005
    root@odwa:/usr/ports/dns/bind8/work/src/bin/named
    Jul 4 11:50:29 web named[41829]: limit files set to fdlimit (1024)
    Jul 4 11:50:29 web named[41829]: /etc/namedb/named.conf:7: Ignoring BIND 9 inet control clause
    Jul 4 11:50:29 web named[41829]: /etc/namedb/named.conf:11: no options statement before first zone; using previous/default
    Jul 4 11:50:29 web named[41830]: Ready to answer queries.


    Does this give anymore help as to what the problem is?


    Then after installing Bind9 i get the following but appears to load no zones but they are in the config,

    Jul 4 12:13:51 web named[12324]: starting BIND 9.3.1 -u bind -c /etc/namedb/named.conf
    Jul 4 12:13:51 web named[12324]: command channel listening on 127.0.0.1#953
    Jul 4 12:13:51 web named[12324]: running

    Thanks
    Karl Glover.
     
    #4 gloverkarl, Jul 4, 2005
    Last edited: Jul 4, 2005
Loading...

Share This Page