The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

FreeBSD 8

Discussion in 'General Discussion' started by hostultra, Dec 2, 2009.

  1. hostultra

    hostultra Well-Known Member

    Joined:
    Aug 21, 2002
    Messages:
    167
    Likes Received:
    0
    Trophy Points:
    16
    Anyone tried freebsd 8 on a cpanel server?
    Does it work well?
     
  2. uhhosting

    uhhosting Member
    PartnerNOC

    Joined:
    Jan 21, 2007
    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    1
    No, but I'm going to try in a bit.

    I think it would be good to wait for FreeBSD to settle on 8.1/2 for production boxes.
     
  3. uhhosting

    uhhosting Member
    PartnerNOC

    Joined:
    Jan 21, 2007
    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    1
    Well it works - I've had to symlink some of the so's to older versions, in order for cpsrvd to start, which is usual behaviour, as cPanel won't officially support FreeBSD 8.x for a lil while yet.

    But I see no reason why they couldn't complete their own testing within a few weeks and release a fully working version.
     
  4. nyjimbo

    nyjimbo Well-Known Member

    Joined:
    Jan 25, 2003
    Messages:
    1,125
    Likes Received:
    0
    Trophy Points:
    36
    Location:
    New York
    They didnt support 7.1 or 7.2

    I really hope they support 8.0
     
  5. mystique

    mystique Registered

    Joined:
    Dec 6, 2009
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    (morning - possible new whm owner here.. 1st post)

    As an operator of a small hosting company for many years running nothing but FreeBSD ;)

    It says in the docs that amd64 7.0 is supported..

    if you did a 7.0 install then a buildworld up to 7.2, I would think everything would work as long as you did not do a make delete-old-libs (and such)

    obviously any new apps that would be built would be linked using the newer libs.. but the old ones would be lying around for (somewhat) compatibility..

    (right?)

    Or does cpanel not work this way?
     
  6. nyjimbo

    nyjimbo Well-Known Member

    Joined:
    Jan 25, 2003
    Messages:
    1,125
    Likes Received:
    0
    Trophy Points:
    36
    Location:
    New York
    Just checked on "System Requirements" today and saw this :

    Supported Operating Systems:

    i386 Architecture: •FreeBSD®-RELEASE versions 7.1, 7.2, 8.0
    x86-64 Architecture: •FreeBSD® -RELEASE versions 7.1, 7.2, 8.0

    Merry Christmas ! :)
     
    #6 nyjimbo, Dec 23, 2009
    Last edited: Dec 23, 2009

Share This Page