Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

FreeBSD and Apache FD_SETSIZE

Discussion in 'EasyApache' started by hicom, Oct 6, 2005.

  1. hicom

    hicom Well-Known Member

    Joined:
    May 23, 2003
    Messages:
    282
    Likes Received:
    2
    Trophy Points:
    168
    Hi!

    I am noticing this error on FreeBSD 5.4 with Apache 1.3.33

    [Thu Oct 6 14:51:31 2005] [warn] send body: filedescriptor (1367) larger than FD_SETSIZE
    (1024) found, you probably need to rebuild Apache with a larger FD_SETSIZE

    I did re-compile apache from WHM (we made sure FD_SETSIZE is checked, and removed the checked at the bottom next to Skip Building apache)

    however, the problem still occurs. so I modified /usr/local/apache/bin/apachectl and added :

    ulimit -n 16480
    also in
    /etc/init.d/httpd

    But the same problem continues, it is happening much less than before, but we continue to see it.

    Doing
    <?PHP echo `ulimit -n`; ?> shows: 11095

    How else would we need to increase the FD_SETSIZE on FreeBSD 5 ?

    I read somewhere there is also need to change it at:
    /usr/include/sys/select.h ?

    This requires recompiling Kernel, correct ? How about adding this to the FBSD kernel:
    options FD_SETSIZE nnn as suggested in Apache FAQ:
    http://httpd.apache.org/docs/1.3/misc/FAQ.html#freebsd-setsize

    Also it appears there are different places the FD_SETSIZE need to be changed as per:
    http://apache.active-venture.com/descriptors.html

    Any input or experiences with these are welcomed.

    Thanks!
     
    #1 hicom, Oct 6, 2005
    Last edited: Oct 6, 2005
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice