The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

[freebsd, php] missing iconv

Discussion in 'General Discussion' started by Escaflowne, Apr 11, 2006.

  1. Escaflowne

    Escaflowne Active Member

    Joined:
    May 5, 2004
    Messages:
    40
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    PL
    Hello!

    I have a problem with iconv support in PHP. I've installed PHP with iconv through easyapache. Here's how my phpinfo() looks like:
    http://amsterdam.pl/info.php
    And here's a sample script that tries to run the PHP iconv() function:
    http://amsterdam.pl/iconv.php

    So... do I, or don't I have iconv compiled into PHP?

    PS. I've tried recompiling PHP but with no luck at all - iconv in phpinfo, no iconv in scripts :(
     
  2. IPSecureNetwork

    IPSecureNetwork Well-Known Member

    Joined:
    May 28, 2005
    Messages:
    99
    Likes Received:
    0
    Trophy Points:
    6
    in the cpanel software box in the WHM you must install php again true the ports section.
    in the ports just type PHP and you can see all the php ports to install is easy to fix.
    good luck.
     
  3. Escaflowne

    Escaflowne Active Member

    Joined:
    May 5, 2004
    Messages:
    40
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    PL
    So, you're saying that I should reinstall PHP through the ports interface available in WHM (Software section)?
    My PHP (and Apache) was installed through WHM easyapache. Won't installing PHP through ports break my configuration?
    PHP is located in /usr and the ports will install PHP in /usr/local.
     

Share This Page