The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

FreeBSD: required gettext library

Discussion in 'General Discussion' started by Homie, Sep 24, 2004.

  1. Homie

    Homie Member

    Joined:
    Jul 22, 2003
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    1
    Hello People,

    I'm in need of your help. I'm trying to fix cPanel PHP using its built in /scripts/makecpphp and I get the following results:

    checking for bindtextdomain in -lintl... no
    checking for bindtextdomain in -lc... no
    configure: error: Unable to find required gettext library
    make: no target to make.
    make: don't know how to make install. Stop
    PHP version file is up to date

    What do you suggest?

    OS is FreeBSD 4.10
     
  2. laborspy

    laborspy Well-Known Member

    Joined:
    Feb 7, 2004
    Messages:
    94
    Likes Received:
    0
    Trophy Points:
    6
    you probly have it installed but the program can't find it. You usually need to complile php with --with-gettext=[path to gettext]. have you tried using the "Update Apache" function in WHM? It will recompile apache & php at the same time.

    -jason
     
  3. Homie

    Homie Member

    Joined:
    Jul 22, 2003
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    1
    Yes, I ran 'easyapache' from shell, but as I've learned from a 3rd party company, cPanel are using their own PHP instance rather than the one compiled by the 'easyapache' script.

    The issue was fixed with a reinstall. :cool:
     
Loading...

Share This Page