The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

fresh fedora OS install / cpanel apache problems

Discussion in 'EasyApache' started by cz1179, Jan 27, 2005.

  1. cz1179

    cz1179 BANNED

    Joined:
    Dec 27, 2004
    Messages:
    105
    Likes Received:
    0
    Trophy Points:
    0
    I got my server freshly installed with Fedora Core 1 OS and followed these steps below:

    mkdir /home/cpins
    cd /home/cpins
    wget http://layer1.cpanel.net/latest
    sh latest

    /scripts/updatenow
    /scripts/upcp
    if you have the latest build then you can just run
    yum update
    /scripts/easyapache

    It is not working. Please see errors below. Odd enough, it worked just fine on another server installed with CentOS 3.3

    postgresql-server-7.3.4-1 100% |=========================| 2.6 MB 00:02
    Running test transaction:
    Test transaction complete, Success!
    postgresql-libs 100 % done 1/4
    postgresql 100 % done 2/4
    postgresql-devel 100 % done 3/4
    postgresql-server 100 % done 4/4
    Installed: postgresql-devel 7.3.4-11.i386 postgresql 7.3.4-11.i386 postgresql-s
    erver 7.3.4-11.i386
    Dep Installed: postgresql-libs 7.3.4-11.i386
    Transaction(s) Complete
    Stopping postgresql service: [FAILED]
    postmaster: no process killed
    postmaster: no process killed
    Initializing database: [ OK ]
    Starting postgresql service: [ OK ]
    You should now configure postgresql from WHM!
    You should now configure postgresql from WHM!
    You should now configure postgresql from WHM!
    You should now configure postgresql from WHM!
    13:33:42 URL:http://layer1.cpanel.net/buildapache/1/libmcrypt-2.5.7.tar.gz [5233
    21/523321] -> "libmcrypt-2.5.7.tar.gz" [1]
    Untarring mcryptDone
    configure libmcrypt-2.5.7...(--prefix=/usr --disable-posix-threads).........Done
    make libmcrypt-2.5.7......................Done
    make libmcrypt-2.5.7...(install)....Done
    13:34:06 URL:http://layer1.cpanel.net/buildapache/1/mhash-0.8.18.tar.gz [347483/
    347483] -> "mhash-0.8.18.tar.gz" [1]
    Untarring mhashDone
    configure mhash-0.8.18...(--prefix=/usr).........Done
    make mhash-0.8.18...............Done
    make mhash-0.8.18...(install)....Done
    Unable to fetch curl-7.12.0.tar.gz
    Waiting for httpd to restart..............finished.

    root 2344 0.3 0.3 9192 3996 ? S 13:34 0:00 /usr/local/apache
    /bin/httpd -DSSL

    httpd started ok


    What went wrong here that I did? How can I fix this?
     
  2. cz1179

    cz1179 BANNED

    Joined:
    Dec 27, 2004
    Messages:
    105
    Likes Received:
    0
    Trophy Points:
    0
    I ran /scripts/easyapache again and it worked this time...

    now when installing APF (which I've done so many times same way without trouble) I get this error

    [root@localhost apf-0.9.4-8]# /usr/local/sbin/apf -s
    /usr/local/sbin/apf: line 281: Pure: command not found
    /etc/apf/vnet/vnetgen: line 281: Pure: command not found
    /etc/apf/firewall: line 281: Pure: command not found
    Development mode enabled!; firewall will flush every 5 minutes.
    /etc/apf/firewall: line 281: Pure: command not found


    Why?
     
  3. haze

    haze Well-Known Member

    Joined:
    Dec 21, 2001
    Messages:
    1,550
    Likes Received:
    3
    Trophy Points:
    38
    This has already been explained to you elsewhere Chadi. You've modified your config file, and the lines seem to be wrapping to a new line rather than stick to the line their meant to be on.
     
  4. cz1179

    cz1179 BANNED

    Joined:
    Dec 27, 2004
    Messages:
    105
    Likes Received:
    0
    Trophy Points:
    0
    I did not modify anything. Please read carefully. Its a fresh OS install
     
  5. haze

    haze Well-Known Member

    Joined:
    Dec 21, 2001
    Messages:
    1,550
    Likes Received:
    3
    Trophy Points:
    38
    :rolleyes:
    Your APF config file.. /etc/apf/conf.apf

    You have to modifiy this file before you start the APF firewall, so I assume YOU DID modify this file one way or another.

    As for your other issue. First, make sure your OS is up to date ( Fedora Core 1 IS no longer updated by the way, its End Of Life, its only a matter of time before cpanel will have no choice but to drop support for it as well ). Second make sure your resolvers are correctly set and check the log files in /home/cpapachebuild/buildapache/build-log for more details on what caused the error.
     
  6. cz1179

    cz1179 BANNED

    Joined:
    Dec 27, 2004
    Messages:
    105
    Likes Received:
    0
    Trophy Points:
    0
    I had to modify that one file as its part of teh APF install instructions. I've done it that way so many times without trouble but on this fresh Fedora install its giving me a weird error.

    The resolv.conf is fine as well, yum update says "no updates needed". I've ran /scripts/easyapache three times already as well.

    As for /home/cpapachebuild/buildapache/build-log there are so many files that I don't know where to look for as php for example is already working, all green status in WHM server stats as well.
     
  7. cz1179

    cz1179 BANNED

    Joined:
    Dec 27, 2004
    Messages:
    105
    Likes Received:
    0
    Trophy Points:
    0
    Not sure how it fixed but I, once again ran /scripts/easyapache and /scripts/upcp then reinstalled APF once more, somehow it worked this time around.

    I'll never know but it worked.

    Thanks for your effort haze
     
Loading...

Share This Page