The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Fresh installation, Roundcube 404

Discussion in 'General Discussion' started by marcushann, Jan 14, 2014.

  1. marcushann

    marcushann Registered

    Joined:
    Jan 14, 2014
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Hi,

    I have installed cpanel on a centos 5 server and have not made any modifications to it. The server has 4 cores, 2gb ram and 100gb disk space.

    Unfortunately, for some reason Roundcube is not working because I am getting a 404 error. I have tried reformatting my server and starting from scratch but it is still not working and I am now stuck for ideas and I was hoping someone here would be able to help.

    Thanks,
    Marcus
     
  2. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,478
    Likes Received:
    203
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    Have you enabled it in Tweak Settings?
    Home » Server Configuration » Tweak Settings, Mail tab.
     
  3. marcushann

    marcushann Registered

    Joined:
    Jan 14, 2014
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
  4. marcushann

    marcushann Registered

    Joined:
    Jan 14, 2014
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Hi,

    I have just figured out what was wrong. When I was attempting to force an update to roundcube, it was trying to install a patch (patch number 0004).
    Code:
    info [update-roundcube] Applied patch '0004-append-INBOX.-to-avoid-UID-COPY-Unknown-namespace-er.patch'
    I deleted the patch and then forced a roundcube update again and it seems to have worked (as far as there is no 404 error any more). Although, I am still not sure why I had a patch that didn't work on a completely fresh installation (installed this morning)

    Thanks,
    Marcus
     
  5. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    676
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    Please keep in mind that you should not reinstall the OS/cPanel for an issue such as this. It's much easier to simply review the error logs and determine what's preventing it from loading. In this case, I suggest forcing an update of cPanel and installing Roundcube with all included patches. Then, if the issue continues, review the Roundcube error log in:

    /var/cpanel/roundcube/log/

    Thank you.
     
Loading...

Share This Page