The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

front page of cpanel loading slowly

Discussion in 'General Discussion' started by ZapX.net, Apr 17, 2005.

  1. ZapX.net

    ZapX.net Well-Known Member

    Joined:
    Feb 24, 2005
    Messages:
    52
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Sidman, PA
    Hello,

    Some work was done on my vps last night, and this morning cpanel seems to be loading quite slowly. The funny thing is, it is just the front page loading slowly, all other pages work fine.

    I noted the following error message on /usr/local/cpanel/logs/error_log.

    When loading it generally gets stuck at the statistics table, where it usually says "ftp accounts".

    Also, note that whm loads fine.

    I guess my conclusion is it's unable to stat the number of ftp accounts for some reason, as it does say "0 / 50"

    Thanks for any help,

    Brandon
     
  2. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    When I've come across this the one of the following always seems t get it working correctly again:

    1. Restart cPanel
    2. Remove /etc/passwd.lock if it is there, then 1.
    3. Run /scripts/updatenow, then 1.
    4. run /scripts/upcp --force
     
  3. ZapX.net

    ZapX.net Well-Known Member

    Joined:
    Feb 24, 2005
    Messages:
    52
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Sidman, PA
    Actually whatever you did worked, chirpy. What I had done temporarily was to comment out the part in CPanel where it attempts to count ftp accounts. I did try your suggestion on deleting /etc/passwd.lock and restart cpanel, but that didn't work. Not sure what you did.

    Anyway thanks.

    Brandon
     
  4. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    I did 1. then 2. then 3. in turn in the list I posted, sprinkled on a little pixie dust, and it worked ;)
     
Loading...

Share This Page