The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

FrontPage Auth no longer working

Discussion in 'General Discussion' started by deddy, Dec 3, 2003.

  1. deddy

    deddy Well-Known Member

    Joined:
    Oct 13, 2003
    Messages:
    131
    Likes Received:
    0
    Trophy Points:
    16
    After update to Apache 1.3.29 it is
    no longer possible to publish FrontPageWebs although FrontPage Extensions are installed.

    It seems to be an auth problem.

    Error Message :

    Internal Server Error: An error occurred accessing your FrontPage web files. Authors - if authoring against a web server, please contact the webmaster for this server's site. WebMasters - please see the server's system log for more details.

    Error is #4000a
    It was used FrontPage 2000.
    FrontPage/5.0.2.2634 is installed.

    /scripts/fpupdate
    can't help to get rid of that problem.

    /scripts/fp-auth got the following error :

    Internal Server Error
    The server is temporarily unable to service your
    request because it was unable to change uids to the requested uid.
    This is usually because the User/Group line is missing from the
    VirtualHost entry for this domain in httpd.conf.

    on another server :

    [fp-auth] [error] Cannot open //_vti_pvt/service.pwd uid=0 gid=0 10 6 4 3 2 1 0

    How can I fix that problem ?
     
  2. Daniel

    Daniel Well-Known Member

    Joined:
    Aug 13, 2001
    Messages:
    165
    Likes Received:
    0
    Trophy Points:
    16
  3. hicom

    hicom Well-Known Member

    Joined:
    May 23, 2003
    Messages:
    272
    Likes Received:
    0
    Trophy Points:
    16
    Check the Username/Group on the account you're trying to access through frontpage.

    Also check the CHMOD, it must be 751 or more, and the username/group should not contain 'nobody'
     
  4. deddy

    deddy Well-Known Member

    Joined:
    Oct 13, 2003
    Messages:
    131
    Likes Received:
    0
    Trophy Points:
    16
    Yes, permissions on home directories and public_html
    directories were messed up. Fixed.

    All public_html directories got nobody as group.
    Fixed.

    But the FP problems mentioned above "unfortunately"
    are not fixed and still persist. :confused:
     
  5. hicom

    hicom Well-Known Member

    Joined:
    May 23, 2003
    Messages:
    272
    Likes Received:
    0
    Trophy Points:
    16
    After you change permissions and user/group you need to re-install frontpage extensions
     
  6. deddy

    deddy Well-Known Member

    Joined:
    Oct 13, 2003
    Messages:
    131
    Likes Received:
    0
    Trophy Points:
    16
    I re-installed Frontpage in different versions e.g. 5.0.1 and
    5.1.0

    The problem still persists.

    I would say the problem belongs to the Frontpage module =
    FrontPage/5.0.2.2634.

    Is there a way to downgrade or change this module?
     
  7. deddy

    deddy Well-Known Member

    Joined:
    Oct 13, 2003
    Messages:
    131
    Likes Received:
    0
    Trophy Points:
    16
    What I said above is correct.

    On one of our RH 8.0 cPanel server is
    Frontpage version: 5.0.2.2623 installed
    and FP publishing is working properly there.

    On all our RH 9 cPanel server is version :
    5.0.2.2634 installed and FP publishing fails.

    Therefore, it is definitively a RH 9/Frontpage
    5.0.2.2634 problem :(
     
  8. Planet_Master

    Planet_Master Well-Known Member

    Joined:
    Apr 18, 2002
    Messages:
    233
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    New Yorker
    Its true FP is broke with Apache 1.3.29. I havent had Fp for about 20 clients in weeks. I have had to tell them to either FTP there files or send me a zip and I will install but this is only a temporary fix. They are getting frustrated and I already lost one customer. The thing that really pisses me off is that I waited all weekend for an edge build hoping that maybe they were working on a fix and they release 98,99 which is basically worthless. I too have RH9 and have tried every so called fix in this forum and over at ev1 and its all a sham.

    FP is broken so acknowledge this and fix it for christ sake!
     
  9. Daniel

    Daniel Well-Known Member

    Joined:
    Aug 13, 2001
    Messages:
    165
    Likes Received:
    0
    Trophy Points:
    16
    Cpanel we need a fix for this. It's been over a month since I opened a ticket.
     
  10. jackal

    jackal Well-Known Member
    PartnerNOC

    Joined:
    Feb 23, 2002
    Messages:
    708
    Likes Received:
    0
    Trophy Points:
    16
    We are running 8.5.4 edge 99 and we unistalled extensions and installed again and problems seem to be fixed.
     
  11. Daniel

    Daniel Well-Known Member

    Joined:
    Aug 13, 2001
    Messages:
    165
    Likes Received:
    0
    Trophy Points:
    16
    I upgraded to E99 but I still get the same error when installing frontpage.
     
  12. deddy

    deddy Well-Known Member

    Joined:
    Oct 13, 2003
    Messages:
    131
    Likes Received:
    0
    Trophy Points:
    16
    Daniel,

    could you please tell us what local FrontPage
    version you are using ?

    FP 97, 98, 2000, 2002 or 2003.

    Thank you !
     
  13. Daniel

    Daniel Well-Known Member

    Joined:
    Aug 13, 2001
    Messages:
    165
    Likes Received:
    0
    Trophy Points:
    16
    I'm using 2002 but frontpage ext will not install on the account at all. I get a file not found error wile it's chmoding the files.
     
  14. deddy

    deddy Well-Known Member

    Joined:
    Oct 13, 2003
    Messages:
    131
    Likes Received:
    0
    Trophy Points:
    16
    Daniel,

    that seems to be a different problem.

    It looks like FP extensions are not or
    not properly installed on your server.

    First of all check the installation by
    rpm -q frontpage

    If installed check the permissions and
    owner/groups of /usr/local/frontpage/*
    and whether version5.0 directory is
    installed and it's files.

    If the /usr/local/frontpage directory is
    damaged or if there are files missing
    remove this directory by

    rm -rf frontpage

    Before you can do that you have to
    chattr -RV -AacDdijsSu fpexe, otherwise
    you are unable to remove that directory.

    After that removal use
    rpm -e frontpage
    to remove the RPM.

    Now your system should be cleaned
    in case of FP extensions.

    Next download from cpanel.net the
    Frontpage*. sea file and set up again
    these extensions, which will get compiled
    automatically.

    As soon as it finished re-install the
    FP extension to all requested domains
    by WHM. Now it should work properly.

    If you are not satisfied with the Apache/
    PHP 4.3.3 compilation simply use "update
    Apache" within your WHM and choose such
    features like GD, IMAP, PostgreSQL ...
    you'd like to have installed and compiled
    on your system.

    I hope this helps.
     
  15. MetalAges

    MetalAges Member

    Joined:
    Jul 16, 2003
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    I am also dead in the water with FP 2002 users and discovering this thread I now know why. Please please can we get a fix for this? My particular FP clients are knuckleheads as it is so trying to explain to them why and what they have to do in place will be pretty time consuming. Anyone found any workarounds since?
     
Loading...

Share This Page