The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Frontpage error > server is not a valid virtual server.

Discussion in 'General Discussion' started by Envision5000, Jul 13, 2005.

  1. Envision5000

    Envision5000 Active Member

    Joined:
    Jul 5, 2005
    Messages:
    37
    Likes Received:
    0
    Trophy Points:
    6
    When trying to install frontpage extensions I get this error.

    Using Frontpage 5.x!
    Error: 'www.2-fast.org:80' server is not a valid virtual server.
    Invalid argument

    Can anyone help me out with this?
     
  2. linux-image

    linux-image Well-Known Member

    Joined:
    Jun 8, 2004
    Messages:
    1,192
    Likes Received:
    1
    Trophy Points:
    38
    Location:
    India
    cPanel Access Level:
    Root Administrator
    does this domain has a valid entry at the httpd.conf ?
     
  3. GTFO

    GTFO Active Member

    Joined:
    Aug 8, 2005
    Messages:
    35
    Likes Received:
    0
    Trophy Points:
    6
    Im interested in this problem as well. I am having this problem too. Any update on this situation ?
     
  4. nyjimbo

    nyjimbo Well-Known Member

    Joined:
    Jan 25, 2003
    Messages:
    1,125
    Likes Received:
    0
    Trophy Points:
    36
    Location:
    New York
    Are any of you seeing weird errors on creating a new account with Frontpage extensions. I seem to be getting errors on the system console and whm, I put in a ticket for it but the fellow working on it seems to busy right now. I am getting:

    In the WHM interface as you install:

    ..snip...
    Attempting to install FrontPage extensions...
    Building site conf for www.xxxxx.com...Done
    Note: Local version of Apache must use the FrontPage Apache patch.
    Starting install, port: 80.

    Creating web http://www.xxxxx.com.
    Chowning Content in service /.
    Cannot chown content: user xxxxx does not exist.
    Install completed.
    Setting Password
    Frontpage passthough auth enabled!


    FrontPage extensions are currently: installed
    ... snip..

    Of course the "xxxxx" above is a name not the x's.

    On the servers console it spits out at the same time:

    ./owsadm.exe: /etc/spwd.db ..permission denied

    Not sure whats goin on. I am using the 10.6.0-C61 build on a Freebsd box.
     
  5. MattDr2

    MattDr2 Well-Known Member
    PartnerNOC

    Joined:
    Feb 19, 2003
    Messages:
    84
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Norman, OK
    Did you ever get this fixed? I have a website reporting the same issue.
     
  6. linux-image

    linux-image Well-Known Member

    Joined:
    Jun 8, 2004
    Messages:
    1,192
    Likes Received:
    1
    Trophy Points:
    38
    Location:
    India
    cPanel Access Level:
    Root Administrator
    check if the User and Group field are there at the apache conf for the domain in question.
     
  7. ccccanada

    ccccanada Well-Known Member

    Joined:
    Jan 17, 2003
    Messages:
    279
    Likes Received:
    0
    Trophy Points:
    16
    Is there any resolution for this I am having the same problem

    Attempting to install FrontPage extensions...
    Error: 'www.xxxxxxxxxx.com:80' server is not a valid virtual server.
    Setting Password
    Frontpage passthough auth enabled!


    FrontPage extensions are currently: not installed
     
  8. balakrishnan

    balakrishnan Member

    Joined:
    Sep 13, 2004
    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    India
    is there any fix for this ?
    I am having the same problem too
     
  9. lagoth

    lagoth Member

    Joined:
    Apr 5, 2003
    Messages:
    24
    Likes Received:
    0
    Trophy Points:
    1
    about the error on /etc/spwd.db I got the same error too. i changed the permissions on spwd.db to 604 and everything went fine. BUT thats not a solution!

    ===============================
    Starting install, port: 80.
    Created: 01 Dec 2005 11:28:40 -0000
    Version: 5.0.2.2634
    Server extensions already installed on port 80.
    Reverting to upgrade.

    Starting upgrade, port: 80.

    Created: 01 Dec 2005 11:28:40 -0000
    Version: 5.0.2.2634
    Chowning Content in service /.
    Port 80: Upgrade completed.
    Upgraded Version: 5.0.2.2634.
    Setting Password
    Frontpage passthough auth enabled!
    ==============================


    Anyone know why owsadm.exe cannot access spwd.db with out giving swpd.db world read access!?

    if permissions are 600 then it gets "cannot chown contect in service no user XXXXX"
     
  10. Drew Nichols

    Drew Nichols Well-Known Member

    Joined:
    May 5, 2003
    Messages:
    96
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    SC
  11. ozirisno1

    ozirisno1 Member

    Joined:
    Nov 12, 2005
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    Does anyone know how to apply the patch they are mentioning in bugzilla?
     
  12. kship

    kship Member

    Joined:
    Oct 29, 2004
    Messages:
    21
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    HUNTSVILLE, TEXAS
    I am having the same problem...mine started on certain domains after a server migration using the migration tools from one whm to another...not all domains are doing this though...only a handful....any specific instructions on a fix is greatly appreciated!

    Thanks,
    Ken
     
  13. Drew Nichols

    Drew Nichols Well-Known Member

    Joined:
    May 5, 2003
    Messages:
    96
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    SC
    Editing the httpd.conf file to remove the SSL entry (I believe, double check the forum / bugzilla) fixes it.
     
  14. Gnomercy

    Gnomercy Well-Known Member
    PartnerNOC

    Joined:
    Sep 4, 2002
    Messages:
    80
    Likes Received:
    0
    Trophy Points:
    6
    Same issue here. Can't remove the SSL definition from httpd.conf because the site uses SSL and would go nuts if I took it off. User and Group fields are present in the httpd.conf entry. I've recompiled apache, to no avail. I'd attribute it to a server migration, but the migration done on this box was over 2 months ago and we've been able to remove and reinstall frontpage extentions on this account since the migration; now, however, we're getting the error that it's not a valid virtual server.

    Checked /usr/local/frontpage and the www.domain.com:80.cnf file is there, but incomplete. Uninstalling frontpage removes the file, reinstalling puts it back in the same, broken, form. Domain is on a dedicated IP, so I modified an existing test account on the server to use a dedicated IP as well, and am able to remove and reinstall FPE's with no trouble.

    Quite a distressing issue.


    EDIT: Ok, after restarting my brain, I commented out the SSL definition, restarted apache and did manage to get FPE's installed on this domain. Not ideal, but it works.
     
    #14 Gnomercy, Mar 4, 2006
    Last edited: Mar 4, 2006
Loading...

Share This Page