The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Frontpage Problems

Discussion in 'General Discussion' started by WilliamE, May 23, 2005.

  1. WilliamE

    WilliamE Well-Known Member

    Joined:
    May 14, 2004
    Messages:
    52
    Likes Received:
    0
    Trophy Points:
    6
    Hey,

    I've beat my head agains the wall with this problem and our noc isn't being that much help at this time so going to see if anybody here ran into this.

    Basically right now Frontpage on the server it can't connect or modify anything. On the domains we're testing with (it appears to be server wide problem) we've reinstalled the extensions several times through the whm, cpanel and manually on the server.

    The error being received is:
    Error: FrontPage requires that the AllowOverride option be set to something other than "None" (typically set in access.conf). "All" is the preferred AllowOverride option for the document root.

    And/or doesn't bring up a login box, just gives generic error when trying to connect with Frontpage. The AllowOverride is there and we also manually added it to the httpd.conf as a directive for their virtual host to make certain.

    Suexec is enabled on the server, disabling it appeas to allow it to work, however it was working with it on before and is working on other servers with suexec and frontpage installed.

    Any ideas?

    Thanks!
     
  2. dave9000

    dave9000 Well-Known Member

    Joined:
    Apr 7, 2003
    Messages:
    891
    Likes Received:
    1
    Trophy Points:
    16
    Location:
    arkansas
    cPanel Access Level:
    Root Administrator
    make sure your httpd.conf is configured like this

    # First, we configure the "default" to be a very restrictive set of
    # permissions.
    #
    <Directory />
    Options All
    AllowOverride All
    </Directory>

    #
    # Note that from this point forward you must specifically allow
    # particular features to be enabled - so if something's not working as
    # you might expect, make sure that you have specifically enabled it
    # below.
    #

    #
    # This should be changed to whatever you set DocumentRoot to.
    #
    <Directory "/usr/local/apache/htdocs">

    #
    # This may also be "None", "All", or any combination of "Indexes",
    # "Includes", "FollowSymLinks", "ExecCGI", or "MultiViews".
    #
    # Note that "MultiViews" must be named *explicitly* --- "Options All"
    # doesn't give it to you.
    #
    Options All MultiViews

    #
    # This controls which options the .htaccess files in directories can
    # override. Can also be "All", or any combination of "Options", "FileInfo",
    # "AuthConfig", and "Limit"
    #
    AllowOverride All

    #
    # Controls who can get stuff from this server.
    #
    Order allow,deny
    Allow from all
    </Directory>
     
  3. WilliamE

    WilliamE Well-Known Member

    Joined:
    May 14, 2004
    Messages:
    52
    Likes Received:
    0
    Trophy Points:
    6
    Hey,

    Yes we already have those settings on the server in the httpd.conf. Thanks!
     
  4. dave9000

    dave9000 Well-Known Member

    Joined:
    Apr 7, 2003
    Messages:
    891
    Likes Received:
    1
    Trophy Points:
    16
    Location:
    arkansas
    cPanel Access Level:
    Root Administrator
    just for the hell of it

    go into /home and delete the cpapachebuild dir and rerun /scripts/easyapache

    we had a corrupted build that php and frontpage would not co exist together

    then once thats done reinstall fp extensions for the web

    if this still doesn't work then delete all the _vti* dir and all the .htaccess files in the web and reinstall the extensions for that web
     
Loading...

Share This Page