The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

FrontPage Renames index.htm to "\" at publish

Discussion in 'General Discussion' started by SonServers, Dec 18, 2004.

  1. SonServers

    SonServers Well-Known Member

    Joined:
    Oct 24, 2001
    Messages:
    94
    Likes Received:
    0
    Trophy Points:
    6
    I have a weird issue with FrontPage on my FreeBSD and Cpanel stable server. I've searched and not found a similar thread. I've had three new customers over the last few weeks using FrontPage with this same issue.

    When FrontPage publishes the site, the local "index.htm" page is being renamed to "\" on the server side. The local version is still called "index.htm". FrontPage thinks they are the same file but yet displays the remote file as "\".

    In one case, the customer is using FP 2003. She was able to rename the file on the server called "\" as "index.htm" and that fixed her problem. She got a warning message asking of she really wanted to rename that file. She did, and it worked. Her index page now publishes correctly.

    In the most recent case, the customer is using FP 2000. He was not able to rename that server-side file through FP 2000. If I rename it under SSH, it breaks the page extensions. I copied the "\" file to "index.htm", deleted the "\" file and had him republish. The "\" file comes back and the "index.htm" file I copied is broken (no navigation, backgrounds, etc.). I have Apache set to also recognize "home.htm" as a first page so I had him make a copy of his "index.htm" page as "home.htm" and that page comes up and works. Not a fix, but a work-around.

    The third customer somehow fixed it himself. He just said a friend helped him and he didn't know what was done to solve it.

    Has anyone else seen this? Any ideas what may be causing it? Would you suspect this is a FrontPage issue, user error, or a server extensions issue? I don't have FP myself, but where this has happened to three people now, it seems to be a real issue.

    Thoughts?
     
  2. SonServers

    SonServers Well-Known Member

    Joined:
    Oct 24, 2001
    Messages:
    94
    Likes Received:
    0
    Trophy Points:
    6
    At the time of this reply, I see that no one has read this thread other than the one time by me when it was posted. I will update it now for future search results.

    I found the problem . . . and I caused it myself.

    I spent a few hours Googling for this type of problem. I could not find the exact same problem, but I learned of a "feature" in FrontPage I didn't know existed. It seems that when FrontPage publishes, it reads the Apache config file and looks at the "DirectoryIndex" settings. By doing that, when it publishes, it will look to see if your "home" page is a file name that is listed in the httpd.conf "DirectoryIndex" setting. If it is not, it will rename your home page to one that is listed.

    I suppose this is a helpful feature for those that are new to web building and have named their home page somehthing like "My First Home Page Site.htm".

    A while ago, I was editing the "DirectoryIndex" setting in httpd.conf. To make it easier to read, group, organize, save for backup, and edit from the command line, I included the backslash escape character and a few line returns. After doing this, rather than one long line that was longer than my editor's screen, my "DirectoryIndex" looked like:

    DirectoryIndex \
    index.htm index.html index.php \
    default.htm default.html default.php \
    home.htm etc. etc. \

    Apache on *nix, sees this as one long line and is perfectly fine with that, but apparently FrontPage couldn't read past the first "\". Thus, when publishing, FrontPage thought the "home" page needed to be named "\" so it could be found by Apache.

    I'm just happy to have found the problem. Hopefully, this will help someone in a search someday with a similar FrontPage publishing problem. :)
     
Loading...

Share This Page