Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

frustrating mysql issue after upgrading to 5.6

Discussion in 'Database Discussion' started by Bashed, Apr 7, 2014.

  1. Bashed

    Bashed Well-Known Member

    Joined:
    Dec 18, 2013
    Messages:
    109
    Likes Received:
    3
    Trophy Points:
    18
    cPanel Access Level:
    Root Administrator
    Upgraded MySQL from 5.5 to 5.6

    Found out that "STRICT_TRANS_TABLES,NO_ENGINE_SUBSTITUTION" becomes standard in MySQL 5.6 (not even in my.cnf file). So, in my.cnf I added:

    sql_mode="TRADITIONAL" and restarted mysql. Didn't fix the issue. Also tried this, same.
    sql_mode="TRADITIONAL,NO_AUTO_CREATE_USER"

    EDIT: JUST FOUND A FIX.

    There is a my.cnf in /usr/my.cnf that had the strict enabled rule. I changed it to:

    sql_mode=NO_ENGINE_SUBSTITUTION
     
    #1 Bashed, Apr 7, 2014
    Last edited: Apr 7, 2014
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    43,711
    Likes Received:
    1,791
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    I am happy to see you were able to find a solution. Thank you for updating us with the outcome.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice