The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

ftp access via browser, is it possible ?

Discussion in 'General Discussion' started by raylin, Mar 10, 2003.

  1. raylin

    raylin Active Member

    Joined:
    Sep 9, 2001
    Messages:
    26
    Likes Received:
    0
    Trophy Points:
    1
    I knew it works for a FTP account , say user@domain.com, to FTP login via ftp client such as CuteFTP and WS_FTP.

    But is it possible to do FTP access via a browser like I.E. ?
    (Main accoount is fine , but not for a FTP account like user@domain.com)

    I tried to type ftp://domain.com at location field above I.E.
    and then entered username: user@domain.com and password,
    but failed to connect.

    Any ideas ?
     
  2. Craig

    Craig Well-Known Member

    Joined:
    Aug 10, 2001
    Messages:
    171
    Likes Received:
    0
    Trophy Points:
    16
  3. raylin

    raylin Active Member

    Joined:
    Sep 9, 2001
    Messages:
    26
    Likes Received:
    0
    Trophy Points:
    1
    Craig, thanks for your suggestion, but no luck, I can not pass the verification:

    After typing ftp://user:domain.com@ftp.yourdomain.com ,
    IE asked username and password.
    I entered user:domain.com for username and my password.
    Failed.
    Then I entered user@domain.com for username and my password.
    Failed again.

    Does IE accept username like user@domain.com ?
     
  4. dgbaker

    dgbaker Well-Known Member
    PartnerNOC

    Joined:
    Sep 20, 2002
    Messages:
    2,578
    Likes Received:
    3
    Trophy Points:
    38
    Location:
    Toronto, Ontario Canada
    cPanel Access Level:
    DataCenter Provider
  5. raylin

    raylin Active Member

    Joined:
    Sep 9, 2001
    Messages:
    26
    Likes Received:
    0
    Trophy Points:
    1
    Please keep in mind:
    the "username" is not the main account,
    it is just a ftp account created for an IP-less VirtualHost.
    I believe I should use "username@domain.com"
    as ftp username to login FTP server (am I right?).

    Anyway, I tried:

    ftp://username:password@domain.com
    ftp://username@domain:password@domain.com

    Both ways failed to login FTP server.

    The problem for 1st way is that "username" is not main account, and for 2nd way there are 2 @ making IE confused.
     
  6. Juanra

    Juanra Well-Known Member

    Joined:
    Sep 22, 2001
    Messages:
    777
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Spain
    #6 Juanra, Mar 10, 2003
    Last edited: Mar 10, 2003
  7. raylin

    raylin Active Member

    Joined:
    Sep 9, 2001
    Messages:
    26
    Likes Received:
    0
    Trophy Points:
    1
    No luck. MSIE's response:
    I think this "problem" can be solved if CPanel could add usernames with a + sign in addition to usernames with an @ sign as Juanra said.
     
  8. adun

    adun Registered

    Joined:
    Jul 20, 2003
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    I'm having this problem too, except i'm trying to get it in an iframe. any ideas on how to connect this way?

    thanks,
    adun

    cPanel.net Support Ticket Number:
     
  9. nanabite

    nanabite Active Member

    Joined:
    Jun 27, 2003
    Messages:
    41
    Likes Received:
    0
    Trophy Points:
    6
    Try changing the "Use Passive FTP" option in Options > Advanced.

    cPanel.net Support Ticket Number:
     
  10. NetX

    NetX Well-Known Member

    Joined:
    Jun 18, 2003
    Messages:
    177
    Likes Received:
    0
    Trophy Points:
    16
    With the format of users in cpanel "user@domain.com" is not possible login via IE. I suggest you use a FTP web based program like WebFTP 1.4, and your users will access their ftp accounts via web without problems ;)

    cPanel.net Support Ticket Number:
     
  11. Trel

    Trel Well-Known Member

    Joined:
    Apr 9, 2003
    Messages:
    116
    Likes Received:
    0
    Trophy Points:
    16
    actually unless you're your own host, I'd ask them. Before I switched hosts, the old host had made it so you couldn't connect to FTP via internet explorer.

    cPanel.net Support Ticket Number:
     
  12. jackal

    jackal Well-Known Member
    PartnerNOC

    Joined:
    Feb 23, 2002
    Messages:
    708
    Likes Received:
    0
    Trophy Points:
    16
  13. goodmove

    goodmove Well-Known Member

    Joined:
    May 12, 2003
    Messages:
    624
    Likes Received:
    0
    Trophy Points:
    16
    What username did you use to logon?
     
  14. jackal

    jackal Well-Known Member
    PartnerNOC

    Joined:
    Feb 23, 2002
    Messages:
    708
    Likes Received:
    0
    Trophy Points:
    16
    username for the account

    cPanel.net Support Ticket Number:
     
  15. goodmove

    goodmove Well-Known Member

    Joined:
    May 12, 2003
    Messages:
    624
    Likes Received:
    0
    Trophy Points:
    16
    So you used:

    ftp://joe@domain.com
    username: joe@domain.com
    password: joe's password

    And you were able to logon?
     
  16. jackal

    jackal Well-Known Member
    PartnerNOC

    Joined:
    Feb 23, 2002
    Messages:
    708
    Likes Received:
    0
    Trophy Points:
    16
    Registered: Feb 2002
    Location:
    Posts: 276
    yep

    go to internet settings in control panel then advanced tab make sure this is checked.

    Enable folder view for ftp sites


    ftp://username@yourdomain.net
    window pops up with username installed in field just insert password

    cPanel.net Support Ticket Number:
     
    #16 jackal, Aug 3, 2003
    Last edited: Aug 3, 2003
  17. nanabite

    nanabite Active Member

    Joined:
    Jun 27, 2003
    Messages:
    41
    Likes Received:
    0
    Trophy Points:
    6
  18. Bright

    Bright Member

    Joined:
    Jan 9, 2003
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    :mad: Is this issue ever going to be resolved, the only way we can get this to work for our clients is to do what is suggested here by asmithjr

    http://forums.cpanel.net/showthread.php?s=&threadid=7429&perpage=15&highlight=ftp login&pagenumber=2

    This is a total imposition on our clients because they have to email us every time an add-on ftp account is created so we can manually change the entry in psswd.vhosts for them so they and/or their clients can have access to their ftp accounts via a web browser.

    Has any one come up with a fix that is automated to alleviate the time that is spent doing this manually, this is just far too time consuming when you start talking hundreds of accounts.

    PS Warning: I have just thought, the fix that asmithjr describes may be a security risk due to the possiblity of two clients having the same user name and pointing to the same ftp account? Would I be right in assuming this to be the case and if so, it only highlites how important it is to resolve this ASAP.

    cPanel.net Support Ticket Number: yeah right lol
     
    #18 Bright, Aug 25, 2003
    Last edited: Aug 25, 2003
  19. cass

    cass Well-Known Member

    Joined:
    Jul 17, 2002
    Messages:
    354
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Argentina/USA/Mexico
  20. farago

    farago Registered

    Joined:
    Feb 17, 2004
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    ISSUE: Internet Explorer doesn't show any login box.

    Found this fix -

    Microsoft internet explorer needs to have the following accommodations in order to display the pop up window asking forusername and password.

    ISSUE: Internet Explorer doesn't show any login box.

    SOLUTION: IE does a very strange trick to detect whether an FTP serverdoes accept anonymous connections or not. Basically, it connects to the serverand logs in as 'anonymous'. But if you say 'no' at this point, it drops theconnections with an error. You have to say 'ok, anonymous users are allowed'and then, when a dummy password ('IE@') is sent, you say 'ah ehm... finally...no... anonymous users aren't allowed' . Silly. To play that game, you must runpure-ftpd with the -E (non-anonymous server) and -b (compatibility with brokenclients) flags. Then, the magic popup will show up. But please note that IE(and browsers at large) are usually bad FTP clients.

    Check that the maxnumber of connections (either per user or per IP) is at least 2. IE needs twoconnections to connect to an FTP server.
     
Loading...

Share This Page