The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

ftp accounts not letting me in

Discussion in 'General Discussion' started by SharonGilmore, May 10, 2011.

  1. SharonGilmore

    SharonGilmore Member

    Joined:
    May 5, 2011
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    1
    I've set up a few ftp accounts under cPanel, but I can't use them to log in. I've tried FireFTP and Filezilla, but keep being told "Authentication Failed".

    I've checked the password, and it's fine, but I was also given a ppk / pem key, and I'm not sure whether to use it or not (it doesn't work either way).

    Here's what I'm doing:

    > Set up ftp account from Control Panel
    > In FireFTP,
    host: ftp.mysite.com
    id: me@mysite.com
    password: xxxxxxxx​
    Connection (I've tried all the options, but currently it's like this):
    Passive Mode checked & greyed out
    IPv6 not checked
    Security: SFTP
    Port: 22
    Private Key: Path/to/private/key​
    Advanced tab: left at default, nothing filled in

    What am I doing wrong? Thanks!
     
  2. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    For sFTP, you can only use the cPanel username account rather than any created FTP accounts. For the username for that cPanel username account, you would only use the username itself (the same you use to log into cPanel) rather than username@domain.com for the username. It appears you are using @domain.com as part of the username, which will not work.

    Of note, I would not suggest using sFTP but rather TLS for authenticating. Both are secure methods and TLS does not require a jailed shell to function.
     
  3. SharonGilmore

    SharonGilmore Member

    Joined:
    May 5, 2011
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    1
    Thanks for that. I need to restrict the directories the ftp user has access to, so I can't give them cPanel access. Basically, they should be able to make changes to the files in one directory only (and the sub directories of that).

    It sounds like I need to use TLS. However, it's still not working.

    I have:
    Host: ftp.pubfish.com
    Login: sharon (this is what I created for the ftp user in the control panel)
    Password: xxxxx
    Passive Mode: checked and greyed out
    IPv6: not checked
    Security: Auth TLS
    Port: 21
    and everything else blank.

    Do i need to do something else?

    I don't get an error with this - it just changes 'Connect' to 'Disconnect', waits a few seconds, and then goes back to 'Connect'.

    Thanks for any help you can give.
     
  4. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    If you are using a cPanel username account (the cPanel login for the account), then it is only username. If you are using a created FTP user account, you do then use username@domain.com, so for TLS please change to username@domain.com if this is a created FTP account (not the cPanel username account).

    Also, which type of TLS are you using: FTPES - FTP over explicit TLS/SSL or FTPS - FTP over implicit TLS/SSL ? I ask as you would need to use FTPES rather than FTPS under cPanel's pure-ftpd system. I know this option is available in FileZilla, so please test with FileZilla.

    Next, please change the Host to pubfish.com rather than adding ftp. to the beginning of it.
     
  5. SharonGilmore

    SharonGilmore Member

    Joined:
    May 5, 2011
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    1
    Ok, got Filezilla, entered the info, and still can't get in. Here's what I get:

    I've set:
    Host: pubfish.com
    Port: 21
    Protocol: FTP
    Encryption: Require explicit FTP over TLS (also tried implicit, but that didn't work either)
    Logon Type: Normal
    User: shaorn@pubfish.com
    Password: xxxxxx

    Do I need any kind of encryption key or anything like that?

    And which logon type should I use? Normal? Or something else?

    Thanks again for your time and patience!
     
  6. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    It appears that whoever handles the server does not have port 21 opened for FTP. I tried a simple telnet to that port and it times out:

    Code:
    telnet 50.17.181.62 21
    Port 22 is opened, because that is the SSH port which can also be used for sFTP. As such, it appears only sFTP is going to be allowed on the machine. Created users cannot use sFTP, so you would need to contact your hosting provider if you are not the root administrator of the machine to open up regular FTP on port 21 where they can set it to only allow TLS encrypted FTP in WHM > FTP Server Configuration > TLS Encryption Support with the "Required (Command/Data)" option in the dropdown. If they will not do so, then you would not be able to provide access for created FTP users.
     
Loading...

Share This Page