The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

FTP anonymous access

Discussion in 'General Discussion' started by AVL, Nov 20, 2003.

  1. AVL

    AVL Member

    Joined:
    Nov 5, 2003
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Our client wants to open anonymous FTP access to their /public_ftp directory with the
    ability to anonymously upload files to /public_ftp/incoming. This is supposed to be done
    by checking corresponding cPanel's check boxes in Account Settings -> FTP Manager ->
    Anonymous FTP Control. "Allow anonymous access to ftp://ftp.<domainname>/" and "Allow
    anonymous upload to ftp://ftp.<domainname>/incoming/" buttons should do that.

    In fact, anonymous access is not allowed, instead, you can log in using
    "anonymous@<domainname>" name as username and empty password (which is not an anonymous
    login). Then you will be able to upload files to /incoming, but you cannot see its
    contents (permission set to /incoming allows writing but doesn't allow reading!). As for
    me, this is ridiculous.

    Is there a standart way to allow real anonymous access to /public_ftp folder?
     
  2. @home

    @home Well-Known Member

    Joined:
    Nov 5, 2003
    Messages:
    119
    Likes Received:
    0
    Trophy Points:
    16
    cPanel Access Level:
    Root Administrator
    Did jou check Allow anonymous ftp access in WHM also?
     
  3. AVL

    AVL Member

    Joined:
    Nov 5, 2003
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    yes

    WHM/Tweak FTP Settings:
    Currently Installed Ftp Server: proftpd
    Anonymous Ftp is currently: enabled
     
  4. I-Web

    I-Web Well-Known Member

    Joined:
    Jul 7, 2003
    Messages:
    138
    Likes Received:
    0
    Trophy Points:
    16
    i have just found that my server had anonymous ftp access switched on (we dont allow it)

    I went into whm, and disabled it, it said restarting ftp server etc, but when i checked the anonymous ftp server was still running,

    I manually edited

    /etc/vsftpd/vsftpd.conf and changed

    anonymous_enable=YES

    to

    anonymous_enable=NO
    I guess if you change it the other way round it should work, but it appears that the WHM setting is not changing this like it should

    :S
     
  5. AVL

    AVL Member

    Joined:
    Nov 5, 2003
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Obviously, you run vsftpd as your FTP server. I have proftpd. And WHM only allows to choose between proftpd and pure-ftpd. I'm a little bit depressed, becuase it seems like I will need to play around with proftpd.conf, though WHM+cPanel should provide all the needed functionality.
     
  6. I-Web

    I-Web Well-Known Member

    Joined:
    Jul 7, 2003
    Messages:
    138
    Likes Received:
    0
    Trophy Points:
    16
    lmao... this is where i got confused.....

    I switch to pure-ftp as this bug with proftpd keep timing out had me running round in circles.....

    Then i switched back from pure-ftp to proftpd, and that was the only setting i could use to control the anonymous ftp setting, as far as i am aware (via WHM) i am using proftpd, and after i made that edit, i typed

    Service proftpd Stop
    Service proftpd Start

    And all was fine :)
     
  7. AVL

    AVL Member

    Joined:
    Nov 5, 2003
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    I restarted proftpd, it does not help.
     
  8. I-Web

    I-Web Well-Known Member

    Joined:
    Jul 7, 2003
    Messages:
    138
    Likes Received:
    0
    Trophy Points:
    16
    did you check that file?????

    etc/vsftp/vsftp.conf


    i know whm should sort it itself, but it worked for me... ;)
     
  9. AVL

    AVL Member

    Joined:
    Nov 5, 2003
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    I don't have this file. My guess is that you run an FTP server other than proftpd.
     
  10. I-Web

    I-Web Well-Known Member

    Joined:
    Jul 7, 2003
    Messages:
    138
    Likes Received:
    0
    Trophy Points:
    16
    sorry its /etc/vsftpd/vsftpd.conf
     
Loading...

Share This Page