Hostprofil

Member
Sep 10, 2013
17
0
1
cPanel Access Level
Root Administrator
Re: how to check remote ftpbackup

Hy, I installed cpanel on my VPS can not use ftp, remain so when I try to connect:
Command: TYPE I
Response: 200 Type set to I
Command: PASV
Response: 227 Entering Passive Mode.
Command: MLSD

Why?
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,913
2,205
363
Hello :)

It's likely you have firewall rules enabled that are blocking the passive FTP ports that are configured in:

Code:
/etc/pure-ftpd.conf
Check to ensure the following line is not disabled in the above file:

Code:
PassivePortRange 30000 35000
Then, ensure the above port range is not blocked in your firewall.

Thank you.
 

Hostprofil

Member
Sep 10, 2013
17
0
1
cPanel Access Level
Root Administrator
After you run the command /etc/pure-ftpd.conf I get this error


Code:
/etc/pure-ftpd.conf
/etc/pure-ftpd.conf: line 20: ChrootEveryone: command not found
/etc/pure-ftpd.conf: line 34: BrokenClientsCompatibility: command not found
/etc/pure-ftpd.conf: line 40: MaxClientsNumber: command not found
/etc/pure-ftpd.conf: line 46: Daemonize: command not found
/etc/pure-ftpd.conf: line 52: MaxClientsPerIP: command not found
/etc/pure-ftpd.conf: line 59: VerboseLog: command not found
/etc/pure-ftpd.conf: line 65: DisplayDotFiles: command not found
/etc/pure-ftpd.conf: line 71: AnonymousOnly: command not found
/etc/pure-ftpd.conf: line 77: NoAnonymous: command not found
/etc/pure-ftpd.conf: line 84: SyslogFacility: command not found
/etc/pure-ftpd.conf: line 98: DontResolve: command not found
/etc/pure-ftpd.conf: line 104: MaxIdleTime: command not found
/etc/pure-ftpd.conf: line 131: ExtAuth: command not found
/etc/pure-ftpd.conf: line 161: LimitRecursion: command not found
/etc/pure-ftpd.conf: line 167: AnonymousCanCreateDirs: command not found
/etc/pure-ftpd.conf: line 174: MaxLoad: command not found
/etc/pure-ftpd.conf: line 208: AntiWarez: command not found
/etc/pure-ftpd.conf: line 214: Bind: command not found
/etc/pure-ftpd.conf: line 234: Umask: command not found
/etc/pure-ftpd.conf: line 240: MinUID: command not found
/etc/pure-ftpd.conf: line 246: AllowUserFXP: command not found
/etc/pure-ftpd.conf: line 252: AllowAnonymousFXP: command not found
/etc/pure-ftpd.conf: line 260: ProhibitDotFilesWrite: command not found
/etc/pure-ftpd.conf: line 266: ProhibitDotFilesRead: command not found
/etc/pure-ftpd.conf: line 273: AutoRename: command not found
/etc/pure-ftpd.conf: line 279: AnonymousCantUpload: command not found
/etc/pure-ftpd.conf: line 304: AltLog: command not found
/etc/pure-ftpd.conf: line 370: MaxDiskUsage: command not found
/etc/pure-ftpd.conf: line 386: CustomerProof: command not found
/etc/pure-ftpd.conf: line 423: TLS: command not found
/etc/pure-ftpd.conf: line 429: TLSCipherSuite: command not found
root: PassivePortRange 30000 35000
-bash: PassivePortRange: command not found
[email protected] [~]# PassivePortRange 30000 35000
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,913
2,205
363
I did not post commands for you to enter directly via the command line. I simply placed the files and entries in code tags to make it easier for you to see what I was referencing. You have to view or edit files with an editor such as "vi".

Thank you.
 

Hostprofil

Member
Sep 10, 2013
17
0
1
cPanel Access Level
Root Administrator
Hello :)

It's likely you have firewall rules enabled that are blocking the passive FTP ports that are configured in:

Code:
/etc/pure-ftpd.conf
Check to ensure the following line is not disabled in the above file:

Code:
PassivePortRange 30000 35000
Then, ensure the above port range is not blocked in your firewall.

Thank you.
I not have this line in the file.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,913
2,205
363
You should see output like this if you are using Pure-FTPd:

Code:
 [~]# grep PassivePortRange /etc/pure-ftpd.conf
# PassivePortRange          30000 50000
Have you tried temporarily disabling your firewall rules to ensure that's not the cause of the problem?

Thank you.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,913
2,205
363
First, you need to check to see if you have a firewall management tool such as CSF installed already. Do you see that under the plugins menu in Web Host Manager? If so, you can disable it right from within the option.

Note: It seems like you may not be experienced with the command-line environment. It might be a good idea to consult with a qualified system administrator or read some tutorials on Linux in general to give you a better understanding of how it works.

Thank you.