The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

FTP - Connection timed out

Discussion in 'General Discussion' started by wisenerl, Mar 10, 2013.

  1. wisenerl

    wisenerl Member

    Joined:
    Sep 27, 2006
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    1
    Evening,

    Need a little help with this one. See the snippit below. I have a customer who can't get logged into FTP on the server, keeps getting the Connection timed out error.

    Passive ports are set on the pureftp config file, they are open in the firewall.

    I can connect using Flashfxp just fine (She is also using Flashfxp). I never get any errors connecting to it, but they can't get in, they were able to login a couple of days ago though.

    It's not I am getting an error code to work with either!

    Any suggestion as to what it could be?


     
  2. PlotHost

    PlotHost Well-Known Member

    Joined:
    Apr 29, 2011
    Messages:
    253
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    US
    cPanel Access Level:
    Root Administrator
    Twitter:
    Maybe she has a firewall/antivirus that blocks somehow the connection.
     
  3. Hostprofil

    Hostprofil Member

    Joined:
    Sep 10, 2013
    Messages:
    17
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Hello, welcome and I problem with this error below:

    Code:
    Command:	PASV
    Response:	227 Entering Passive Mode (188,240,231,188,142,41).
    Command:	MLSD
     
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,723
    Likes Received:
    660
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    It's likely you have firewall rules enabled that are blocking the passive FTP ports that are configured in:

    Code:
    /etc/pure-ftpd.conf
    Check to ensure the following line is not disabled in the above file:

    Code:
    PassivePortRange 30000 35000
    Then, ensure the above port range is not blocked in your firewall.

    Thank you.
     
  5. Hostprofil

    Hostprofil Member

    Joined:
    Sep 10, 2013
    Messages:
    17
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Hy, we next line:

    Code:
    # Port range for passive connections replies. - for firewalling.
    
    PassivePortRange          30000 50000
    Also does not connect, I get the same error
     
    #5 Hostprofil, Sep 11, 2013
    Last edited: Sep 11, 2013
  6. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,723
    Likes Received:
    660
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
  7. Hostprofil

    Hostprofil Member

    Joined:
    Sep 10, 2013
    Messages:
    17
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Not that I know use another firewall, how to check this please? Thank you.
     
  8. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,723
    Likes Received:
    660
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Which firewall do you use? Have you tried disabling it temporarily to see if that resolves the issue? Please provide as many details as possible in your replies so we can assist you.

    Thank you.
     
  9. Hostprofil

    Hostprofil Member

    Joined:
    Sep 10, 2013
    Messages:
    17
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    I used these commands and it`s work but can not access subdirectories.Is any danger for my server so leave them or put them back? Thanks

    Code:
    chkconfig iptables off
    service iptables save
    service iptables stop
     
  10. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,723
    Likes Received:
    660
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    That disables your firewall completely. You are welcome to use that method to resolve the issue if you prefer not to have any firewall rules enabled. It's odd that the issue still persists with subdirectories. Do you get the same error message?

    Thank you.
     
  11. Hostprofil

    Hostprofil Member

    Joined:
    Sep 10, 2013
    Messages:
    17
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    the problem persists only for subdirectories. aditionnaly i can't delete something from them if i want to. how can i make them work with the firewall active?
     
  12. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,723
    Likes Received:
    660
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    That sounds like it may be an issue with your FTP client. Try using a different FTP client to see if you experience the same results. You may want to install a third-party firewall such as CSF if you are not comfortable manually modifying your iptables firewall rules:

    ConfigServer Firewall

    Thank you.
     
Loading...

Share This Page