The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

FTP Connection Timed Out?

Discussion in 'General Discussion' started by pagedeveloping, Jul 17, 2007.

  1. pagedeveloping

    pagedeveloping Well-Known Member

    Joined:
    Jun 11, 2003
    Messages:
    219
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    New York
    I am running the latest 11 edge on cpanel and now having problems with PureFTP.

    Passive mode is off
    Passwords seems to work both ways
    Loging in goes directly to restricted directory /

    All seems to be fine and then I get a
    425 Could not open data connection to port 1262: Connection timed out

    This happens when trying to use Pro or Pure FTP programs.
    I have even tried force install on the pureftp
    I have stoped and started pureftp
    I do not use passive mode on the server.
    I even tried by turning off my firewall program.
    I have synch the passwords.

    Nothing seems to work at this point and I am very baffled over this.

    any one else having this issue.

    Thanks in advance for all input.
     
  2. pagedeveloping

    pagedeveloping Well-Known Member

    Joined:
    Jun 11, 2003
    Messages:
    219
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    New York
    Found The Fix!

    Well after searching through help files and this forum I finally found the fix for my problem.

    Much thanks to DuranDuran and csf instructions on how to work around this issue.

    "
    Well, this fix for me, maybe fix for others... In my case this is a APF/Monolithic kernel problem.

    Try this, in the /etc/pure_ftpd.conf uncoment the line

    #PassivePortRange 35000 35999

    And save. In the /etc/apf.conf change the line: ( I have csf and it explains it inside their config file)

    SET_MONOKERN="1" to SET_MONOKERN="0" (I have csf and was able to keep this set to 1)

    and put the Passive Port Range in the line IG_TCP_CPORTS
    "
     
Loading...

Share This Page