The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

FTP Connection Timeout

Discussion in 'General Discussion' started by morpheous, Jan 8, 2005.

  1. morpheous

    morpheous Member

    Joined:
    Dec 21, 2004
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    1
    Hi,

    I'm having problems with FTP on my server. Both ports 20 and 21 UDP/TCP are open, and i've tried this with Pure-FTPd and ProFTPd.

    Basically when i'm transferring files it'll randomly not send one and return the error 'Server disconnected. Connection timed out'.

    Any ideas why? Don't know what's causing it.

    Morph
     
  2. RegisterHosting

    Joined:
    Aug 21, 2004
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    1
    Same Problem here. I have use current build.
    Maybe bug.
     
  3. Finkinstein

    Finkinstein Well-Known Member

    Joined:
    Mar 21, 2003
    Messages:
    131
    Likes Received:
    0
    Trophy Points:
    16
    Same problem here too. Can't connect to FTP. If it doesnt timeout the directory won't list.
     
  4. fusioncroc

    fusioncroc Well-Known Member

    Joined:
    Sep 28, 2004
    Messages:
    261
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    U.K.
    this happens to me from time to time it keeps diconnecting every 3 minutes and timeouts
     
  5. dougvaughan

    dougvaughan Member

    Joined:
    Nov 26, 2004
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    1
    My ftp transfers time out like this too, especially when uploading lots of files or a big file. I am using 9.9.9 S15.
     
  6. chican0

    chican0 Well-Known Member

    Joined:
    Mar 26, 2003
    Messages:
    59
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Los Angeles
    Does anyone have any information on this issue? Having issue here as well.
     
  7. blackice

    blackice Active Member

    Joined:
    Dec 21, 2004
    Messages:
    40
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Oxfordshire UK
    i need a reply urgently please, this is driving my customers mad.

    Richard Oastler
     
  8. nerdzoll

    nerdzoll Well-Known Member

    Joined:
    Oct 4, 2004
    Messages:
    105
    Likes Received:
    0
    Trophy Points:
    16
    ditto

    I am having same problem, always have had it... thought it was my server. I am running release build 10.0.0. R-7

    any ideas?
     
  9. DigitalN

    DigitalN Well-Known Member

    Joined:
    Sep 23, 2004
    Messages:
    420
    Likes Received:
    1
    Trophy Points:
    18
    You need more than 20 / 21 open for passive ftp connections.

    Do you have any ports set within /etc/sysconfig/pure-ftpd or /etc/pure-ftpd.conf to allow these connections ie

    /etc/sysconfig/pure-ftpd

    --passiveportrange=50000:51000


    restart pure-ftpd and enable tcp connections to ports 50000 through 51000 within your firewall.

    Hope this helps.
     
  10. fusioncroc

    fusioncroc Well-Known Member

    Joined:
    Sep 28, 2004
    Messages:
    261
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    U.K.
    I have this:
    # Port range for passive connections replies. - for firewalling.

    # PassivePortRange 30000 50000

    But as its commented out and none of my other customers have problems , i think it only affects my computer
     
  11. DigitalN

    DigitalN Well-Known Member

    Joined:
    Sep 23, 2004
    Messages:
    420
    Likes Received:
    1
    Trophy Points:
    18
    The default setting can be used too (as posted above) - the default is PassivePortRange 30000-50000 - so you need to open all of those ports in your firewall if you have one.
    General rule is open twice the ports that you have clients, so you can use the default or restrict them to less ports, by defining the passive ports yourself.
     
    #11 DigitalN, Feb 28, 2005
    Last edited: Feb 28, 2005
Loading...

Share This Page