FTP connections Icon not showing on users cPanel

ok

  • ok

    Votes: 0 0.0%
  • Great

    Votes: 0 0.0%

  • Total voters
    0
Operating System & Version
Centos 7
cPanel & WHM Version
v94.0.3

tteam

Registered
Mar 22, 2021
2
0
1
Nigeria
cPanel Access Level
Root Administrator
Hi, i noticed the FTP connections icon is not showing on users cPanel.

We use PURE-FTPD on our server, we have tried upcp to be sure nothing is broken, however, the FTP accounts Icon is showing.

We have disabled and reenabled the ftp server.

Kindly assist further.
 

Tarak Nath

Well-Known Member
Mar 12, 2018
104
14
18
India
cPanel Access Level
Root Administrator
Is there any update? We are also facing same issue.

We have also noticed that "FTP Connections" icon is showing in older cPanel version 86.0.40. Please find the attached screenshot called "86.png" of the version 86.0.40.

But its not showing in the version 94.0.11, please find the attached screenshot called "94.png"

Please suggest.

Regards,
Tarak Nath
 

Attachments

ServerHealers

Member
Sep 21, 2015
11
10
53
India
cPanel Access Level
Root Administrator
This link is working: FTP Connections Not Displayed Properly

As shown in the above forum post please check if your /proc is mounted with "hidepid" option and that could be what causes this. It is a security feature and not recommended to disable it. ( More info: If "hidepid=2 - process files are invisible to non-root users. The existence of a process can be learned by other means, but its effective UID and GID is hidden. Hiding these IDs complicates an intruder's task of gathering information about running processes. )

But if it's that important for you or your customers ( do it at your own risk ), it is possible to disable "hidepid". This option is in sync with fs.proc_can_see_other_uid kernel parameter of CloudLinux. So, you can disable "hidepid" feature by changing fs.proc_can_see_other_uid values in sysctl.conf. ( Again, it is a security feature. So, NOT recommended to disable it. )