Osama Tariq

Well-Known Member
Nov 27, 2014
206
2
18
Lahore, Pakistan
cPanel Access Level
Root Administrator
Twitter
Code:
# /scripts/restartsrv_pureftpd
Waiting for “pureftpd” to restart ………warn [restartsrv_base] The 'pureftpd' service's PID file '/var/run/pure-ftpd.pid' did not appear after 10 seconds.

…warn [restartsrv_base] The 'pureftpd' service's PID file '/var/run/pure-ftpd.pid' did not appear after 10 seconds.

…warn [restartsrv_base] The 'pureftpd' service's PID file '/var/run/pure-ftpd.pid' did not appear after 10 seconds.

…failed.

Service Error
    (XID vv6ane) The “pureftpd” service failed to start.

Startup Log
    Starting pure-config.pl: [  OK  ]
    Starting pure-authd:

pureftpd has failed. Contact your system administrator if the service does not automagically recover.
 

waqas_websouls

Member
PartnerNOC
Dec 9, 2014
5
1
53
cPanel Access Level
Root Administrator
The reason for this error is that Pure-ftpd service doesn’t work with {CallUploadScript} set to (yes) in /etc/pure-ftpd.conf configuration file. That is because the pure-uploadscript service is not getting started while restarting the pure-ftpd service.

Run the following command via SSH for fix this issue:

# /usr/sbin/pure-uploadscript -B -r /etc/pure-ftpd.conf

Restart the service :

# /etc/init.d/pure-ftpd restart
 
  • Like
Reactions: cornishman33

arjanvr

Well-Known Member
Dec 13, 2013
113
1
18
cPanel Access Level
Root Administrator
Hello,

Sorry for bumping old threat

At every reboot i keep getting that ftp service failed and i run the fix mentioned here:

"Run the following command via SSH for fix this issue:

# /usr/sbin/pure-uploadscript -B -r /etc/pure-ftpd.conf

Restart the service :

# /etc/init.d/pure-ftpd restart"

and it works again but why do i need to do this after every reboot.. what can be the unline cause? I only have this on one vps.

Thanks
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,904
2,237
463
Hello @arjanvr,

Please post the output from the following command:

Code:
grep Call /etc/pure-ftpd.conf
Thank you.
 

garconcn

Well-Known Member
Oct 29, 2009
168
17
68
I've checked all my servers and only found "CallUploadScript no" on two servers, both servers having Imunify360 installed. Other servers without Imunify360 using default cpanel setting "#CallUploadScript yes". Can anyone confirm this on your servers?
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,904
2,237
463
Sorry for my extreme late response, i missed it somehow..

[~]# grep Call /etc/pure-ftpd.conf
CallUploadScript yes
[~]#
Hello @arjanvr,

I've seen this happen on systems that previously utilized a third-party application such as CXS. Upon removing the third-party application (which made use of /usr/sbin/pure-uploadscript) , the "CallUploadScript yes" value was left in-place. To solve the issue, you can modify or add "CallUploadScript no" in /var/cpanel/conf/pureftpd/main using the instructions at:

FTP FAQ - Version 68 Documentation - cPanel Documentation

I've checked all my servers and only found "CallUploadScript no" on two servers, both servers having Imunify360 installed. Other servers without Imunify360 using default cpanel setting "#CallUploadScript yes". Can anyone confirm this on your servers?
Hi @garconcn,

The default value in the Pure-FTP configuration file included with cPanel & WHM is as follows:

Code:
# CallUploadScript             yes
The "#" indicates the line is commented, and thus the option is disabled. It's likely your third-party application that's setting the value to "CallUploadScript no", however note that in either case the option is disabled.

Thank you.
 

Benjamin Biswas

Registered
Nov 10, 2018
3
1
3
Dhaka
cPanel Access Level
Root Administrator
The reason for this error is that Pure-ftpd service doesn’t work with {CallUploadScript} set to (yes) in /etc/pure-ftpd.conf configuration file. That is because the pure-uploadscript service is not getting started while restarting the pure-ftpd service.

Run the following command via SSH for fix this issue:

# /usr/sbin/pure-uploadscript -B -r /etc/pure-ftpd.conf

Restart the service :

# /etc/init.d/pure-ftpd restart
Thanks, it's working for me. Just need to change the restart command from /etc/init.d/pure-ftpd restart to service pure-ftpd restart (if i use your restart command then see "no such file or directory).
 
  • Like
Reactions: cPanelAnthony