The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

FTP Fails after 2GB

Discussion in 'General Discussion' started by RayT, Feb 25, 2003.

  1. RayT

    RayT Registered

    Joined:
    Feb 25, 2003
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Hey Folks,

    I have a user account created in WHM with unlimited disk space. I am transferring a website that is 50 GB to this server via ftp, but the session seems to fail after 2GB.

    The server has plenty of space for the site in /home

    Filesystem Size Used Avail Use% Mounted on
    /dev/sda6 2.0G 171M 1.7G 9% /
    /dev/sda1 787M 27M 720M 4% /boot
    /dev/sda8 88G 21G 63G 25% /home
    none 1.5G 0 1.4G 0% /dev/shm
    /dev/sda7 1011M 33M 927M 4% /tmp
    /dev/sda2 8.2G 5.9G 1.9G 75% /usr
    /dev/sda5 3.8G 570M 3.0G 16% /var

    As the origin server does not have enough space to tar up and hold 50 more GB, to move the site from my customers old server to his new account, I am using FTP with pipes to capture directories recursively, tar and zip them into a file, and write them remotely to the cPanel account (using ftp).

    put "| tar cvf - . | gzip " customer_website.tar.gz (50GB)

    from the server which I am sending from (to the cpanel account), I get the following message.

    pwd.xxx.com/
    pwd.xxx.com/.dsklk_0-ds-_s/
    pwd.xxx.com/.dsklk_0-ds-_s/add-passwd.cgi
    pwd.xxx.com/.dsklk_0-ds-_s/a_path.cgi
    pwd.xxx.com/
    pwd.xxx.com/fd_223sd_--_sd/
    pwd.xxx.com/fd_223sd_--_sd/add-passwd.cgi
    pwd.xxx.com/fd_223sd_--_sd/a_path.cgi
    pwd.xxx.com/
    pwd.xxx.com/sdwf-_efe-___fde/
    pwd.xxx.com/sdwf-_efe-___fde/add-passwd.cgi
    pwd.xxx.com/sdwf-_efe-___fde/a_path.cgi
    ########
    421 Service not available, remote server has closed connection.

    Anyone know of a 2GB file limit on cPanel, RedHat 8, or in the WHM?
     
  2. jimcarter

    jimcarter Well-Known Member

    Joined:
    Jun 30, 2002
    Messages:
    152
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    UK
    not that I know of, there might be,
    why not ssh into your box and then ftp to the site there and then use mget * to download all the files?
     
  3. RayT

    RayT Registered

    Joined:
    Feb 25, 2003
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    it won't capture the directory structure.. only the files in that directory.

    If someone knows of an mget command that can capture an entire directory structure, please share.
     
  4. ecoutez

    ecoutez Well-Known Member

    Joined:
    May 23, 2002
    Messages:
    152
    Likes Received:
    0
    Trophy Points:
    0
    Or just use scp or rsync as long as you have shell access on both sides. Much easier, encrypted, keeps directory structure and permissions (and ownership if UID/GIDs match).

    login to the new server
    cd ~username/public_html
    scp -pr username@oldserver.tld:~/public_html/* .

    or rsync -avz username@oldserver.tld:~/public_html/* .

    - Jason
     
  5. Donna

    Donna BANNED

    Joined:
    Feb 15, 2003
    Messages:
    88
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Toronto, Canada
    Might also wanna check the timeout settings on your ftp client and raise it. I get that problem sometimes when I'm uploading a huge file that takes a long time. Also use an ftp client that supports "resume failed downloads" and you should be able to reconnect and continue uploading.
     
  6. NeutralGold

    NeutralGold Well-Known Member

    Joined:
    Jun 5, 2002
    Messages:
    233
    Likes Received:
    0
    Trophy Points:
    16
    Seems thats something to do with proftpd, I dont know whats causing it or why, i just know it has something to do with proftpd, like in the post above, check the timeout. its happened on several servers ive had via ensim and cpanel, hasnt really ever been an issue for me unless i was backing up a site over 2 gb via ensim..

    btw, ensim sux ... ;)
     
  7. Nathan D.

    Nathan D. Well-Known Member

    Joined:
    Mar 21, 2004
    Messages:
    78
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Virginia
    I have this same problem. I need to remove this limit where ever it is. I use pure-ftp so it's not proftp. Maybe they both have the same problem though? This didn't happen on my last cpanel installation. I had to reinstall cPanel and now I can't upload over 2GB. Please give me information on this. This is really important.
     
  8. jester.ro

    jester.ro Well-Known Member
    PartnerNOC

    Joined:
    Feb 6, 2004
    Messages:
    304
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Bucharest, Romania
    cPanel Access Level:
    DataCenter Provider
    i think thephantom set things straight.
    there's a file-system limit on default linux instalations. you need to re-compile your kernel to get rid of that limit.


    if you can't do that, split the archive in volumes ( tar supports splitting i think, but you might have better luck with rar/unrar for linux www.rarlabs.com )
     
  9. Nathan D.

    Nathan D. Well-Known Member

    Joined:
    Mar 21, 2004
    Messages:
    78
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Virginia
    Could you explain in detail, step-by-step on how to change this limit and re-compile the kernel? I'd really appreciate it.
     
Loading...

Share This Page