The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

FTP Hangs for 10 seconds then goes

Discussion in 'General Discussion' started by zartanch, Mar 25, 2003.

  1. zartanch

    zartanch Member

    Joined:
    Mar 25, 2003
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    Hi,

    FTP used to be lickedy split in Cpanel... then all of a sudden (might be upgrade) when I or anyone connects to the Cpanel FTP, it hangs............. then connects.

    Then if you try and upload everything it hangs........................................... and then uploads it.

    I've heard it's because Cpanel has to "think" to see where the user is going... but that is weird, never happened before in Cpanel or Windows.

    What can I do?

    This makes development work very tedious.

    Thanks!

    Zartan
    zartan@chupacabras.net
     
  2. zartanch

    zartanch Member

    Joined:
    Mar 25, 2003
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    Fixed!

    Cpanel support was great in assisting me...

    The problem was that my Firewall "Tiny Personal Firewall" for some reason was slowing the communication of the server to my home PC. Simply disabling the firewall fixed the problem.

    Just in case someone has the same problem.

    :)
     
  3. Bert W

    Bert W Member

    Joined:
    Mar 2, 2003
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    1
    I don't have any firewall, and I get a hang and a quick disconnect from the server if I am not exchanging files, it releases the connection much too quickly. Any way to adjust this?
    I am connecting using passive ftp. Seems to be the only way?
     
  4. haze

    haze Well-Known Member

    Joined:
    Dec 21, 2001
    Messages:
    1,550
    Likes Received:
    3
    Trophy Points:
    38
    Try turning off reversedns lookups in /etc/proftpd.conf.. you can also edit the idle timout here as well.
     
  5. Bert W

    Bert W Member

    Joined:
    Mar 2, 2003
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    1
    I don't see a line that allows 'reverse dnslookup' in the file? do I have to write it in? and if so, what would be the syntax?

    I also don't see the idle time out, is there another conf file that I am not seeing?
     
  6. jmc67

    jmc67 Well-Known Member

    Joined:
    Mar 10, 2002
    Messages:
    105
    Likes Received:
    0
    Trophy Points:
    16
    Add this to proftpd.conf then restart proftpd.


    Add this after DefaultRoot ~ !wheel

    UseReverseDNS off
    IdentLookups off

    <Global>
    IdentLookups off
    </Global>

    This worked for me and I don't get the pause. I also had to add the Global section because the top setting didn't work for ip based sites. It only worked for the shared sites.
     
  7. Bert W

    Bert W Member

    Joined:
    Mar 2, 2003
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    1
    I am still getting the pause when I log in,
    also what is the idle time out adjustment syntax? and does that go in the same place,

    thanks
     
  8. jmc67

    jmc67 Well-Known Member

    Joined:
    Mar 10, 2002
    Messages:
    105
    Likes Received:
    0
    Trophy Points:
    16
    This is what I have on mine. Works perfect for me.



    ServerName "ProFTPD"
    AuthUserFile /etc/proftpd/passwd.vhosts
    LogFormat BytesLog "%b"
    ServerType standalone
    DeferWelcome off
    DefaultServer on
    DefaultRoot ~ !wheel
    UseReverseDNS off
    IdentLookups off
    TimeoutNoTransfer 300
    TimeoutIdle 300
    TimeoutLogin 120
    TimeoutStalled 600


    <Global>
    IdentLookups off
    </Global>
     
Loading...

Share This Page