The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

FTP issue

Discussion in 'General Discussion' started by crliuh, Jun 20, 2014.

  1. crliuh

    crliuh Member

    Joined:
    Jun 16, 2014
    Messages:
    23
    Likes Received:
    1
    Trophy Points:
    3
    cPanel Access Level:
    Root Administrator
    Im trying to login to one of my website's ftp. and i get the following logs from filezilla,

    Code:
    Status:	Resolving address of domain.com
    Status:	Connecting to 54.255.xx.xx:21...
    Status:	Connection established, waiting for welcome message...
    Response:	220---------- Welcome to Pure-FTPd [privsep] [TLS] ----------
    Response:	220-You are user number 1 of 50 allowed.
    Response:	220-Local time is now 02:05. Server port: 21.
    Response:	220-This is a private system - No anonymous login
    Response:	220-IPv6 connections are also welcome on this server.
    Response:	220 You will be disconnected after 15 minutes of inactivity.
    Command:	USER zuvizi
    Response:	331 User domain OK. Password required
    Command:	PASS **************
    Response:	230 OK. Current restricted directory is /
    Command:	SYST
    Response:	215 UNIX Type: L8
    Command:	FEAT
    Response:	211-Extensions supported:
    Response:	 EPRT
    Response:	 IDLE
    Response:	 MDTM
    Response:	 SIZE
    Response:	 MFMT
    Response:	 REST STREAM
    Response:	 MLST type*;size*;sizd*;modify*;UNIX.mode*;UNIX.uid*;UNIX.gid*;unique*;
    Response:	 MLSD
    Response:	 AUTH TLS
    Response:	 PBSZ
    Response:	 PROT
    Response:	 TVFS
    Response:	 ESTA
    Response:	 PASV
    Response:	 EPSV
    Response:	 SPSV
    Response:	 ESTP
    Response:	211 End.
    Status:	Server does not support non-ASCII characters.
    Status:	Connected
    Status:	Retrieving directory listing...
    Command:	PWD
    Response:	257 "/" is your current location
    Command:	TYPE I
    Response:	200 TYPE is now 8-bit binary
    Command:	PORT 192,168,1,96,217,224
    Response:	500 I won't open a connection to 10.112.157.124 (only to 14.192.xx.xx)
    Command:	PASV
    Response:	227 Entering Passive Mode (172,31,5,255,250,80)
    Status:	Server sent passive reply with unroutable address. Using server address instead.
    Command:	MLSD

    Set the ftp setting to active mode, but it's still have the same error.
     
  2. crliuh

    crliuh Member

    Joined:
    Jun 16, 2014
    Messages:
    23
    Likes Received:
    1
    Trophy Points:
    3
    cPanel Access Level:
    Root Administrator
    Hi,

    removed # in PassivePortRange 30000 50000

    right now im getting this error.

    Error: Server returned unroutable private IP address in PASV reply

    Code:
    Status: Resolving address of domain.com
    Status: Connecting to 54.255.xx.xx
    Status: Connected, waiting for welcome message...
    Reply: 220---------- Welcome to Pure-FTPd [privsep] [TLS] ----------
    Reply: 220-You are user number 1 of 50 allowed.
    Reply: 220-Local time is now 16:22. Server port: 21.
    Reply: 220-IPv6 connections are also welcome on this server.
    Reply: 220 You will be disconnected after 15 minutes of inactivity.
    Command: CLNT https://ftptest.net on behalf of 14.192.xx.xx
    Reply: 530 You aren't logged in
    Command: USER domain
    Reply: 331 User domain OK. Password required
    Command: PASS *************
    Reply: 230 OK. Current restricted directory is /
    Command: SYST
    Reply: 215 UNIX Type: L8
    Command: FEAT
    Reply: 211-Extensions supported:
    Reply: EPRT
    Reply: IDLE
    Reply: MDTM
    Reply: SIZE
    Reply: MFMT
    Reply: REST STREAM
    Reply: MLST type*;size*;sizd*;modify*;UNIX.mode*;UNIX.uid*;UNIX.gid*;unique*;
    Reply: MLSD
    Reply: AUTH TLS
    Reply: PBSZ
    Reply: PROT
    Reply: TVFS
    Reply: ESTA
    Reply: PASV
    Reply: EPSV
    Reply: SPSV
    Reply: ESTP
    Reply: 211 End.
    Command: PWD
    Reply: 257 "/" is your current location
    Status: Current path is /
    Command: TYPE I
    Reply: 200 TYPE is now 8-bit binary
    Command: PASV
    Reply: 227 Entering Passive Mode (172,31,5,255,185,113)
    Error: Server returned unroutable private IP address in PASV reply
    pls help.


    update ---------------------------------------


    i realised that the 227 Entering Passive Mode (172,31,5,255,185,113) is my internal ip is not my public ip therefore i change the ForcePassiveIP to 54.255.xx.xx (my public ip) in pure-ftpd.conf. tried to test in /https://ftptest.net turn out with the follow error,

    Error: Carriage return without line feed received
    The replies sent by your server are violating the FTP specifications.
    You have to upgrade to a proper server.

    even i have disabled my iptables i still get the same error.

    what else i have missed it?
     
    #3 crliuh, Jun 21, 2014
    Last edited: Jun 21, 2014
  3. crliuh

    crliuh Member

    Joined:
    Jun 16, 2014
    Messages:
    23
    Likes Received:
    1
    Trophy Points:
    3
    cPanel Access Level:
    Root Administrator
    hi guys, my problem solved at last, with the following steps,

    1. i removed removed # for PassivePortRange 30000 50000 in pure-ftp conf
    2. Change the ForcePassiveIP to 54.255.xx.xx (my public ip) in pure-ftpd.conf
    3. allow incoming FTP in Iptables. followed the instruction here - Iptables to allow incoming FTP - Unix & Linux Stack Exchange

    p.s. ftptest.net showing error when im trying to test my ftp, but it's working when im using filezilla to connect.

    Reply from cpanel support team: "It also appears there's an issue with using the ftptest.net tool to test this. I recommend using an actual FTP client on your local workstation to test this (such as Filezilla). You can see other users have had an issue using ftptest.net here:http://forums.cpanel.net/f5/replies-sent-your-server-violating-ftp-specifications-266401.html".
     
  4. storminternet

    storminternet Well-Known Member

    Joined:
    Nov 2, 2011
    Messages:
    462
    Likes Received:
    0
    Trophy Points:
    16
    cPanel Access Level:
    Root Administrator
    Are you adding rules from command line while managing iptables. I suggest you to use csf with which you can easily manage firewall from WHM , GUI mode.
     
Loading...

Share This Page