zerackam

Registered
Dec 14, 2013
3
0
1
cPanel Access Level
Root Administrator
Hi so i just setup WHM/cPanel on my dedicated server and I am currently running default installation of whm/cpanel with Pure-FTPD but i am having a problem logging into the FTP using filezilla and the normal FTP protocol. Below is the error i get when attempting to login to FTP and it seems to login but just times out when its retreiving the directories. The only way around this for me is to use SFTP ie) SSH FTP instead of plain FTP but this is causing problems.


Status: Connecting to (My IP address)...
Status: Connection established, waiting for welcome message...
Response: 220---------- Welcome to Pure-FTPd [privsep] [TLS] ----------
Response: 220-You are user number 2 of 50 allowed.
Response: 220-Local time is now 13:50. Server port: 21.
Response: 220-This is a private system - No anonymous login
Response: 220-IPv6 connections are also welcome on this server.
Response: 220 You will be disconnected after 15 minutes of inactivity.
Command: USER (My user name)
Response: 331 User (My user name) OK. Password required
Command: PASS ************
Response: 230 OK. Current restricted directory is /
Status: Server does not support non-ASCII characters.
Status: Connected
Status: Retrieving directory listing...
Command: PWD
Response: 257 "/" is your current location
Command: TYPE I
Response: 200 TYPE is now 8-bit binary
Command: PORT 192,168,0,14,194,73
Response: 200 PORT command successful
Command: MLSD
Error: Connection timed out
Error: Failed to retrieve directory listing

So i continually get this error unless i change to SFTP. This is causeing issues as some wordpress plugins need to access ftp to install. How can i fix this issue? Thank you for your help

Additional info:
There is no firewall installed yet
setting FTP to active or passive mode also results in the same error as above
Not using or Using encryption TLS for FTP connection also gives the same error
I have even tried changing to ProFTPD but that did not help the problem
im running my server on centos 6.5

Thank you guys for the help.
 

MikeDVB

Well-Known Member
PartnerNOC
Jun 4, 2008
218
3
68
Indiana, USA
You need to configure the passive ports in the FTP configuration and then open those ports in your firewall. Alternatively you can disable passive connections and force active connections, you can white-list your IP in the firewall, or you can disable the firewall.
 

zerackam

Registered
Dec 14, 2013
3
0
1
cPanel Access Level
Root Administrator
You need to configure the passive ports in the FTP configuration and then open those ports in your firewall. Alternatively you can disable passive connections and force active connections, you can white-list your IP in the firewall, or you can disable the firewall.
so there are a few problems first I did not install a firewall on the server there is only centos WHM and Cpanel so i dont think there is a firewall to configure. as far as configuring the passive ports in the FTP config i cheked WHM FTP config.
 

MikeDVB

Well-Known Member
PartnerNOC
Jun 4, 2008
218
3
68
Indiana, USA
In that case I'd do one of two things:
1. Open a ticket with cPanel to see if they can assist you.
2. Hire a competent server administrator.
 

cPanelPeter

Technical Analyst III
Staff member
Sep 23, 2013
575
20
143
cPanel Access Level
Root Administrator
Twitter
Hello,

Please go to your WHM => Service Configuration => FTP Server Configuration and tell me what you have for TLS Encryption Support.

Or as suggested by Michael Denney above, open up a support ticket using the link in my signature.
 

talk2prakash

Member
Sep 29, 2013
14
0
1
cPanel Access Level
Root Administrator
Any ideas why SFTP would work but regular FTP does not?
Are you able to telnet the port 21 port from your local system to your server where your site is hosted ?

Telnet from windows machine
=====================

telnet yourdomainname 21

See if you could able to connect to the server or whether you're receiving any error in connecting through port 21