The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

FTP Management -- What's wrong here?!

Discussion in 'General Discussion' started by Blue|Fusion, Nov 19, 2004.

  1. Blue|Fusion

    Blue|Fusion Well-Known Member

    Joined:
    Sep 12, 2004
    Messages:
    378
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Cleveland, Ohio
    [solved] FTP Management -- What's wrong here?!

    Hello everyone,

    Yesterday it has come to my attention after attempting to add a FTP Account to my website that there is a problem with the FTP Account Management (atleast on my cP). I can not add, or delete FTP accounts. The "Main Accounts" are missing from the Management list although the "Main Accounts" can be access normally through FTP.

    The only account listed in the FTP Management is a user "h@mydomain.com()". As I said before, I can not add other accounts ot delete this one.

    The thing I noticed about this is all of my web accounts that had additional FTP Accounts previously had this issue. Accounts from before, and new accounts have no noticable problems regarding the FTP Management. I can add, edit, and delete accounts as I need to.

    As I said, I did not notice this until yesterday, however 2 weeks ago this was working perfectly normal.

    Last time I noticed this was working, I was using 9.9.8-STABLE-6. When I noticed the problem, I was using 9.9.8-RELEASE-119. I am not implying that the upgrade caused this, just that I have not noticed anything caused by it (but it very well may be). Today, after trying a a forced reinstall of cPanel 9.9.8-CURRENT-119, and failing, I tried to force an install of 9.9.8-RELEASE-6 again, and still it shows up the same way. After that failed, I also tried a force reinstall of ProFTPd, with still no change.

    Below is an image of one of the accounts with a bad FTP Account Management page:
    [​IMG]

    Please, does anyone have any idea what may be wrong here?
     
    #1 Blue|Fusion, Nov 19, 2004
    Last edited: Nov 19, 2004
  2. Blue|Fusion

    Blue|Fusion Well-Known Member

    Joined:
    Sep 12, 2004
    Messages:
    378
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Cleveland, Ohio
    It ended up being a problem with the ProFTPd vhosts files veing corrupted on those accounts. When cPanel updated, any accounts with additional FTP accounts added in some new lines at the beginning and end of file, which had to be removed manually.
     
  3. bwalla

    bwalla Member
    PartnerNOC

    Joined:
    Aug 20, 2004
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Dallas, TX
    Where is this file?
     
  4. bwalla

    bwalla Member
    PartnerNOC

    Joined:
    Aug 20, 2004
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Dallas, TX
    Nevermind found this, this worked for me
     
Loading...

Share This Page