The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

ftp manager shows no accounts

Discussion in 'General Discussion' started by smoogles, Jan 13, 2005.

  1. smoogles

    smoogles Member

    Joined:
    Dec 19, 2004
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    i have no problems logging in via ftp (im using pure-ftpd). But ftp manager shows no accounts saying "There are currently no active ftp accounts". Even if i add a new account, still nothing shows up. I wouldnt be concerned i guess, i just want to make sure its not part of a bigger problem, and it seems theres no way to remove accounts unless you can see them there.

    All accounts do this, btw... i have 3 accounts setup in WHM... all can login via ftp though

    WHM 9.9.9, cPanel 9.9.9-RELEASE 70, CentOS 3.3 :cool:
     
  2. eth00

    eth00 Well-Known Member
    PartnerNOC

    Joined:
    Mar 30, 2003
    Messages:
    723
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    NC
    cPanel Access Level:
    Root Administrator
    look at /etc/proftpd/username.conf and try to see if it looks wierd or has some wierd spacing in it. I have see some that randomly get corrupted and we have to go in and manually change them back.
     
  3. smoogles

    smoogles Member

    Joined:
    Dec 19, 2004
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    i didnt find that file in /etc/proftpd/, i did find however 'passwd.vhosts' and 'vrc'. 'vrc' is the name of one of my accounts, when i checked that accounts ftp manager, the accounts were listed. Why werent the ftp account file lists created for the other 2 accounts. How can i remake them?
     
  4. smoogles

    smoogles Member

    Joined:
    Dec 19, 2004
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    i terminated and remade an account that i have the luxury of being able to do that to. The ftp account list file appeared after re-creation. I do NOT have the luxury of doing that to the final, 3rd account. Is there any way to force a creation of this ftp account list file in /etc/proftpd/?
     
  5. babyboom

    babyboom Registered

    Joined:
    Oct 7, 2004
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    that's Cpanel problem when it is installed. Reinstall your Cpanel or ask for help from you Server Provider. I did have that problem before when I reinstall OS and Cpanel , but lucky I have backup of Cpanel/bin/ folder , so i copy all of my backup to Cpanel/bin , and the problem is solved. But first of all make sure your FTP Server is working, if not try to reinstall it too.
     
  6. ozarkhost

    ozarkhost Active Member

    Joined:
    Oct 9, 2003
    Messages:
    32
    Likes Received:
    0
    Trophy Points:
    6
    I am also have the same problem.
     
  7. ozarkhost

    ozarkhost Active Member

    Joined:
    Oct 9, 2003
    Messages:
    32
    Likes Received:
    0
    Trophy Points:
    6
    Here is what I have found at least in my case mind you this is a recent fresh install also note so many problems with cpanel install recently that it's pathetic. In any case here is the problem I think

    From reading other posts with the same problem here is what I'm seeing if I go to /etc/pure-ftpd directory I see a system linking to another direct with if I do ls -n I see it pointing to /var/ftp
    so I go to var ftp
    -bash: cd: /var/ftp: No such file or directory
    Ah hmm I was exspecting to see some file but that dir does not exsist. Now being logical I attempted to switch to proftpd and guess what it fails.


    In any case all cpanel clients are seeing this in ftp manager
    FTP Account Maintenance

    There are currently no active ftp accounts.

    Ftp Disk Usage/Quotas
    No Ftp Accounts have a quota set.


    [ Add FTP Account ] | [ Go Back ]
     
  8. cPanelNick

    cPanelNick Administrator
    Staff Member

    Joined:
    Mar 9, 2015
    Messages:
    3,426
    Likes Received:
    2
    Trophy Points:
    38
    cPanel Access Level:
    DataCenter Provider
    What build are you using?

    ls -l /etc/proftpd/user (/etc/proftpd is still used when pure-ftpd is installed for legacy reasons)

    Check the /etc/proftpd/user file to make sure it is intact.
     
  9. ozarkhost

    ozarkhost Active Member

    Joined:
    Oct 9, 2003
    Messages:
    32
    Likes Received:
    0
    Trophy Points:
    6
    Ok people here is your fix :)

    I had a similar issue after a hd failure and had to have a reinstall of the os and recover backups but however had this ftp issue with all cpanel accounts not having any ftp logins this is how to fix it.

    This assumes you have a backup drive!!

    mount /yourbackupdrive

    Now depending how long it has been for you you may have to go to monthly, but first we will try the daily.

    cd /yourbackupdrive/cpbackup/daily/dirs/
    tar -xzvf _etc_proftpd.tar.gz
    cd etc/proftpd
    ls

    Now again depending how long this has gone on you will either see one of two things

    A: you see only passwd.vhosts
    ---------------------------------------
    If you see the results of A then go to
    cd /yourbackupdrive/cpbackup/monthly/dirs/
    tar -xzvf _etc_proftpd.tar.gz
    ---------------------------------------
    Repeat this process for daily weekly monthly backup untill you see result B

    B: alot of files including passwd.vhosts
    ---------------------------------------
    within the extracted file
    cp * /etc/proftpd/
    if it ask you to overwrite passwd.vhosts (DO NOT DO THIS SAY NO)
    now what you will need to do is go to whm and login to each cpanel account via the account list by clicking on the cpanel logo verfiying each cpanel accounts ftp management area to check the results. If you see any accounts that are still having this issue do the following.
    cd /etc/proftpd
    nano username
    (NOTE replace username with cpanel accounts username that are having the issue)
    type any letter then cntrl x then y to save
    nano username
    remove the letter you just typed then cntrl x then y to save
    Go to WHM click Synchronize FTP Passwords
    go back to account lists and check that cpanel account in question in the ftp manager you should now see the main ftp account for this user cpanel


    You will need to go to each cpanel account to verify as some may have to be reset with the above process.


    If anyone is not comfortable with doing this or needs help I will be glad to do this for a small fee depending on number of accounts.

    My contact information is located on my site ozarkhost.com or you can call me toll free
    Please note

    Do NOT CALL ME UNLESS YOUR NEED HELP AND WILL PAY ME TO FIX THIS FOR YOU!!!
    this will require ssh access and whm access for me to do this for you.
     
    #9 ozarkhost, Jan 20, 2005
    Last edited: Jan 24, 2005
  10. rascal2trust

    rascal2trust Active Member

    Joined:
    Apr 28, 2003
    Messages:
    43
    Likes Received:
    0
    Trophy Points:
    6
    Are you going to get a fix for this problem.

    I got the accounts to show back up, by reinstalling pure-ftp a few times, but I still have accounts that the users can not login to , this is getting really stupid, and has been going on for awhile now with no real reaponse from the cpanel team. I have checked all I know to check inluding the passwd.vhosts, and the individual user account files files for the ftp.

    Still does not work, when will you guys quit breaking things with new updates.
     
  11. ozarkhost

    ozarkhost Active Member

    Joined:
    Oct 9, 2003
    Messages:
    32
    Likes Received:
    0
    Trophy Points:
    6
    If you read the above It will fix it. If you need help on this I can do this for you.
     
  12. ozarkhost

    ozarkhost Active Member

    Joined:
    Oct 9, 2003
    Messages:
    32
    Likes Received:
    0
    Trophy Points:
    6
    Rather simple if you got most of them to work here is how.
    ssh into your server.
    cd /etc/proftpd
    pico or nano (depending on what os you have)

    pico username

    username being the username of the cpanel client that has no accounts within ftp account manager

    type a single letter any letter then cntl x then type y to save
    pico the same file again to remove the letter so the file is empty then cntl x then y to save

    Go to whm resync the ftp account it's a link toward the bottom of the left nav. This should repopulate that users file with the default ftp account information thus being able to add ftp accounts ect ect.
     
  13. rascal2trust

    rascal2trust Active Member

    Joined:
    Apr 28, 2003
    Messages:
    43
    Likes Received:
    0
    Trophy Points:
    6
    The problem is the all of the info is now showing up in the users accounts, you just can not login to any of the ftp users accounts,, I have even created new addon ftp accounts and same problem, just will not let you log into it.
     
  14. ozarkhost

    ozarkhost Active Member

    Joined:
    Oct 9, 2003
    Messages:
    32
    Likes Received:
    0
    Trophy Points:
    6
    Did you do a ftp sync password in WHM?


    Hmm well there are some options here.
    1. Some ftp logs might show whats going on
    2. do a netstat -an to confirm that port 21 for ftp is up
    3. what does the ftp client say in it's login attempts if any info
    3. your pure-ftpd.conf file or proftpd.conf file
    4. In some rare cases I have seen ftp clients just fail to work with cpanels ftp server
     
    #14 ozarkhost, Jan 21, 2005
    Last edited: Jan 21, 2005
Loading...

Share This Page