The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

FTP not working for users

Discussion in 'General Discussion' started by wingtip, Feb 17, 2008.

  1. wingtip

    wingtip Member

    Joined:
    Oct 15, 2006
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    Following an upgrade of cPanel, none of my user accounts can log into their accounts via FTP. I am pretty sure that cPanel creates an FTP user for each account using the same name and password that you would use to log into cPanel.

    Now, when I try to log into one of my accounts using FTP it fails. I am using WS_FTP Pro...here is what it says in the details:

    Connecting to XX.YY.ZZZ.ABC:21
    Connected to XX.YY.ZZZ.ABC:21 in 0.000000 seconds, Waiting for Server Response
    220---------- Welcome to Pure-FTPd [TLS] ----------
    220-You are user number 1 of 50 allowed.
    220-Local time is now 13:24. Server port: 21.
    220-This is a private system - No anonymous login
    220-IPv6 connections are also welcome on this server.
    220 You will be disconnected after 15 minutes of inactivity.
    Host type (1): Automatic Detect
    USER myuser
    331 User myuser OK. Password required
    PASS (hidden)
    530 Login authentication failed


    Any ideas how to fix this?
     
  2. cPanelKenneth

    cPanelKenneth cPanel Development
    Staff Member

    Joined:
    Apr 7, 2006
    Messages:
    4,461
    Likes Received:
    22
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    Try:

    1. Restarting the FTP servers
    2. Synchronize the FTP passwords
     
  3. Bobsie

    Bobsie Registered

    Joined:
    Feb 18, 2008
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    It seems that I have the same problem. I had to change the way the userid's are entered. Instead of just a userid and password, I had to use userid@domainname.xxx and password as if they were sub ftp accounts despite each account being its own virtual server. I restarted the ftp server and sync'd the passwords before changing the userid's but to no avail. I discovered this fix through experimentation. I should note, this was not necessary if using sftp, just normal ftp.

    I should also note, it is now working both ways again... so I dunno anymore :)
     
    #3 Bobsie, Feb 18, 2008
    Last edited: Feb 18, 2008
  4. Sklndr

    Sklndr Registered

    Joined:
    Sep 20, 2006
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    I am not sure, but I think I am having a similar problem

    I created a ftp user that needs to only have access to a specific folder,

    for example

    www.domainname.com/videos

    I dont want them to access anything outside of the videos folder so they can ftp videos to that folder.

    I keep getting cant connect.

    I restart ftp via WHM and sync'd etc, but no go.

    Am I setting the ftp wrong in Filezilla?


    What should the host part say? This is my first time setting up a ftp that is specific to 1 folder.

    thx
     
  5. cPanelDavidG

    cPanelDavidG Technical Product Specialist

    Joined:
    Nov 29, 2006
    Messages:
    11,279
    Likes Received:
    8
    Trophy Points:
    38
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    The host part should say: domainname.com

    The username should be: user@domainname.com where user is their FTP username. You cannot login using only user (for secondary FTP accounts anyway).

    When you create a user that only has access to a specific folder (in your case ~/public_html/videos), the user will be unable to access anything above that folder.
     
    #5 cPanelDavidG, Mar 3, 2008
    Last edited: Mar 3, 2008
  6. Sklndr

    Sklndr Registered

    Joined:
    Sep 20, 2006
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Thank You,

    I knew I was missing something very obvious.

    I was forgetting to put usename@domain.com I was just adding the usename in the ftp application


    thanks for your help!
     
Loading...

Share This Page