monkey64

Well-Known Member
Nov 6, 2011
121
5
68
cPanel Access Level
Root Administrator
I'm struggling to get trying to get FTP over SSL/TLS (FTPS) working for virtual users. I am using Pure-FTPD as my FTP server. I read this post on FTP over SSL/TLS where cPanelDavidG says:

Correct, SFTP is only for cPanel users, not the virtual FTP accounts created by cPanel users. However virtual users can use FTP over SSL/TLS (FTPS).
Service Configuration => FTP Server Configuration => TLS Encryption Support = Optional

CuteFTP Settings

FTP with TLS/SSL (AUTH TLS - Explicit)
Port 21

When I connect, the following happens:

*** CuteFTP 8.3 - build May 19 2010 ***

COMMAND:> [23/08/2012 07:55:33] AUTH TLS
[23/08/2012 07:55:33] 234 AUTH TLS OK.
STATUS:> [23/08/2012 07:55:33] Establishing SSL session...
STATUS:> [23/08/2012 07:55:33] Connected. Exchanging encryption keys...
STATUS:> [23/08/2012 07:55:33] SSL Connect time: 47 ms.
STATUS:> [23/08/2012 07:55:33] SSL encrypted session established.
COMMAND:> [23/08/2012 07:55:33] PBSZ 0
[23/08/2012 07:55:33] 200 PBSZ=0
COMMAND:> [23/08/2012 07:55:33] USER myuser
[23/08/2012 07:55:33] 331 User myuser OK. Password required
COMMAND:> [23/08/2012 07:55:33] PASS *****
[23/08/2012 07:55:33] 230 OK. Current restricted directory is /
STATUS:> [23/08/2012 07:55:33] Login successful.
COMMAND:> [23/08/2012 07:55:33] PWD
[23/08/2012 07:55:33] 257 "/" is your current location
STATUS:> [23/08/2012 07:55:33] Home directory: /
STATUS:> [23/08/2012 07:55:33] This site supports features.
STATUS:> [23/08/2012 07:55:33] This site supports SIZE.
STATUS:> [23/08/2012 07:55:33] This site can resume broken downloads.
COMMAND:> [23/08/2012 07:55:33] REST 0
[23/08/2012 07:55:33] 350 Restarting at 0
COMMAND:> [23/08/2012 07:55:33] CWD /public_html
[23/08/2012 07:55:33] 250 OK. Current directory is /public_html
STATUS:> [23/08/2012 07:55:33] PWD skipped. Current folder: "/public_html".
COMMAND:> [23/08/2012 07:55:33] PBSZ 0
[23/08/2012 07:55:33] 200 PBSZ=0
COMMAND:> [23/08/2012 07:55:33] PROT P
[23/08/2012 07:55:33] 200 Data protection level set to "private"
COMMAND:> [23/08/2012 07:55:33] PORT 192,168,0,5,194,75
[23/08/2012 07:55:33] 500 I won't open a connection to 192.168.0.5 (only to MY IP ADDRESS)
ERROR:> [23/08/2012 07:55:33] Syntax error: command unrecognized.
ERROR:> [23/08/2012 07:55:33] Failed to establish data socket.


Any ideas?
 
Last edited:

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,909
2,228
463
Hello :)

You may want to check your firewall rules to ensure they are not blocking traffic related to FTP. If you continue to experience issues, feel free to submit a ticket so we can check further:

Submit A Ticket

You can post the ticket number here so we can track the issue.

Thank you.