The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

FTP password error

Discussion in 'General Discussion' started by Alexandre Duran, Apr 18, 2005.

  1. Alexandre Duran

    Alexandre Duran Well-Known Member

    Joined:
    May 6, 2003
    Messages:
    61
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Rio de Janeiro - BRAZIL
    Hi,

    I have a problem with FTP (PUREFTP).
    No user gets access through FTP.
    All the users that I create now don't also get access through FTP.

    The account is created, but every access FTP gives a error - it doesn't recognize the password.
    The system not accepts any user's password (FTP only).
     
  2. DigitalN

    DigitalN Well-Known Member

    Joined:
    Sep 23, 2004
    Messages:
    420
    Likes Received:
    1
    Trophy Points:
    18
    If you add an ftp account, you need to login using

    $user@domain.com with the password ($user being the ftp user you added.) rather than just $user

    Are you doing that?

    Logs: /var/log/messages /var/log/xferlog will provide further insight if you are using the correct user name syntax as above.
     
  3. duranduran

    duranduran Well-Known Member

    Joined:
    Apr 30, 2004
    Messages:
    198
    Likes Received:
    0
    Trophy Points:
    16
    No, this is not a problem.
    I am use $user alone (not $user@domain.com) in all others cpanel box and works fine.
    I always use $use in this box (never $user@domain.com) and always works fine too.

    All FTP passwords, for all users dont work.

    Last /var/log/xferlog lines:

    Mon Apr 18 14:43:16 2005 0 200.233.111.172 249 /home/lomphar/public_html/images/folder_hot.gif b _ i r lomphar ftp 1 * c
    Mon Apr 18 14:43:19 2005 1 200.233.111.172 13123 /home/lomphar/public_html/images/websphere.gif b _ i r lomphar ftp 1 * c
    Mon Apr 18 14:43:22 2005 1 200.233.111.172 5994 /home/lomphar/public_html/images/0001v.jpg b _ i r lomphar ftp 1 * c

    The message error: (/etc/messages):

    Apr 18 22:41:04 ns1 pure-ftpd: (?@200.217.103.72) [INFO] Logout.
    Apr 18 22:41:04 ns1 pure-ftpd: (?@200.217.103.72) [INFO] New connection from 200.217.103.72
    Apr 18 22:41:06 ns1 pure-ftpd: (?@200.217.103.72) [WARNING] Authentication failed for user [lx3serve]
    Apr 18 22:41:11 ns1 pure-ftpd: (?@200.217.103.72) [INFO] Logout.
    Apr 18 22:41:12 ns1 pure-ftpd: (?@200.217.103.72) [INFO] New connection from 200.217.103.72
    Apr 18 22:41:12 ns1 pure-ftpd: (?@200.217.103.72) [WARNING] Authentication failed for user [lx3serve]

    All passwords for all users in this server not work.
    Before it is work 100%
     
    #3 duranduran, Apr 18, 2005
    Last edited: Apr 18, 2005
  4. duranduran

    duranduran Well-Known Member

    Joined:
    Apr 30, 2004
    Messages:
    198
    Likes Received:
    0
    Trophy Points:
    16
    I am try to change to proftp, but dosent work :

    Ftp Setup Script Version 6.0
    Fetching version information from http://updates.cpanel.net/ftpinstall/version (STABLE)....Done
    This is the proftpd 1.2.10tls installer release number 5 for platform redhat AS-3

    Fetching Obsoletes list for channel: rhel-i386-es-3...

    Fetching Obsoletes list for channel: rhel-i386-es-3-extras...

    Fetching rpm headers...

    Name Version Rel
    ----------------------------------------------------------


    The following packages you requested are already updated:
    db4-devel
    pam-devel
    openssl096b
    openssl
    openssl-devel
    gcc
    glibc-devel
    compat-db
    zlib-devel
    rpm-build
    Resetting proftpd to cPanel Defaults and Installing the Latest Version
    Failed to download http://diff.cpanel.net/ftpinstall/p...oftpd-1.2.10tls-5_linuxprivs_newinit.i386.rpm .. using source instead

    Fetching Obsoletes list for channel: rhel-i386-es-3...

    Fetching Obsoletes list for channel: rhel-i386-es-3-extras...

    Fetching rpm headers...

    Name Version Rel
    ----------------------------------------------------------


    The following packages you requested were not found:
    db-devel
    db1-devel
    ndbm-devel

    The following packages you requested are already updated:
    rpm
    rpm-build
    gdbm-devel
    compat-db
    Building RPM....Done
    Failed to download http://diff.cpanel.net/ftpinstall/proftpd/src/proftpd-1.2.10tls-5_linuxprivs_newinit.src.rpm at /scripts/ftpup line 255.
     
  5. duranduran

    duranduran Well-Known Member

    Joined:
    Apr 30, 2004
    Messages:
    198
    Likes Received:
    0
    Trophy Points:
    16
    Any one ?
    This is a realy misterius problem.
     
  6. DigitalN

    DigitalN Well-Known Member

    Joined:
    Sep 23, 2004
    Messages:
    420
    Likes Received:
    1
    Trophy Points:
    18
    Try reinstalling pure-ftpd if its not currently installed, make sure that it's running and then try

    # /scripts/ftpupdate

    Let us know how that goes.
     
  7. jhendrickson

    jhendrickson Member

    Joined:
    Nov 7, 2004
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    I have the exact same problem any word of a fix?

    After switching to pureftp no users are able to authenticate using $user@$domain.com
    or any combination thereof.

    I have force updated pureftp. I have synched ftp password database. Still no joy. This affects newly created users or previous users.
    error 530
     
  8. BenThomas

    BenThomas Well-Known Member

    Joined:
    Feb 12, 2004
    Messages:
    598
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Houston, Texas USA
    cPanel Access Level:
    Root Administrator
    Is pure-authd running?

    The ps ax output for it should look like:

    18655 ? S 0:00 /usr/sbin/pure-authd -s /var/run/ftpd.sock -r /usr/sbin/pureauth
     
  9. jhendrickson

    jhendrickson Member

    Joined:
    Nov 7, 2004
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    yup

    Yes pure authd is running.

    Thanks for the idea, I should have mentioned I already checked that.

    root 1942 0.0 0.0 6680 972 ? S 17:12 0:00 /usr/sbin/pure-authd -s /var/run/ftpd.sock -r /usr/sbin/pureauth


    Any other ideas? I'm up for anything at this point. :)
     
  10. randomuser

    randomuser Well-Known Member

    Joined:
    Jun 25, 2005
    Messages:
    147
    Likes Received:
    0
    Trophy Points:
    16
    I too am seeing this behavior now. It was working fine before, now we have a few tickets with users stating they cannot login. We've been having them log in as username@domain.com, which has been working great. It is strange that logging in as just "username" stopped working out of nowhere. Perhaps there was an update last night I am not familiar with, but as far as I know, nothing has been changed. Either way, it would be nice to know what needs to be changed to have the users simply log in with their usernames. Surely this is a configuration option somewhere, I would think. I'm going to keep researching this issue, and if I can find the cause and/or solution I will update this post with the info.
     
  11. jhendrickson

    jhendrickson Member

    Joined:
    Nov 7, 2004
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    SOLVED!...for me at least

    I have with the help of nickn from cpanel figured out what happened during my last upcp to break pure-ftd

    :D


    In both /etc/passwd and /etc/shadow there are duplicate entries. The entries in /etc/passwd with a shell of noshell and the entries in etc shadow with just :!!! and a few characters are both erroneous and pureftpd is using them instead of the real hash which is also listed in the file.

    Just do

    cp /etc/passwd /etc/pass.old
    cp /etc/shadow /etc/shad.old

    then do sort /etc/shadow | less

    you will then see the dupe entries remove the ones with :!! UNLESS they are for a system daemon!

    Then in /etc/password delete the lines ending in noshell instead of ending in jailshell, UNLESS they are for a system daemon.

    Problem is then fixed.

    I want to say thankyou to everyone that responded thank you chirpy and nickn especially!


    Hope I can contribute in the future.


    -james
     
    #11 jhendrickson, Aug 19, 2005
    Last edited: Aug 19, 2005
  12. randomuser

    randomuser Well-Known Member

    Joined:
    Jun 25, 2005
    Messages:
    147
    Likes Received:
    0
    Trophy Points:
    16
    Thanks for posting what fixed your problem. It's sure to help someone out. Unfortunately, (well, fortunately actually), my passwd and shadow files look fine, and don't contain any duplicate or erroneous information. Still trying to figure this one out. An upgrade to 10.6 didn't help either.
     
  13. dev32

    dev32 Member

    Joined:
    Aug 8, 2005
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    Hey! This is strange ...
    I just had a fresh OS + cpanel install and one thinks it would be trouble free (Exim problems on my previous one ++) but NO! FTP (pure-ftpd) does not work! Ok you do an update just to find out that didn't make a difference :eek: .

    Well...thanks to the users of the forums @cpanel.net I've managed to fix it (or at least I'd like to think I did) my FTP problem.

    I've launched my WinSCP3 (Great SFTP prog. BTW) and removed the last ':::' from /etc/shadow , saved the file and then logged in to normal FTP ..hey Bingooo! Now works! :D

    Special thanks to 'jhendrikson' for posting a fix ...

    --------------------------------------------------
    WHM 10.6.0 cPanel 10.6.0-R16
    Trustix 2.2 i686 - WHM X v3.1.0
    --------------------------------------------------
     
    #13 dev32, Aug 20, 2005
    Last edited: Aug 20, 2005
  14. mikesouth

    mikesouth Member

    Joined:
    Aug 10, 2005
    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    1
    Apparently the geniuses at cpanel did an update that doesnt work...the all started after a cpanel automatic update

    Im having the same problem...
     
  15. dev32

    dev32 Member

    Joined:
    Aug 8, 2005
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    Mike, try that and see if it works for you.
    In my case the last 6 chars on last line of /etc/shadow was :::::: remove 3 x ':'
    so they look like the other lines there (most have ::: at the end)
    Backup the file 1st. ;)
     
  16. mikesouth

    mikesouth Member

    Joined:
    Aug 10, 2005
    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    1
    Im on freebsd there is no etc/shadow
     
  17. mikesouth

    mikesouth Member

    Joined:
    Aug 10, 2005
    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    1
    this is looking more and more like a length of the username problem

    of all things.....

    why the hell did they try to fix something that wasnt broke...this is causing me HUGE headaches on what should be my day off

    way to go cpanel
     
  18. netwrkr

    netwrkr Well-Known Member

    Joined:
    Apr 12, 2003
    Messages:
    203
    Likes Received:
    0
    Trophy Points:
    16
    I've tried every suggestion posted here without success. Pure-FTP had been working so well for so long...
     
  19. mikesouth

    mikesouth Member

    Joined:
    Aug 10, 2005
    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    1
    I have an open ticket on it...will see if I get any help...Im at my wits end on this one

    they updated cpanel and broke hell out of it
     
  20. mikesouth

    mikesouth Member

    Joined:
    Aug 10, 2005
    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    1
    I fixed this by changing my updates from current to stable and updating cp


    set everything like it was before the change

    ftp works again...

    I had cpanel tech no-support on this all day and all they managed to do was poke around in my server a bit

    6 hours later...I fixed it myself....something about if you want something done right...

    needless to say I am NOT very happy with cpanel right now...hopefully it'll pass
     
Loading...

Share This Page