Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

FTP password not saving in /etc/proftpd

Discussion in 'General Discussion' started by stefanbc, Sep 15, 2017.

  1. stefanbc

    stefanbc Well-Known Member

    Joined:
    Apr 13, 2015
    Messages:
    52
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    toronto
    cPanel Access Level:
    Root Administrator
    Hi,

    I can't sftp into one of the accounts and I think, the reason is that no password is saved anymore in etc/proftpd/user


    Here is what I have for one account that is not working(cpanel access works but no sftp)
    user1:*:535:536::/home/user1:/bin/bash
    user1_logs:*:535:536:user1:/etc/apache2/logs/domlogs/user1:/bin/ftpsh

    And here is what I have for a user that is working
    user2:$6$b.............RA/:525:526::/home/user2:/bin/bash
    user2_logs:$6$b...........RA/:525:526:user2:/etc/apache2/logs/do$


    I changed the password a few times for user1, I restarted the ftp, I modified the account, regenerated the file by deleting and restarting and syncing ftp, but the second set of character which I believe is the encrypted password is always a *.


    Any ideas if this is a correct assumption, or any other ways sftp access could be fixed?


    Thank you
     
  2. sysdop

    sysdop Member

    Joined:
    Sep 10, 2017
    Messages:
    18
    Likes Received:
    1
    Trophy Points:
    3
    Location:
    International
    cPanel Access Level:
    Root Administrator
    @stefanbc If I am not wrong, correct me if I am wrong from now on WHM / cPanel encrypts FTP passwords as it is betting more on user security than anything else. Although you can open a ticket with cpanel for more information about this.
     
  3. stefanbc

    stefanbc Well-Known Member

    Joined:
    Apr 13, 2015
    Messages:
    52
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    toronto
    cPanel Access Level:
    Root Administrator
    The problem is that for one user on my system, the password is encrypted as *, as mentioned above. Currently I am afraid to change the other users as I might not be able to login. I will try to create a new account and test.

    So either the pass is saved some place else or there is a bug in setting the password, or I can't sftp into this account because I set it up incorrectly.
     
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    38,658
    Likes Received:
    1,424
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    SFTP runs on a different protocol than FTP. It's essentially FTP over the SSH protocol. Currently, it's only possible to access SFTP using the cPanel account username and password. Can you let us know of any output to /var/log/secure when attempting to access SFTP as the cPanel account username?

    Thank you.
     
  5. stefanbc

    stefanbc Well-Known Member

    Joined:
    Apr 13, 2015
    Messages:
    52
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    toronto
    cPanel Access Level:
    Root Administrator
    Hi,

    The account was put in demo mode(because something was not working as expected and never switched back) but there was no way of finding that out from the interface when viewing or modifying the account or the password. I believe a ticket was added so that a notification is shown.

    Thank you
     
  6. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    38,658
    Likes Received:
    1,424
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    Thanks for the update. For reference, the internal case number for the inclusion of a warning for FTP when demo mode is enabled is CPANEL-15871.

    Thank you.
     
Loading...

Share This Page