The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

FTp question

Discussion in 'General Discussion' started by SmashU, Dec 15, 2005.

  1. SmashU

    SmashU Registered

    Joined:
    Dec 15, 2005
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Hello, I setup a FTP account and it does not seem to show the right number of files when I connect via FTP. Is there a limit on the number of files that will show up in FTP when connected? if so is there a way to change the limit?
     
  2. dalem

    dalem Well-Known Member
    PartnerNOC

    Joined:
    Oct 24, 2003
    Messages:
    2,577
    Likes Received:
    40
    Trophy Points:
    48
    Location:
    SLC
    cPanel Access Level:
    DataCenter Provider
    from where did you create this ftp account what folder is it connecting to ? what are your expecting to see? :confused:


    not really enough info here to advise you
     
  3. SmashU

    SmashU Registered

    Joined:
    Dec 15, 2005
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    I created it with cPanel, it works ok but I dont see all the files via FTP, but if I look on the linux side or the file manager in cPanel I see all the files there
     
  4. dalem

    dalem Well-Known Member
    PartnerNOC

    Joined:
    Oct 24, 2003
    Messages:
    2,577
    Likes Received:
    40
    Trophy Points:
    48
    Location:
    SLC
    cPanel Access Level:
    DataCenter Provider
    same question what folder is it connecting to ? what are your expecting to see?


    if you created it to connect to the folder /public_html/user/
    or /public_html/
     
  5. SmashU

    SmashU Registered

    Joined:
    Dec 15, 2005
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    the folder is /public_html/ut99/
    I expect to see all the files but I only see half the files in there.
    but if I look in the file manager I do see all the files.
     
  6. PWSowner

    PWSowner Well-Known Member

    Joined:
    Nov 10, 2001
    Messages:
    2,948
    Likes Received:
    3
    Trophy Points:
    38
    Location:
    ON, Canada
    Sounds to me like you have over 2000 files in it. If so, many FTP programs only show 2000 of them.
     
  7. ShockHosts

    ShockHosts Well-Known Member

    Joined:
    Nov 25, 2005
    Messages:
    123
    Likes Received:
    0
    Trophy Points:
    16
    That is weird. Never heard of anything like that. If the main ftp shows all the files in /ut89 and the new ftp account you made does NOT then you have a problem.
     
  8. RizyDeWino

    RizyDeWino Well-Known Member

    Joined:
    Aug 1, 2005
    Messages:
    74
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Planet Earth
    If you are facing the above problem then its not due to ftp software but due to FTP server settings , you can request your host to increase this value. Assuming your host is using pure-ftpd, tell them to change this below line in /etc/pure-ftpd.conf :

    LimitRecursion 2000 8

    2000 is the number of files you can view and 8 is the maximum subdirectories you can view from ftp. These are the default values and they can simply change it.

    Most probably they already know what to change and how to change , but I dont know they will agree to do it for you or not, although there is no problem with increasing these values and there are no serious security risk involved until it is increased too much.
     
  9. SmashU

    SmashU Registered

    Joined:
    Dec 15, 2005
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    where would I change these values
     
  10. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    Already mentioned. You'd need to edit /etc/pure-ftpd.conf via SSH logged in as root.
     
Loading...

Share This Page