Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

SOLVED FTP refuse connection

Discussion in 'General Discussion' started by h0feer, Jan 30, 2017.

  1. h0feer

    h0feer Member

    Joined:
    Nov 24, 2016
    Messages:
    15
    Likes Received:
    1
    Trophy Points:
    3
    Location:
    serbia
    cPanel Access Level:
    Root Administrator
    hello to everyone,


    I have an issue with ftp accounts into my server using cpanel manger ,
    FTP installed is : pure-ftpd ( default cpanel installation )


    Now, i have added my domain and i created ftp's there.. but can't login using any software like filezilla, winscp and some others that i tried. ( means no FTP account is accepted )


    but it works only with SFTP connection like this :
    when i type my domain .. it won't work..
    only with server ip , user : root and password : pass of root


    what to do ? how can i fix FTP's to work properly that are created into cpanel of my domain?


    Thanks
     
  2. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    15,765
    Likes Received:
    313
    Trophy Points:
    433
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    Does the domain resolve properly to the server?

    The cPanel default account can login using his username only. Any Addon FTP accounts must use the full name provided when you created it, for example: someusr@yourdomain.com

    Also, addon FTP accounts cannot use SFTP.
     
    h0feer likes this.
  3. h0feer

    h0feer Member

    Joined:
    Nov 24, 2016
    Messages:
    15
    Likes Received:
    1
    Trophy Points:
    3
    Location:
    serbia
    cPanel Access Level:
    Root Administrator
    Hi, thanks for your reply ,


    Yes, when i create a ftp it looks like this username@mydomain.com and it's giving instruction how to connect through filezilla

    like this : ftp.mydomain.com
    user : user@domain.com
    pass : password


    but i see on filezile logs while it's trying to connect.. it's resolving a wrong IP , ( not my server ip )


    What to do?

    Thanks.
     
  4. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    15,765
    Likes Received:
    313
    Trophy Points:
    433
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    Sounds to me like the domain is not pointing to the correct server. You should check your domain settings at your Registrar to be sure they're updated to the new server.
     
  5. h0feer

    h0feer Member

    Joined:
    Nov 24, 2016
    Messages:
    15
    Likes Received:
    1
    Trophy Points:
    3
    Location:
    serbia
    cPanel Access Level:
    Root Administrator

    I already checked, domain is already linked with my server.. when i type my domain it works and it's displaying my website

    also servers there are update..


    any other suggestion ?
     
  6. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    15,765
    Likes Received:
    313
    Trophy Points:
    433
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    What happens when you use: mydomain.com sans the ftp. part?
     
  7. h0feer

    h0feer Member

    Joined:
    Nov 24, 2016
    Messages:
    15
    Likes Received:
    1
    Trophy Points:
    3
    Location:
    serbia
    cPanel Access Level:
    Root Administrator

    when i type mydomain.com without "ftp." it's resolving my server IP but there is an error :



    Status: TLS connection established.
    Command: USER magi
    Response: 331 User magi OK. Password required
    Command: PASS ******
    Response: 530 Login authentication failed
    Error: Critical error: Could not connect to server
     
  8. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    15,765
    Likes Received:
    313
    Trophy Points:
    433
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    I don't use Filezilla, can you set TLS to optional or just set the connect to FTP and try that. Does it work then?
     
  9. h0feer

    h0feer Member

    Joined:
    Nov 24, 2016
    Messages:
    15
    Likes Received:
    1
    Trophy Points:
    3
    Location:
    serbia
    cPanel Access Level:
    Root Administrator
    No still not works, i already tried all possibilities but still not working.. seems something wrong in the ftp config .. but in fact i installed cpanel since 3-4 days on it and none of our employeers have access on it to touch any config..

    i don't know whats happened
     
  10. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    15,765
    Likes Received:
    313
    Trophy Points:
    433
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    When you configure your FTP client to use normal FTP protocol and port and you're connecting via the main cPanel user, is does not connect or it does?
     
  11. h0feer

    h0feer Member

    Joined:
    Nov 24, 2016
    Messages:
    15
    Likes Received:
    1
    Trophy Points:
    3
    Location:
    serbia
    cPanel Access Level:
    Root Administrator
    Yes, via main cpanel ..


    But i found the issue by checking your questions



    Thanks , You are a legend : )
     
    Infopro likes this.
  12. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    15,765
    Likes Received:
    313
    Trophy Points:
    433
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    Happy to help. :)
     
Loading...

Share This Page