The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

ftp transfer timeout

Discussion in 'General Discussion' started by NNNils, Feb 26, 2003.

  1. NNNils

    NNNils Well-Known Member

    Joined:
    Sep 17, 2002
    Messages:
    580
    Likes Received:
    0
    Trophy Points:
    16
    I want to alter the ftp transfer timeout. Couldn't find it in /etc/proftpd.conf

    Where can I set it?
     
  2. PWSowner

    PWSowner Well-Known Member

    Joined:
    Nov 10, 2001
    Messages:
    2,948
    Likes Received:
    3
    Trophy Points:
    38
    Location:
    ON, Canada
    It's in the httpd.conf file.

    Here's a copy of the section you will want to look at:

    #
    # Timeout: The number of seconds before receives and sends time out.
    #
    Timeout 300

    #
    # KeepAlive: Whether or not to allow persistent connections (more than
    # one request per connection). Set to "Off" to deactivate.
    #
    KeepAlive On

    #
    # MaxKeepAliveRequests: The maximum number of requests to allow
    # during a persistent connection. Set to 0 to allow an unlimited amount.
    # We recommend you leave this number high, for maximum performance.
    #
    MaxKeepAliveRequests 500

    #
    # KeepAliveTimeout: Number of seconds to wait for the next request from the
    # same client on the same connection.
    #
    KeepAliveTimeout 60


    Timeout shouldn't be set too long though. It's better to use a program that sends keep alive signals, as long as KeepAlive is set to on.
     
  3. hicom

    hicom Well-Known Member

    Joined:
    May 23, 2003
    Messages:
    272
    Likes Received:
    0
    Trophy Points:
    16
    timeout

    check

    /usr/local/etc/proftpd.conf

    also check the ProFTPD website for helpful tip on how to increase the time (see their complex virtual host example)
     
  4. batchtech

    batchtech Member

    Joined:
    Mar 13, 2004
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    1
    problem...

    Hmm, I added this stuff in but Proftpd would not restart. It failed after adding that stuff. Where in particular should it go in the config file?

    Thanks,
    David
     
  5. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    What error did you get?

    Did you do the following to restart proftpd:

    /etc/init.d/proftpd stop
    /etc/init.d/proftpd start
     
  6. batchtech

    batchtech Member

    Joined:
    Mar 13, 2004
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    1
    the problem was httpd.conf

    The problem was that above were settings for httpd.conf, not proftpd.conf....that's why it was failing. I found the settings for proftpd in another post and it works fine now.
     
Loading...

Share This Page