The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

ftp user permission

Discussion in 'General Discussion' started by tatazhang, Sep 18, 2009.

  1. tatazhang

    tatazhang Registered

    Joined:
    Sep 18, 2009
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Got a problem on setting ftp at cpanel.
    I want to setting all the ftp user can upload only, but can not modify and delete the file which upload by themselves, is that possible do it in cpanel? thanks.
    Jeff
     
  2. cPanelDavidG

    cPanelDavidG Technical Product Specialist

    Joined:
    Nov 29, 2006
    Messages:
    11,279
    Likes Received:
    8
    Trophy Points:
    38
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    Setting users to upload only is not yet possible in cPanel/WHM.
     
  3. eUK-Patrick

    eUK-Patrick Registered

    Joined:
    Sep 16, 2008
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    If you have SSH access to the server then you can edit pure-ftpd.conf file and enable NOT to delete file option as given below :


    Just remove # in front of KeepAllFiles.

    Now save changes and quit.

    Then restart FTP service on the server.

    But from this option you can't deny from renaming the file name.
     
  4. tatazhang

    tatazhang Registered

    Joined:
    Sep 18, 2009
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    I cannot found the file pure-ftpd.conf under the found etc.
    but i create the one anyway, wrote the code and restart ftp service.
    still not work.:eek:
     
  5. Spiral

    Spiral BANNED

    Joined:
    Jun 24, 2005
    Messages:
    2,023
    Likes Received:
    7
    Trophy Points:
    0
    Check your FTP server selection in WHM ....

    Are you sure you are running pure-ftpd?

    Cpanel also offers "ProFTPd" as an alternate server and you could possibly be running that server instead of pure-ftpd.

    (I personally don't recommend ProFTPd for a lot of various reasons)
     
Loading...

Share This Page