The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

FTP Welcome Message

Discussion in 'General Discussion' started by Daemon1, Feb 11, 2004.

  1. Daemon1

    Daemon1 Well-Known Member

    Joined:
    Nov 26, 2003
    Messages:
    87
    Likes Received:
    0
    Trophy Points:
    6
    Does anyone know how to edit the FTP welcome message when connecting via FTP to any given account? Currently I have the following which I believe is default with cpanel :

    220-=(<*>)=-.:. (( Welcome to PureFTPd 1.0.12 )) .:.-=(<*>)=-
    220-You are user number 1 of 50 allowed.
    220-Local time is now 14:26 and the load is 0.00. Server port: 21.
    220-This is a private system - No anonymous login
    220 You will be disconnected after 15 minutes of inactivity.


    Now how do I make it so only 1 user per account is allowed to login instead of 1/50 and also how do I edit it and add my own lines of information to this message. Thanks in advance...
     
  2. Daemon1

    Daemon1 Well-Known Member

    Joined:
    Nov 26, 2003
    Messages:
    87
    Likes Received:
    0
    Trophy Points:
    6
    Anyone yet who is able to tell me where to edit this information?
     
  3. PWSowner

    PWSowner Well-Known Member

    Joined:
    Nov 10, 2001
    Messages:
    2,948
    Likes Received:
    3
    Trophy Points:
    38
    Location:
    ON, Canada
    Check the files at
    /etc/motd
    /etc/issue
    /etc/issue.net

    They contain that text so it would likely be one of them you can modify. I think I changed the motd one a while back to experiment and it did the trick.

    Possibly the /etc/proftp.conf or pureftp.conf file. Depending on which one you are using.
     
  4. Daemon1

    Daemon1 Well-Known Member

    Joined:
    Nov 26, 2003
    Messages:
    87
    Likes Received:
    0
    Trophy Points:
    6
    Thanks anyway, but none of that worked. I am using PureFTPd 1.0.12 and I edited the pure-ftpd.conf from 50 users to 1, and I restarted FTP services however this did not take away the message "You are user number 1 of 50 allowed" in the FTP welcome message. Do I have to reboot the entire server for the change to take effect? Just changing it and restarting FTP appeared to do nothing.

    As for the welcome message, it is not located in the files you mentioned at all... The motd file is blank for starters, and all the issue/issue.net files contain is this :

    This computer system is for authorized users only. Individuals using this
    system without authority or in excess of their authority are subject to
    having all their activities on this system monitored and recorded or
    examined by any authorized person, including law enforcement, as system
    personnel deem appropriate. In the course of monitoring individuals
    improperly using the system or in the course of system maintenance, the
    activities of authorized users may also be monitored and recorded. Any
    material so recorded may be disclosed as appropriate. Anyone using this
    system consents to these terms.

    That is NOT the welcome message, the welcome message I have is :

    220-=(<*>)=-.:. (( Welcome to PureFTPd 1.0.12 )) .:.-=(<*>)=-
    220-You are user number 1 of 50 allowed.
    220-Local time is now 04:03 and the load is 0.04. Server port: 21.
    220-This is a private system - No anonymous login
    220 You will be disconnected after 15 minutes of inactivity.

    Can anyone tell me how to edit the actual welcome message, and rid of the 1/50 users allowed text. Thanks in advance...
     
  5. PWSowner

    PWSowner Well-Known Member

    Joined:
    Nov 10, 2001
    Messages:
    2,948
    Likes Received:
    3
    Trophy Points:
    38
    Location:
    ON, Canada
    PureFTPd must work differently.

    How I find things I'm looking for is by searching my local hard drive for files containing what I am looking for. I have a full copy of my server on my office computer. It's good for additional backup security and makes it easy to do various things like searching without loading the server to do it.

    When I got my first server 2 years ago, the first thing I did was download the whole thing and study everything. That's how I learned a lot of what I know now.
     
  6. bamasbest

    bamasbest Well-Known Member

    Joined:
    Jan 10, 2004
    Messages:
    531
    Likes Received:
    0
    Trophy Points:
    16
    When in doubt, check the vendor's docs.

    It seems as if this message is compiled in with pure-ftp (probably one of the reasons why it is quicker than pro?

    here's what they say you have to do to include a custom banner message:

    -> How do I display a customized message before the login prompt?

    Compile with --with-cookie and run the server with -F <file name> . In that
    file, put a nice customized banner message.

    Perhaps pure is already compiled with the cookie option and you may just need to stop and start it again with the -F option?
     
  7. Leandro

    Leandro Well-Known Member

    Joined:
    Sep 23, 2003
    Messages:
    48
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Argentin
    cPanel Access Level:
    DataCenter Provider
    Are there any new ?

    I want to change the Wellcome message, but I can't find any...

    Greatings
     
Loading...

Share This Page