Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

FTP won't start - Help!

Discussion in 'General Discussion' started by drsprite, Jul 14, 2006.

  1. drsprite

    drsprite Active Member

    Joined:
    Aug 5, 2004
    Messages:
    39
    Likes Received:
    0
    Trophy Points:
    156
    I've tried everything I can find to get FTP to start. I want to run PureFTPd.

    I tried switching back and forth using the WHM tools, and it fails. I've surfed out to

    http://diff.cpanel.net/ftpinstall/pure-ftpd/fedora/5 to do a pure-ftpd reinstall

    and I've gone to http://diff.cpanel.net/ftpinstall/proftpd/fedora/5/ to do a proftpd reinstall.

    After each attempt I get

    Waiting for ftpserver to restart..............finished.


    ftpserver has failed, please contact the sysadmin.


    I've even tried to do a /scripts/ftpup --force and it still fails...

    Any help is appreciated.

    Thanks!
     
  2. AndyReed

    AndyReed Well-Known Member
    PartnerNOC

    Joined:
    May 29, 2004
    Messages:
    2,222
    Likes Received:
    4
    Trophy Points:
    193
    Location:
    Minneapolis, MN
    Check the log files for any errors that might help you troubleshoot this issue.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. drsprite

    drsprite Active Member

    Joined:
    Aug 5, 2004
    Messages:
    39
    Likes Received:
    0
    Trophy Points:
    156
    I did and I'm still lost.

    Here's some log info:

    root@fusion [/etc/ssl/private]# /etc/init.d/pure-ftpd restart
    Stopping pure-config.pl: cat: /var/run/pure-ftpd.pid: No such file or directory
    kill: usage: kill [-s sigspec | -n signum | -sigspec] pid | jobspec ... or kill
    -l [sigspec]

    Stopping pure-authd:
    Starting pure-config.pl: Running: /usr/sbin/pure-ftpd -O clf:/var/log/xferlog
    -lextauth:/var/run/ftpd.sock --daemonize -A -c50 -B -C8 -D -fftp -H -I15
    -lextauth:/var/run/ftpd.sock -L2000:8 -m4 -s -U133:022 -u100
    -Oxferlog:/usr/local/apache/domlogs/ftpxferlog -k99 -Z -Y1
    [ OK ]
    Starting pure-authd:


    root@fusion [/etc/ssl/private]# tail /var/log/messages


    Jul 14 23:08:44 fusion pure-ftpd: (?@?) [ERROR] Sorry, but that file doesn't
    exist: [/etc/ssl/private/pure-ftpd.pem]
    Jul 14 23:08:44 fusion kernel: audit(1152932924.601:622): avc: denied {
    execmod } for pid=19450 comm="restartsrv_mysq"
    name="mysql.so" dev=hda2 ino=1720002
    scontext=root:system_r:unconfined_t:s0-s0:c0.c255
    tcontext=root:eek:bject_r:lib_t:s0 tclass=file
    Jul 14 23:13:17 fusion pure-ftpd: (?@?) [ERROR] Sorry, but that file doesn't
    exist: [/etc/ssl/private/pure-ftpd.pem]
     
  4. mOdY

    mOdY Well-Known Member

    Joined:
    Dec 25, 2004
    Messages:
    80
    Likes Received:
    0
    Trophy Points:
    156
    this is the same happening with me! isn't there any fix yet or again cPanel will starve our boxes to DEATH :p
     
  5. NightStorm

    NightStorm Well-Known Member

    Joined:
    Jul 28, 2003
    Messages:
    286
    Likes Received:
    4
    Trophy Points:
    168
    cPanel Access Level:
    Root Administrator
    Twitter:
    Have you tried asking cPanel? Opening a ticket is a fast and effective way to have one of their techs look at the problem. It's very well-known that this is a "user-based" support forum, and not a "staff-based" support forum.
     
  6. myhostingRU

    myhostingRU Registered

    Joined:
    Aug 3, 2006
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    151
    Fixed!!

    open file:
    /etc/rc.d/init.d/pure-ftpd

    then comment lines which include:
    prog=pure-config.pl
    stat=pure-ftpd

    and add line:
    prog=pure-ftpd

    after that, you can to restart ftpd vie WHM
     
  7. myhostingRU

    myhostingRU Registered

    Joined:
    Aug 3, 2006
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    151
    FIXED!! Stage TWO %))

    Hey, Mans.... IGRORE my prevision post!!!!!....

    real FIXED:

    open for edit /etc/pure-ftpd.conf
    and set TLS option at 0.

    old
    TLS 1

    new

    TLS 0
     
    #7 myhostingRU, Aug 3, 2006
    Last edited: Aug 4, 2006
  8. drsprite

    drsprite Active Member

    Joined:
    Aug 5, 2004
    Messages:
    39
    Likes Received:
    0
    Trophy Points:
    156
    thanks for all the help.

    i couldn't wait any longer for a resolution so i had cut a cpanel ticket at the time of the issue. they had it fixed within a couple of hours.

    thanks
     
  9. bigiken

    bigiken Registered

    Joined:
    Jul 20, 2006
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    151
    I come across with the same problem.
    By using the solution above, I have fixed it.
    myhostingRU, thanks for your help!;)
     
  10. serj21

    serj21 Member

    Joined:
    Oct 11, 2004
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    151
    Just wanted to say thanks for this fix as helped me fix the same error was getting on a new server
     
  11. naveen3

    naveen3 Active Member

    Joined:
    Jan 28, 2005
    Messages:
    30
    Likes Received:
    0
    Trophy Points:
    156
    Thanks myhostingRU.

    Thanks myhostingRU
    it worked on my new server.

    -Naveen
     
  12. ddcarnage

    ddcarnage Member

    Joined:
    Mar 1, 2006
    Messages:
    21
    Likes Received:
    0
    Trophy Points:
    151
    Horray thx a lot :)
     
  13. madhav

    madhav Member

    Joined:
    Jun 29, 2005
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    151
    gr8

    Nice work myhostingRU, Thanks again for the wonderful tip :eek:
     
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice