ftpd service starts, despite being disabled.

jacampbe

Active Member
Mar 19, 2008
30
0
56
In WHM >> Main >> Service Configuration >> Service Manager, I have configured ftpd such that Enabled and Monitored are unchecked (not ticked).

However, each time I restart the server, pure-ftpd starts. I have now used chkconfig to ensure that the service is not restarted for future reboots - see Console output below.

Question:
Is this the expected behaviour ? If so, I think the "Service Manager" screen should warn that an additional step is necessary to stop the ftpd service starting when the server is re-booted.

Our server runs CentOS 5 on an applogic VPS.

Console output:
#chkconfig --list pure-ftpd
HTML:
pure-ftpd       0:off   1:off   2:on    3:on    4:on    5:on    6:off
#chkconfig pure-ftpd off

#chkconfig --list pure-ftpd
HTML:
pure-ftpd       0:off   1:off   2:off   3:off   4:off   5:off   6:off
 

aapkapratik

Member
Oct 26, 2009
24
0
51
It seems really strange....

As you've mentioned Steps Performed by you:

In WHM >> Main >> Service Configuration >> Service Manager, I have configured ftpd such that Enabled and Monitored are unchecked (not ticked).
And

#chkconfig pure-ftpd off

This should take care of pure-ftpd....

But if it still manages to trouble you, you can try this :
{ This step is even strange then this issue but will work surely }

From Shell fire this command with root privileges

# chmod 000 /etc/init.d/pure-ftpd

With this what we are doing is the not allowing daemon "pure-ftpd " to execute as permission is being given to " 000 "