jimlongo

Well-Known Member
Mar 20, 2008
248
20
68
I have in my pure-ftp.config
Code:
# Port range for passive connections - keep it as broad as possible.
PassivePortRange 49152 65534

# Force an IP address in PASV/EPSV/SPSV replies. - for NAT.
# Symbolic host names are also accepted for gateways with dynamic IP
# addresses.

ForcePassiveIP 192.168.0.1
#ForcePassiveIP ~
Have also tried the above config with ForcePassiveIP ~ as in the docs

And the range allowed in CSF TCP IN 49152:65534

If I try to connect FTPS and specify a port in that range it always gets refused.
I can connect on port 21.

What do I need to do so my requests on a specific port other than 21 will be allowed?
 

cPanelLauren

Product Owner
Staff member
Nov 14, 2017
13,295
1,254
313
Houston
Hi @jimlongo


You wouldn't want to change the passive IP range, what you're wanting to do is change the active FTP port it sounds like. What you'll do in this case is change the port number on the line as follows:

Code:
Bind 21
Then restart the ftp server as well as ensure that the new port number is allowed in the firewall.

Some information on Passive vs Active FTP mode: How to Enable FTP Passive Mode - cPanel Knowledge Base - cPanel Documentation
 
  • Like
Reactions: jimlongo