The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

ftpserver has failed, please contact the sysadmin

Discussion in 'General Discussion' started by djalpha, Feb 8, 2007.

  1. djalpha

    djalpha Active Member

    Joined:
    Jan 20, 2003
    Messages:
    25
    Likes Received:
    0
    Trophy Points:
    1
    dear masters help me about FTP stopped.
    ftpserver has failed, please contact the sysadmin

    fedora 4



    # service pure-ftpd start

    Code:
    Starting pure-config.pl: Running: /usr/sbin/pure-ftpd -O clf:/var/log/xferlog -lextauth:/var/run/ftpd.sock --daemonize -A -c50 -B -C8 -
    D -fftp -H -I15 -lextauth:/var/run/ftpd.sock -L2000:8 -m4 -s -U133:022 -u100 -Oxferlog:/usr/local/apache/domlogs/ftpxferlog -k99 -Z -Y1
    /usr/sbin/pure-ftpd: error while loading shared libraries: [COLOR="Red"]libssl.so.6:[/COLOR] cannot open shared object file: No such file or directory
    [FAILED]
    Starting pure-authd: /usr/sbin/pure-authd: error while loading shared libraries: libssl.so.6: cannot open shared object file: No such f
    ile or directory

    and
    # /scripts/ensurerpm openssl

    Code:
    
    --> Finished Dependency Resolution
    Error: Missing Dependency: libcrypto.so.5 is needed by package httpd
    Error: Missing Dependency: libssl.so.5 is needed by package courier-imap
    Error: Missing Dependency: libcrypto.so.5 is needed by package courier-imap
    Error: Missing Dependency: libssl.so.5 is needed by package exim
    Error: Missing Dependency: libcrypto.so.5 is needed by package exim
    Error: Missing Dependency: libssl.so.5 is needed by package httpd
    Error: Missing Dependency: libapr-0.so.0 is needed by package httpd
    Error: Missing Dependency: howl = 0.9.8 is needed by package howl-libs
    Error: Missing Dependency: libaprutil-0.so.0 is needed by package httpd
    Error: hal conflicts with kernel < 2.6.15
    Error: Missing Dependency: xorg-x11-libs = 6.8.2-37.FC4.49.2.1 is needed by package xorg-x11-devel
    Error: Missing Dependency: XFree86-libs >= 4.2.99 is needed by package libgnomeui
    Error: Missing Dependency: xorg-x11-libs = 6.8.2-37.FC4.49.2.1 is needed by package xorg-x11-xfs
    Error: Missing Dependency: libdpstk.so.1 is needed by package ImageMagick
    Error: Missing Dependency: libdps.so.1 is needed by package ImageMagick
    
    
    anybody help me?
     
  2. ujr

    ujr Well-Known Member

    Joined:
    Mar 19, 2004
    Messages:
    290
    Likes Received:
    0
    Trophy Points:
    16
    wow, that's not good.

    have you tried forcing an update and reinstalling any missing libraries?

    if you don't know how this is done, then perhaps hire some one that does. there are plenty of people here who offer services like that.
     
  3. djalpha

    djalpha Active Member

    Joined:
    Jan 20, 2003
    Messages:
    25
    Likes Received:
    0
    Trophy Points:
    1
    My last actions;

    update kernel
    #yum -y update kernel


    finaly my kernel now kernel-2.6.17-1.2142_FC4

    Update fedora 4 to fedora 5
    #rpm -Uhv http://download.fedora.redhat.com/p.../os/Fedora/RPMS/fedora-release-5-5.noarch.rpm

    #yum -y update
    #rpm -qa | grep fedora-release
    fedora-release-5-5

    update openssl
    #rpm -q openssl
    openssl-0.9.7f-7.10

    Cpanel version
    WHM 11.0.0 Cpanel 11.1-E172 Fedora i686

    Server information Pentium(R) 4 CPU 2.80GHz 1Ghz Ram

    I don't reboot my server and I don't thing reboot without full backup :cool:

    I know my server now Fedora 5 but my kernel for fedora4 and ftp server find libssl.so.6 for fedora6 :rolleyes:


    I need profesional fresh setup for kernel, fedora and cpanel + mailscanner, apache 2, php5, mysql
     
  4. djalpha

    djalpha Active Member

    Joined:
    Jan 20, 2003
    Messages:
    25
    Likes Received:
    0
    Trophy Points:
    1
    # yum -y update kernel

    Code:
     
    Setting up Update Process
    Setting up repositories
    core                                                                 [1/3]
    core                      100% |=========================| 1.1 kB    00:00     
    updates                                                              [2/3]
    updates                   100% |=========================| 1.2 kB    00:00     
    extras                                                               [3/3]
    extras                    100% |=========================| 1.1 kB    00:00     
    Reading repository metadata in from local files
    Excluding Packages in global exclude list
    Finished
    Resolving Dependencies
    --> Populating transaction set with selected packages. Please wait.
    ---> Package kernel.i686 0:2.6.18-1.2257.fc5 set to be installed
    --> Running transaction check
    --> Processing Conflict: kernel conflicts iptables < 1.3.2-1
    --> Proc Dep: mkinitrd >= 4.2.21-1 for package: kernel
    --> Processing Conflict: kernel conflicts ppp < 2.4.3-3
    --> Processing Conflict: kernel conflicts kudzu < 1.2.5
    --> Processing Conflict: kernel conflicts isdn4k-utils < 3.2-32
    --> Restarting Dependency Resolution with new changes.
    --> Populating transaction set with selected packages. Please wait.
    ---> Package iptables.i386 0:1.3.5-1.2 set to be updated
    ---> Package kudzu.i386 0:1.2.34.5-1 set to be updated
    ---> Package mkinitrd.i386 0:5.0.32-2 set to be updated
    ---> Package isdn4k-utils.i386 0:3.2-41.1.fc5 set to be updated
    ---> Package ppp.i386 0:2.4.3-6.2.1 set to be updated
    --> Running transaction check
    .........
    BLABLABLA
    .........
    .........
    --> Proc Dep: libICE.so.6 for package: ImageMagick
    --> Proc Dep: libXdmcp.so.6 for package: libX11
    --> Proc Dep: libXpm.so.4 for package: gd-progs
    --> Proc Dep: xorg-x11-libs = 6.8.2-37.FC4.49.2.1 for package: xorg-x11-devel
    --> Proc Dep: libSM.so.6 for package: redhat-lsb
    --> Proc Dep: libcrypto.so.5 for package: httpd
    --> Proc Dep: libssl.so.5 for package: courier-imap
    --> Proc Dep: libICE.so.6 for package: ghostscript
    --> Proc Dep: libXinerama.so.1 for package: gtk2
    --> Proc Dep: hotplug >= 2001_04_24-9 for package: pcmcia-cs
    --> Proc Dep: XFree86-libs >= 4.2.99 for package: libgnomeui
    --> Proc Dep: libXmu.so.6 for package: libtiff
    --> Proc Dep: libnewt.so.0.52 for package: ntsysv
    --> Proc Dep: libdpstk.so.1 for package: ImageMagick
    --> Proc Dep: libcrypto.so.5 for package: courier-imap
    --> Proc Dep: libSM.so.6 for package: gnome-python2
    --> Proc Dep: libXmuu.so.1 for package: xorg-x11-xauth
    --> Proc Dep: libSM.so.6 for package: usermode-gtk
    --> Proc Dep: libapr-0.so.0 for package: httpd
    --> Proc Dep: libnewt.so.0.52(NEWT_0.52) for package: ntsysv
    --> Proc Dep: xorg-x11-libs = 6.8.2-37.FC4.49.2.1 for package: xorg-x11-xfs
    --> Proc Dep: libXt.so.6 for package: ghostscript
    --> Proc Dep: libSM.so.6 for package: xorg-x11-devel
    --> Processing Conflict: hwdata conflicts pcmcia-cs
    --> Proc Dep: libXau.so.6 for package: libX11
    --> Proc Dep: libICE.so.6 for package: libtiff
    --> Proc Dep: libXi.so.6 for package: gtk2
    --> Proc Dep: howl = 0.9.8 for package: howl-libs
    --> Proc Dep: libXau.so.6 for package: libXext
    --> Proc Dep: libICE.so.6 for package: startup-notification
    --> Proc Dep: libXxf86vm.so.1 for package: xorg-x11-Mesa-libGL
    --> Proc Dep: libXpm.so.4 for package: xorg-x11-devel
    --> Proc Dep: libSM.so.6 for package: libungif
    --> Proc Dep: tk >= 8.4.12 for package: tix
    --> Proc Dep: libSM.so.6 for package: libwnck
    --> Proc Dep: libXrandr.so.2 for package: gtk2
    --> Proc Dep: libXcursor.so.1 for package: gtk2
    --> Proc Dep: libSM.so.6 for package: ghostscript
    --> Proc Dep: libssl.so.5 for package: exim
    --> Proc Dep: libSM.so.6 for package: libgnomeui
    --> Proc Dep: libICE.so.6 for package: gnome-python2
    --> Proc Dep: libFS.so.6 for package: xorg-x11-xfs
    --> Proc Dep: libSM.so.6 for package: gnome-mount
    --> Proc Dep: libaprutil-0.so.0 for package: httpd
    --> Proc Dep: libcrypto.so.5 for package: exim
    --> Proc Dep: libXt.so.6 for package: xorg-x11-devel
    --> Proc Dep: libXt.so.6 for package: redhat-lsb
    --> Proc Dep: libSM.so.6 for package: libbonoboui
    --> Proc Dep: libSM.so.6 for package: ImageMagick
    --> Proc Dep: libICE.so.6 for package: xorg-x11-devel
    --> Proc Dep: libXi.so.6 for package: libtiff
    --> Proc Dep: libfontenc.so.1 for package: xorg-x11-font-utils
    --> Proc Dep: tcl >= 8.4.12 for package: tix
    --> Proc Dep: libICE.so.6 for package: libbonoboui
    --> Proc Dep: libXfixes.so.3 for package: gtk2
    --> Proc Dep: libXpm.so.4 for package: gd
    --> Proc Dep: libdps.so.1 for package: ImageMagick
    --> Restarting Dependency Resolution with new changes.
    --> Populating transaction set with selected packages. Please wait.
    ---> Package libXau.i386 0:1.0.0-2.2 set to be updated
    ---> Package libXfont.i386 0:1.0.0-3 set to be updated
    ---> Package libXcursor.i386 0:1.1.5.2-2.2 set to be updated
    ---> Package newt.i386 0:0.52.2-6 set to be updated
    ---> Package libXpm.i386 0:3.5.4.2-2.2 set to be updated
    ---> Package libICE.i386 0:1.0.0-2.2 set to be updated
    ---> Package tcl.i386 0:8.4.13-1.1 set to be updated
    ---> Package libXres.i386 0:1.0.0-2.2 set to be updated
    ---> Package libfontenc.i386 0:1.0.1-1.2 set to be updated
    ---> Package libFS.i386 0:1.0.0-2.2 set to be updated
    ---> Package libXxf86vm.i386 0:1.0.0-2.2 set to be updated
    ---> Package libXrandr.i386 0:1.1.0.2-2.2 set to be updated
    ---> Package libSM.i386 0:1.0.0-2.2 set to be updated
    ---> Package tk.i386 0:8.4.13-1.1 set to be updated
    ---> Package libXt.i386 0:1.0.0-2.2 set to be updated
    ---> Package libXfixes.i386 0:3.0.1.2-2.2 set to be updated
    ---> Package libXmu.i386 0:1.0.0-2.2 set to be updated
    ---> Package libXdmcp.i386 0:1.0.0-2.2 set to be updated
    ---> Package libXinerama.i386 0:1.0.1-1.2 set to be updated
    ---> Package libXi.i386 0:1.0.0-2.2 set to be updated
    ---> Package xorg-x11-filesystem.noarch 0:7.0-1 set to be updated
    --> Running transaction check
    --> Proc Dep: xorg-x11-libs = 6.8.2-37.FC4.49.2.1 for package: xorg-x11-devel
    --> Proc Dep: libnewt.so.0.51 for package: authconfig
    --> Proc Dep: libssl.so.5 for package: httpd
    --> Proc Dep: libnewt.so.0.51 for package: system-config-securitylevel-tui
    --> Proc Dep: libcrypto.so.5 for package: httpd
    --> Proc Dep: libssl.so.5 for package: courier-imap
    --> Proc Dep: filesystem >= 2.3.7-1 for package: xorg-x11-filesystem
    --> Proc Dep: libslang.so.2 for package: newt
    --> Proc Dep: hotplug >= 2001_04_24-9 for package: pcmcia-cs
    --> Proc Dep: XFree86-libs >= 4.2.99 for package: libgnomeui
    --> Proc Dep: libcrypto.so.5 for package: courier-imap
    --> Proc Dep: libnewt.so.0.51 for package: setuptool
    --> Proc Dep: libapr-0.so.0 for package: httpd
    --> Proc Dep: libslang.so.2(SLANG2) for package: newt
    --> Processing Conflict: hwdata conflicts pcmcia-cs
    --> Proc Dep: howl = 0.9.8 for package: howl-libs
    --> Proc Dep: libdpstk.so.1 for package: ImageMagick
    --> Proc Dep: libdps.so.1 for package: ImageMagick
    --> Proc Dep: libssl.so.5 for package: exim
    --> Proc Dep: xorg-x11-libs = 6.8.2-37.FC4.49.2.1 for package: xorg-x11-xfs
    --> Proc Dep: libaprutil-0.so.0 for package: httpd
    --> Proc Dep: libcrypto.so.5 for package: exim
    --> Restarting Dependency Resolution with new changes.
    --> Populating transaction set with selected packages. Please wait.
    ---> Package authconfig.i386 0:5.2.3-1 set to be updated
    ---> Package system-config-securitylevel-tui.i386 0:1.6.16-3 set to be updated
    ---> Package setuptool.i386 0:1.18.1-1.2 set to be updated
    ---> Package slang.i386 0:2.0.6-1.fc5 set to be updated
    ---> Package filesystem.i386 0:2.3.7-1.2.1 set to be updated
    --> Running transaction check
    --> Proc Dep: libssl.so.5 for package: exim
    --> Proc Dep: libapr-0.so.0 for package: httpd
    --> Proc Dep: xorg-x11-libs = 6.8.2-37.FC4.49.2.1 for package: xorg-x11-xfs
    --> Proc Dep: xorg-x11-libs = 6.8.2-37.FC4.49.2.1 for package: xorg-x11-devel
    --> Proc Dep: libcrypto.so.5 for package: httpd
    --> Processing Conflict: hwdata conflicts pcmcia-cs
    --> Proc Dep: libssl.so.5 for package: courier-imap
    --> Proc Dep: libcrypto.so.5 for package: exim
    --> Proc Dep: howl = 0.9.8 for package: howl-libs
    --> Proc Dep: hotplug >= 2001_04_24-9 for package: pcmcia-cs
    --> Proc Dep: libaprutil-0.so.0 for package: httpd
    --> Proc Dep: XFree86-libs >= 4.2.99 for package: libgnomeui
    --> Proc Dep: libssl.so.5 for package: httpd
    --> Proc Dep: libdps.so.1 for package: ImageMagick
    --> Proc Dep: libcrypto.so.5 for package: courier-imap
    --> Proc Dep: libdpstk.so.1 for package: ImageMagick
    [COLOR="red"]--> Finished Dependency Resolution
    Error: Missing Dependency: hotplug >= 2001_04_24-9 is needed by package pcmcia-cs
    Error: hwdata conflicts with pcmcia-cs
    Error: Missing Dependency: hotplug is needed by package udev
    Error: Missing Dependency: libcrypto.so.5 is needed by package httpd
    Error: Missing Dependency: libssl.so.5 is needed by package courier-imap
    Error: Missing Dependency: libcrypto.so.5 is needed by package courier-imap
    Error: Missing Dependency: libssl.so.5 is needed by package exim
    Error: Missing Dependency: libcrypto.so.5 is needed by package exim
    Error: Missing Dependency: libssl.so.5 is needed by package httpd
    Error: Missing Dependency: howl = 0.9.8 is needed by package howl-libs
    Error: Missing Dependency: libapr-0.so.0 is needed by package httpd
    Error: Missing Dependency: libaprutil-0.so.0 is needed by package httpd
    Error: Missing Dependency: xorg-x11-libs = 6.8.2-37.FC4.49.2.1 is needed by package xorg-x11-devel
    Error: Missing Dependency: XFree86-libs >= 4.2.99 is needed by package libgnomeui
    Error: Missing Dependency: libdpstk.so.1 is needed by package ImageMagick
    Error: Missing Dependency: xorg-x11-libs = 6.8.2-37.FC4.49.2.1 is needed by package xorg-x11-xfs
    Error: Missing Dependency: libdps.so.1 is needed by package ImageMagick[/COLOR]
    
     
  5. ujr

    ujr Well-Known Member

    Joined:
    Mar 19, 2004
    Messages:
    290
    Likes Received:
    0
    Trophy Points:
    16
    Here are two guys I can personally recommend to help you out.
    There are indeed other knowledgeable people here too, but I have no experience with the others.

    Chirpy, from configserver.com http://forums.cpanel.net/member.php?u=4363
    Rampage from WHG /webhostgear.com http://forums.cpanel.net/member.php?u=4696
     
    #5 ujr, Feb 9, 2007
    Last edited: Feb 9, 2007
  6. djalpha

    djalpha Active Member

    Joined:
    Jan 20, 2003
    Messages:
    25
    Likes Received:
    0
    Trophy Points:
    1
    dear ujr thank you for help, yes I use mailscanner packet from configserver. thank you again.
     
  7. Nikoms

    Nikoms Member

    Joined:
    Nov 29, 2006
    Messages:
    19
    Likes Received:
    0
    Trophy Points:
    1
    I have exactly the same error... Did you find the solution??

    Thank you!
     
Loading...

Share This Page