Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

function mail() doesn't work

Discussion in 'E-mail Discussion' started by DjMiX, Feb 13, 2005.

  1. DjMiX

    DjMiX Well-Known Member

    Joined:
    Nov 2, 2004
    Messages:
    63
    Likes Received:
    0
    Trophy Points:
    156
    Hello,

    Since the begining, the PHP function mail() doesn't work on our servers, we always get this type of e-mail back:

    The PHP script is perfect, no errors. And the e-mail address works perefectly, we tested it with many different valid e-mails.

    Any ideas ?

    Regards
     
  2. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,470
    Likes Received:
    21
    Trophy Points:
    463
    Location:
    Go on, have a guess
    Make sure that you do not have the following checked?
    WHM > Tweak Settings > Prevent the user 'nobody' from sending out mail to remote addresses

    Make sure that you do have the following completed with a valid email address:
    WHM > Change System Mail Preferences > nobody's mail
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. DjMiX

    DjMiX Well-Known Member

    Joined:
    Nov 2, 2004
    Messages:
    63
    Likes Received:
    0
    Trophy Points:
    156
    Thank you, problem repaired.
    It came from "Prevent the user 'nobody' from sending out mail to remote addresses", it was checked :)
    Thanks again.
     
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice