The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

gd install failed

Discussion in 'General Discussion' started by rachweb, Jun 22, 2005.

  1. rachweb

    rachweb Well-Known Member

    Joined:
    Jun 26, 2004
    Messages:
    268
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    amsterdam
    I have problem with the installation of gd. I get gd install failed. I have searched at the forum and can't find the solution. All library's are installed. I am using Freebsd 5.4
     
  2. daniel.eriksson

    Joined:
    Jan 18, 2004
    Messages:
    24
    Likes Received:
    0
    Trophy Points:
    1
    gd

    Hi,

    Install yum.
    Then,
    yum update. (no need to update if you dont want to)
    then yum install gd

    Br,

    Daniel
     
  3. rachweb

    rachweb Well-Known Member

    Joined:
    Jun 26, 2004
    Messages:
    268
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    amsterdam
    I don't have linux, only Freebsd. Yum is only for linux
     
  4. AlexF

    AlexF Well-Known Member

    Joined:
    Nov 20, 2003
    Messages:
    148
    Likes Received:
    0
    Trophy Points:
    16
    Try compiling apache once again with it. It has heppened to me and a simple rebuild worked.
     
  5. rachweb

    rachweb Well-Known Member

    Joined:
    Jun 26, 2004
    Messages:
    268
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    amsterdam
    I get the error when I run /scripts/upcp or upgrade to the last version. Apache is with gd compiled
     
  6. rachweb

    rachweb Well-Known Member

    Joined:
    Jun 26, 2004
    Messages:
    268
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    amsterdam
    Is the somebody that can help me with this problem??
     
  7. AndyReed

    AndyReed Well-Known Member
    PartnerNOC

    Joined:
    May 29, 2004
    Messages:
    2,222
    Likes Received:
    3
    Trophy Points:
    38
    Location:
    Minneapolis, MN
    It sounds that the GD library got corrupted and since the system is not able to read GD, installation fails. FreeBSD is one of the best OSs, and you need to be very careful when troubleshooting or trying to solve a problem. You can do more damage, than repair.
     
  8. aby

    aby Well-Known Member

    Joined:
    May 31, 2005
    Messages:
    638
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    India

    Did you update all the packages before compiling apache. If no.. try that .

    ----
    Aby :)
     
  9. TogaDave

    TogaDave Well-Known Member

    Joined:
    Apr 13, 2003
    Messages:
    135
    Likes Received:
    0
    Trophy Points:
    16
    rachweb,

    I want to try to help with this suggestion, but please keep in mind that I'm not an expert server admin and I'm not very confident in my abilities to give others advice. You may want to consult with someone more experienced and knowledgeable than me before you try this suggestion. I would really hate to have something go wrong on your server for doing something that I suggested!

    With that "disclaimer" said, I would probably do this:

    1. backup httpd.conf file, just in case

    2. SSH in and do /scripts/cleangd

    3. /scripts/easyapache
    choose option 7 and be sure to select any features you want, inlcuding GD

    after you exit/save and apache recompiles your problem may be fixed.

    But please, definitely consult with an expert before using my advice. Perhaps someone here can confirm whether I'm steering you in the right direction?
     
  10. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    Sounds like good advice to me.
     
  11. TogaDave

    TogaDave Well-Known Member

    Joined:
    Apr 13, 2003
    Messages:
    135
    Likes Received:
    0
    Trophy Points:
    16
    Feels good to finally be able to contribute something from experience :)
     
  12. rachweb

    rachweb Well-Known Member

    Joined:
    Jun 26, 2004
    Messages:
    268
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    amsterdam
    Problem it fails when I do /scripts/cleangd. I have many times recompiled apache but dont work.
     
  13. TogaDave

    TogaDave Well-Known Member

    Joined:
    Apr 13, 2003
    Messages:
    135
    Likes Received:
    0
    Trophy Points:
    16
    Sorry to hear that rachweb. If I were in your situation and had tried everything suggested with no luck, I would probably opt for submitting a trouble ticket to my upstream provider and see if they could help, and then if they can't I'd refer it to the cPanel folks.
     
  14. rachweb

    rachweb Well-Known Member

    Joined:
    Jun 26, 2004
    Messages:
    268
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    amsterdam
    I found the problem. GD installs with option -lpng12. But in libpng_config and libpng12_config the have only -lpng options. How can i fix this. To set lpng12 in the config files don't work. cpanel downloads the tar file and delete this after installation proces
     
  15. inci

    inci Registered

    Joined:
    May 26, 2005
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Moscow, Russian Federation
    I had the same problem on FreeBSD 5.4... but i found a solution.

    When you run /scripts/cleangd you will see something like it:

    ** Configuration summary for gd 2.0.33:

    Support for PNG library: yes (i had this missed)
    Support for JPEG library: yes
    Support for Freetype 2.x library: yes
    Support for Fontconfig library: yes
    Support for Xpm library: yes
    Support for pthreads: yes

    I had only libpng missed, so just downloaded libpng + zlib compiled it and then reruned /scripts/cleangd and GD is compiled without any probs and now all is fine.

    hope this will help you.
     
  16. rachweb

    rachweb Well-Known Member

    Joined:
    Jun 26, 2004
    Messages:
    268
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    amsterdam
Loading...

Share This Page