The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

GD Libraries w/ TTF Support?

Discussion in 'General Discussion' started by MalinRep, Jun 14, 2005.

  1. MalinRep

    MalinRep Member

    Joined:
    Jan 11, 2005
    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    1
    OK,
    I have Invision Top Site List installed. Once of the option is :

    TrueType Style
    If this image does't show yet the above one does either the font is invalid or your GD libraries don't have TTF support

    And that image doesn't show. I have GD installed. How can I give my GD libraries TTF support?
     
  2. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    I would imagine that you'd have to rebuild php with "Freetype Support" selected.
     
  3. hardjoko

    hardjoko Active Member

    Joined:
    Jun 22, 2005
    Messages:
    37
    Likes Received:
    0
    Trophy Points:
    6
    How to

    How to do that?

    I use easy apache, I also use the buildapache avaialable at whm. THings are working fine. But still gd and freetype not installed.
     
  4. aby

    aby Well-Known Member

    Joined:
    May 31, 2005
    Messages:
    638
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    India
    Did you select them when you recompiled the apache. I prefer shell

    /scripts/easyapache then select which all modules you need. It should work.
     
  5. hardjoko

    hardjoko Active Member

    Joined:
    Jun 22, 2005
    Messages:
    37
    Likes Received:
    0
    Trophy Points:
    6
    Yes

    I selected them

    In easyapache, I select 4) Beginner with/php gd+freetype support (if php will not compile, you must choose option 1)

    doesn't work

    I select
    6) Advanced (Experts Only, At Your Own Risk)

    doesn't work too.

    After I select 6 my php suddenly change version to 4.3.11 which is good. But still no gd

    Let's try 4 again.
     
  6. hardjoko

    hardjoko Active Member

    Joined:
    Jun 22, 2005
    Messages:
    37
    Likes Received:
    0
    Trophy Points:
    6
    root@deals [/]# /scripts/easyapache
    --00:37:22-- http://layer1.cpanel.net/buildapache.sea
    => `buildapache.sea'
    Resolving layer1.cpanel.net... done.
    Connecting to layer1.cpanel.net[198.66.78.11]:80... connected.
    HTTP request sent, awaiting response... 200 OK
    Length: 139,040 [text/plain]

    100%[====================================>] 139,040 16.68K/s ETA 00:00

    00:37:31 (16.68 KB/s) - `buildapache.sea' saved [139040/139040]

    Creating directory buildapache
    Verifying archive integrity... All good.
    Uncompressing buildapache.............................................................................................................................
    Verifying compiler and libs....Verifying installation....Existing lock /var/run/yum.pid: another copy is running. Aborting.
    Existing lock /var/run/yum.pid: another copy is running. Aborting.
    Done
    Done
    ********************************
    This is buildapache version 10.5.1
    ********************************

    If you have installed third party modules that buildapache does not install, you will probably need to recompile them after apache is rebuilt. You may experience an unusable apache that produces segmentation faults until the old modules are recompiled or removed.

    Select skill level:
    If it is possible for you to run phpsuexec, we recommend you do this
    by choosing option 2, or using the advanced options.

    phpsuexec combinded with webroot protection will prevent people
    from reading other users webroots. If you are unable to use
    phpsuexec we recommend you enable PHP open_basedir security
    inside of Web Host Manager.

    The following does not work with phpsuexec: php commands in
    .htaccess, php http authentication.

    1) Beginner without/phpsuexec + webroot protection support (*** DEFAULT ***)
    2) Beginner with/phpsuexec support + web root protection
    3) Beginner with/php mcrypt support (if php will not compile, you must choose option 1)
    4) Beginner with/php gd+freetype support (if php will not compile, you must choose option 1)
    5) Beginner with/php gd+freetype+mcrypt support (if php will not compile, you must choose option 1)
    6) Advanced (Experts Only, At Your Own Risk)
    7) Advanced [Load Previous Config] (Experts Only, At Your Own Risk)
    8) Failsafe mode (Resets apache config to default, USE ONLY AS A LAST RESORT)
    ---->4
    Apache automatically configured with gd+ttf support!
    /etc/rc.d/init.d/httpd start: httpd started
    Setting /home2 permissions to 0711......Done
    Setting /home permissions to 0711......Done
    Setting permissions for.....adultbes...associat...beattheg...beautifu...bellydan...bestca...bestcas...besteas1...bestfree...bestlove...bestonl...bestpass...creamycu...cumswall...cuntlick...dealsref...divasmag...dripping...eroticfr...eroticga...erotici...excellen...extremew...fairynud...fastcasi...fetishpe...forcedhu...freedown...freefuck...freelive...freenude...fuckfist...fuckingm...greatint...growrich...howtopla...hugebrea...hugeclit...incident...innocent...interact...javabla...lifenudi...lifetime...livegame...livenude...mardigra...nakedliv...nastyero...naturist...nudebeac...nudefree...nudegirl...nudelive...nudeteen...nudeviae...onlinefo...onlinene...personal...prettygi...privatep...promotin...quickfas...retireyo...sexclipf...stcusto...stliven...stnudet...stranges...strippin...sweetsex...waystoge...waystoma...webcamli...weirdsex...womanten...yourfina...yourpass...eroticp...innocen1...achievin...illustra...amateure...gymnasti...toplessb...publicnu...humansex...cumdrink...amateur1...asianmod...femaleor...livesexy...shavedpi...cumdripp...hardcore...jizzlick...undressg...cumface...lightbon...titsmilk...deepcunt...vibrator...cuntlic1...cumdrin1...cumlicke...sexslut...toyfuck...tiedtits...teencumd...jizzshot...nudegym...indonude...gangbang...ladyporn...clitring...cigarsex...dildocam...fuckface...jizzeate...toonxxx...titscom...wetclit...cuntcum...hottits...bigclit...bareall...asiaxxx...camxxx...avixxx...cumeat...clitpix...cumpix...cumxxx...cumfree...filmxxx...cumlick...cumshow...eatcum...fuckpix...hotpic...japsex...japxxx...lickit...lifesex...mpgxxx...titsex...titfree...wetbra...xxxpic...xxxmpgs...xxxpixs...xxxwavs...bigslut...japsexi...cunttvi...chickzi...cumpixi...tittiei...xxxcomi...cuntvin...titsfuc...upskirt...toonnud...twinnud...bigsluts...vaginaca...busslut...weirdse...wetcunt...wifeslu...wildorg...teencunt...xxxcinem...barenud...asiaxx1...bbwnude...camnude...teenboob...cumswap...titsworl...thainude...indiaxxx...cuntonly...arabnude...fistfuc...fuckcam...headjob...homesex...nudenew...secretar...sexysee...exoticn...nudewor...electric...sorority...barebre...creamyj...nudewo1...topless...sexysto...nudisml...nudebik...nudebod...sexylad...erotics...cleansh...obedient...hugenip...homebase...debtelim...onlinebu...bettero...homemar...onlinen...growyou...affordab...medical...persona1...onlinema...marketin...internet...homebas...interne1...moneyma...makingm...ecommer...earnmon...ideasto...nakedba...pornmov...teenpus...classic...famousn...nudejap...wideope...adultel...arabian...hornypr...girlsho...japanese...nudesai...desktop...nudehou...cumeati...erotich...womanor...vaginaa...hardcor1...publicn...hottub...cumshot...prettyp...teenche...vaginag...youngfu...streetu...hardlon...hornyre...offices...flasher...nicesma...bukkake...beachfl...sexyjap...erotic1...transpar...sexytig...sexysli...nipplee...latexha...nipples...gspots...ejaculat...bathroom...amateur...sickbon...womanwr...sexyshe...dirtyse...cumplas...dutchgo...mardigr...cuntlic...sexyslu...dirtyna...eatcu1...strippi1...cumea1...nudeliv3...cybervi...videopo...casinog...blackja...baccarat...ultimate...rulesof...college...interne2...interac1...nudespri...bachelor...realesta...marketi1...business...discussi...firstmo...fixedra...instant...lowrate...newhome...onlinef...refinanc...finance...loanrat...highint...busines1...genetips...fasterfi...socialis......Done
    00:48:51 URL:http://layer1.cpanel.net/buildapache/1/php-4.3.11.tar.gz [4875262/4875262] -> "php-4.3.11.tar.gz" [1]
    Untarring php....Done
    Applying CURL curl_formfree patch
    patching file ext/curl/curl.c
    Hunk #1 succeeded at 584 (offset 39 lines).
    Hunk #2 succeeded at 900 (offset 15 lines).
    configure php-4.3.11...(--with-apxs=/usr/local/apache/bin/apxs --prefix=/usr --with-xml --enable-bcmath --enable-calendar --enable-ftp --with-gd --with-jpeg-dir=/usr/local --with-png-dir=/usr --with-xpm-dir=/usr/X11R6 --enable-magic-quotes --with-mysql=/usr --enable-discard-path --with-pear --enable-sockets --enable-track-vars --with-ttf --enable-versioning --with-zlib)......................Done
    configure: error: libjpeg.(a|so) not found.
    make -j 1 php-4.3.11...(clean)....Done
    make -j 1 php-4.3.11.......Done
    make php-4.3.11...(install)....Done
    /etc/rc.d/init.d/httpd start: httpd started
    configure php-4.3.11...(--prefix=/usr --with-xml --enable-bcmath --enable-calendar --enable-ftp --with-gd --with-jpeg-dir=/usr/local --with-png-dir=/usr --with-xpm-dir=/usr/X11R6 --enable-magic-quotes --with-mysql=/usr --enable-discard-path --with-pear --enable-sockets --enable-track-vars --with-ttf --enable-versioning --with-zlib)...........................Done
    configure: error: libjpeg.(a|so) not found.
    make -j 1 php-4.3.11...(clean)....Done
    make -j 1 php-4.3.11.......Done
    make php-4.3.11...(install)....Done
    initfpsuexec: using apache 1.x support
    PHP version file has been updated to 4.3.11
    Executing /scripts/postbuildapache (if exists)...Done
    /etc/rc.d/init.d/httpd start: httpd started
    Waiting for httpd to restart..............finished.

    root 1441 1.0 24.9 131208 128512 ? S 00:50 0:00 /usr/local/apache/bin/httpd -DSSL

    httpd has failed, please contact the sysadmin.
    root@deals [/]# service httpd start
    /etc/init.d/httpd start: httpd (pid 1441) already running
     
  7. hardjoko

    hardjoko Active Member

    Joined:
    Jun 22, 2005
    Messages:
    37
    Likes Received:
    0
    Trophy Points:
    6
    Still doesn't work.
     
  8. hardjoko

    hardjoko Active Member

    Joined:
    Jun 22, 2005
    Messages:
    37
    Likes Received:
    0
    Trophy Points:
    6
    Allright,

    If you look at
    http://fasterfinancialfreedom.com/phpinfo.php

    You see:
    ./configure' '--with-apxs=/usr/local/apache/bin/apxs' '--prefix=/usr' '--with-xml' '--enable-bcmath' '--enable-calendar' '--enable-ftp' '--enable-magic-quotes' '--with-mysql=/usr' '--enable-discard-path' '--with-pear' '--enable-sockets' '--enable-track-vars' '--enable-versioning' '--with-zlib'

    Why it doesn't show --with gd I don't know.

    Also, when I run the build apache in the whm version I got this error:
    configure: error: libjpeg.(a|so) not found.

    make -j 1 php-4.3.11...(clean).... Done

    make -j 1 php-4.3.11....... Done

    make php-4.3.11...(install).... Done
    /etc/rc.d/init.d/httpd start: httpd could not be started

    configure php-4.3.11...(--prefix=/usr --with-xml --enable-bcmath --enable-calendar --enable-ftp --with-gd --with-jpeg-dir=/usr/local --with-png-dir=/usr --with-xpm-dir=/usr/X11R6 --enable-magic-quotes --with-mysql=/usr --enable-discard-path --with-pear --enable-sockets --enable-track-vars --with-ttf --enable-versioning --with-zlib).... . . . . . . . . . . . . . . . Done
    configure: error: libjpeg.(a|so) not found


    I think that's the problem. So the script tried to install gd, doesn't work, so they change the configure.

    But how to fix it?
     
  9. aby

    aby Well-Known Member

    Joined:
    May 31, 2005
    Messages:
    638
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    India
    #9 aby, Oct 15, 2005
    Last edited: Oct 15, 2005
  10. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    You also need to fix this:
    And then you can try fixing GD with:

    /scripts/cleangd
     
  11. hardjoko

    hardjoko Active Member

    Joined:
    Jun 22, 2005
    Messages:
    37
    Likes Received:
    0
    Trophy Points:
    6
    The Yum PID no is no longer a problem. It seems that it was just an accident where I am doing something else when I run easy apache.

    However, the real problems seem to be the following line:
    Verifying compiler and libs....Verifying installation....retrygrab() failed for:
    http://wftp.tu-chemnitz.de/pub/linux/ATrpms/fedora/1/en/i386/at-testing/headers/header.info
    Executing failover method
    retrygrab() failed for:
    http://ftp.freshrpms.net/pub/dag/dries/fedora/linux/1/i386/dries/RPMS/headers/header.info
    Executing failover method
    retrygrab() failed for:
    http://mirrors.ircam.fr/pub/dag/dries/fedora/linux/1/i386/dries/RPMS/headers/header.info
    Executing failover method
    retrygrab() failed for:
    http://apt.sw.be/dries/fedora/linux/1/i386/dries/RPMS/headers/header.info
    Executing failover method
    retrygrab() failed for:
    http://dries.studentenweb.org/yum/fedora/linux/1/i386/dries/RPMS/headers/header.info
    Executing failover method
    failover: out of servers to try
    Error getting file http://ftp.freshrpms.net/pub/dag/dries/fedora/linux/1/i386/dries/RPMS/headers/header.info
    [Errno 4] IOError: HTTP Error 404: Not Found
    Error: Cannot find baseurl or name for server 'freshrpms'. Skipping

    How should I fix this?

    I got this error when I run the whm version of update apache.

    Curiously, when I tried to update yum I also get similar error:

    root@deals [~]# yum check-update
    Error: Cannot find baseurl or name for server 'freshrpms'. Skipping
    Gathering header information file(s) from server(s)
    Server: ATrpms - Stable
    retrygrab() failed for:
    http://wftp.tu-chemnitz.de/pub/linu...ers/header.info
    Executing failover method
    Server: ATrpms - Bleeding
    Server: ATrpms - Testing
    Server: Dag APT Repository
    Server: Dries APT/YUM Repository
    retrygrab() failed for:
    http://apt.sw.be/dries/fedora/linux...ers/header.info
    Executing failover method
    retrygrab() failed for:
    http://dries.studentenweb.org/yum/f...ers/header.info
    Executing failover method
    retrygrab() failed for:
    http://ftp.freshrpms.net/pub/dag/dr...ers/header.info
    Executing failover method
    retrygrab() failed for:
    http://mirrors.ircam.fr/pub/dag/dri...ers/header.info
    Executing failover method
    failover: out of servers to try
    Error getting file http://apt.sw.be/dries/fedora/linux...ers/header.info
    [Errno 4] IOError: HTTP Error 404: Not Found
     
    #11 hardjoko, Oct 16, 2005
    Last edited: Oct 16, 2005
  12. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    That suggests that either all those yum mirrors are broken (seems unlikely) or that DNS lookups are not resolving correctly on the server, in which case you need to check that the resolvers listed in /etc/resol.conf are indeed working.
     
  13. cookiesunshinex

    cookiesunshinex Well-Known Member

    Joined:
    Jun 10, 2005
    Messages:
    77
    Likes Received:
    0
    Trophy Points:
    6
    For a simpler explanation of this problem:

    If you have GD installed, but not with TrueType Font support.

    Go to WHM > Update Apache > Click "Load Previous Config" if you have that option. If you don't have that option, it means you haven't updated Apache since WHM/Cpanel install as Chirpy says.

    Make sure that GD is checked, also make sure that "Freetype support" towards the bottom of the PHP module options is also checked.

    When you've finished selecting your options, choose Start Build.

    After Apache finishes rebuilding and restarts itself, you should have GD installed with Freetype Support (TrueType).
     
  14. Joseph

    Joseph Member

    Joined:
    Apr 28, 2003
    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Ontario, Canada
    Solution for Some

    I don't know if this will work for everyone with this issue, but this is how we solved it for our new server (Fedora Core 4, x86_64). Disclaimer: I'm not necessarily the most experienced Linux tech here, so if you are, and my instructions are horribly incorrect - please wade in.

    First I tried what others recommended, clean installs of GD, reinstalling libjpeg from scratch, none of them worked. It still kept saying libjpeg.so wasn't there (libjpeg.(a|so) not found)

    So I went looking - and lo and behold, they weren't there - in fact, they were named something completely different. So all I did was create the symlinks and bang! Easyapache worked like a charm.

    1. Get into the right directory
    > cd /usr/lib

    2. Find the actual name of the libjpeg file (it was libjpeg.so.2.0.0 for me)
    > ls -l libjpeg*

    3. Create your link
    > link libjpeg.so.2.0.0 libjpeg.so

    4. Re-run EasyApache
    > /scripts/easyapache

    Note, for me, libpng also had this problem, and so I had to repeat the above steps for libpng.so

    Hope this helps!

    ~ Joseph
     
Loading...

Share This Page