Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Generating SSL certificate issue

Discussion in 'Security' started by Maor Bar, May 9, 2018.

Tags:
  1. Maor Bar

    Maor Bar Member

    Joined:
    Jun 26, 2017
    Messages:
    9
    Likes Received:
    2
    Trophy Points:
    3
    Location:
    Israel
    cPanel Access Level:
    Root Administrator
    /* UPDATE */
    everything seems to be OK now. I generate the certificate again and it's not a self-sign one.



    Hello,
    I have WHM with 12 websites. in all my websites I installed a certificate from the cPanel with no problem at all.
    yesterday I created a new account for a new website and when I'm tried to generate new SSL certificate I get a self-sign certificate and an error on my website about this certificate.

    I did the same thing like always and for this specific website, I get a self-sign certificate.
    this is the domain

    - Removed -

    What do I need to do?
    Thank you.
     
    #1 Maor Bar, May 9, 2018
    Last edited by a moderator: May 9, 2018
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    43,903
    Likes Received:
    1,814
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello @Maor Bar,

    I'm glad to see the issue is now solved. Were you installing your SSL certificates that you purchased from a SSL certificate provider, or were you making use of the AutoSSL feature? Keep in mind the certificates issued with the AutoSSL feature must pass the domain control validation process (this can take a few hours).

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice