GeoLite Legacy databases are now discontinued

vlee

Well-Known Member
Oct 13, 2005
375
26
178
Spokane, Washington
cPanel Access Level
Root Administrator
According to MaxMind https://support.maxmind.com/geolite-legacy-discontinuation-notice/

On January 2, 2019, we discontinued our GeoLite Legacy databases. This discontinuation was first announced on January 2, 2018.

GeoLite Legacy databases are no longer available for download. Attempting to download a GeoLite Legacy database file will result in the error: “Database edition not found”.

So is there any way to update the cPanel servers with the new methods which is now using "GeoLite2-City.mmdb" "GeoLite2-Country.mmdb" file names?
 

cPanelLauren

Product Owner
Staff member
Nov 14, 2017
13,296
1,261
313
Houston
Hi @vlee

I found an internal case that discusses this issue. In the case, we noted that we do not actually use MaxMind data we use the Geo::IPfree database which gets its data from software77.net/geo-ip/

This won't affect cPanel based on the data in the case.
 
Last edited by a moderator:

vlee

Well-Known Member
Oct 13, 2005
375
26
178
Spokane, Washington
cPanel Access Level
Root Administrator
That is good for the server.

But it does not help in the respect for certain web based applications to use that when they require maxmind database to be installed on the server and there is really much good documentation how to do it on cPanel.

I have tried what they posted for the GEOIP2 php module and still does not work. Because it says that it cannot find the database even though it was installed.

This method mattgibson.ca/compiling-mod_geoip2-use-easyapache-4-ea4-cpanel/ does not work with the new database files.
 
Last edited by a moderator:

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,910
2,216
363
Hello @vlee,

But it does not help in the respect for certain web based applications to use that when they require maxmind database to be installed on the server and there is really much good documentation how to do it on cPanel.
If the applications specifically require the MaxMind database, then you'll need to review the alternatives they offer on the blog post you linked. EX:

If you are using the GeoLite Legacy databases, you will need to switch to the GeoLite2 databases and update your integrations to use the GeoLite2 databases before January 2, 2019 to ensure your continued access to geolocation data.

Another option is to switch to the paid GeoIP Legacy equivalent of the database you are using. In that way, you would be able to continue to use your existing integrations. You may also want to consider upgrading to the GeoIP2 brand. (Please note that since the GeoIP Legacy databases have been superseded by GeoIP2, the GeoIP Legacy databases may also be discontinued at some point in the future.)
Note that we don't officially support mod_geoip2, but there's a feature request you can vote for at:

Request to add mod_geoip2 to EasyApache

In terms of a workaround for your custom integration, can you let us know the full step-by-step instructions we can use to reproduce the issue?

Thank you.
 

vlee

Well-Known Member
Oct 13, 2005
375
26
178
Spokane, Washington
cPanel Access Level
Root Administrator
I just posted a comment and a like to the Request to add mod_geoip2 to EasyApache which was last commented on 21 months ago.

Hello @vlee,

In terms of a workaround for your custom integration, can you let us know the full step-by-step instructions we can use to reproduce the issue?
This is the steps taken to reproduce the issue Just go to mattgibson.ca/compiling-mod_geoip2-use-easyapache-4-ea4-cpanel/ and follow the instructions but use the new file formats.

Then try to install it with the new following files listed below

GeoLite2-City.mmdb
GeoLite2-Country.mmdb

The legacy files below are no longer available

GeoIP.dat
GeoLiteCity.dat
 
Last edited by a moderator:

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,910
2,216
363
Then try to install it with the new following files listed below

GeoLite2-City.mmdb
GeoLite2-Country.mmdb

The legacy files below are no longer available

GeoIP.dat
GeoLiteCity.dat
Hello @vlee,

As I understand, you won't be able to use the mmdb files as drop-in replacement for the .dat files. This is not something that cPanel & WHM can control, as Maxmind operates these databases and notes the following:

If you are using the GeoLite Legacy databases, you will need to switch to the GeoLite2 databases and update your integrations to use the GeoLite2 databases before January 2, 2019 to ensure your continued access to geolocation data.

Another option is to switch to the paid GeoIP Legacy equivalent of the database you are using. In that way, you would be able to continue to use your existing integrations. You may also want to consider upgrading to the GeoIP2 brand. (Please note that since the GeoIP Legacy databases have been superseded by GeoIP2, the GeoIP Legacy databases may also be discontinued at some point in the future.)
You may want to reach out to a third-party developer or system administrator for assistance creating a custom solution if purchasing the commercial GeoIP legacy database is not an option for you. We provide a list of companies offering system admin services at:

System Administration Services | cPanel Forums

Thank you.