The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Getting SELinux errors When SELinux Supposedly Disabled

Discussion in 'General Discussion' started by pr0gr4mm3r, Nov 3, 2008.

  1. pr0gr4mm3r

    pr0gr4mm3r Member

    Joined:
    Aug 25, 2006
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    1
    I am trying to run a php script from the command line, by typing "php some_script.php", and I get a long list of SELinux errors. SELinux should be disabled on this box. Here is a summery of the errors I get:

    Code:
    /etc/selinux/targeted/contexts/files/file_contexts:  line 474 has invalid regex ^/hiddev.*$:  Memory exhausted
    /etc/selinux/targeted/contexts/files/file_contexts:  line 475 has invalid regex ^/mpu401.*$:  Memory exhausted
    /etc/selinux/targeted/contexts/files/file_contexts:  line 476 has invalid regex ^/nvidia.*$:  Memory exhausted
    /etc/selinux/targeted/contexts/files/file_contexts:  line 477 has invalid regex ^/usb/lp.*$:  Memory exhausted
    /etc/selinux/targeted/contexts/files/file_contexts:  line 478 has invalid regex ^/initrd\.img.*$:  Memory exhausted
    /etc/selinux/targeted/contexts/files/file_contexts:  line 479 has invalid regex ^/sbin/r?ndc$:  Memory exhausted
    /etc/selinux/targeted/contexts/files/file_contexts:  line 480 has invalid regex ^/patmgr[01]$:  Memory exhausted
    /etc/selinux/targeted/contexts/files/file_contexts:  line 481 has invalid regex ^/syslog.conf$:  Memory exhausted
    /etc/selinux/targeted/contexts/files/file_contexts:  line 482 has invalid regex ^/i2o/hd[^/]*$:  Memory exhausted
    /etc/selinux/targeted/contexts/files/file_contexts:  line 483 has invalid regex ^/cciss/[^/]*$:  Memory exhausted
    /etc/selinux/targeted/contexts/files/file_contexts:  line 484 has invalid regex ^/reader.conf$:  Memory exhausted
    /etc/selinux/targeted/contexts/files/file_contexts:  line 485 is missing fields, skipping
    /etc/selinux/targeted/contexts/files/file_contexts:  line 486 is missing fields, skipping
    /etc/selinux/targeted/contexts/files/file_contexts:  line 487 is missing fields, skipping
    /etc/selinux/targeted/contexts/files/file_contexts:  line 488 is missing fields, skipping
    /etc/selinux/targeted/contexts/files/file_contexts:  line 489 is missing fields, skipping
    .
    .
    .
    /etc/selinux/targeted/contexts/files/file_contexts:  line 2083 is missing fields, skipping
    /etc/selinux/targeted/contexts/files/file_contexts:  line 2084 is missing fields, skipping
    /etc/selinux/targeted/contexts/files/file_contexts:  line 2085 is missing fields, skipping
    /etc/selinux/targeted/contexts/files/file_contexts.homedirs:  line 14 is missing fields, skipping
    /etc/selinux/targeted/contexts/files/file_contexts.homedirs:  line 15 is missing fields, skipping
    /etc/selinux/targeted/contexts/files/file_contexts.homedirs:  line 16 is missing fields, skipping
    /etc/selinux/targeted/contexts/files/file_contexts.homedirs:  line 17 is missing fields, skipping
    .
    .
    .
    /etc/selinux/targeted/contexts/files/file_contexts.homedirs:  line 52 is missing fields, skipping
    Out of memory
    
    Sometimes the "Out of memory" statement is replaced by a Segmentation Fault, and it leaves a huge "core" file in the directory.

    Echoing /selinux/enforce shows 0, and the /etc/selinux/config shows SELINUX=disabled.

    After some Google searching, I found some bug reports related to SELinux, but this is supposed to be disabled.
     
Loading...

Share This Page