The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Getting SSL3_GET_CLIENT_HELLO:length mismatch on POP3-SSL

Discussion in 'E-mail Discussions' started by jetnet, Jan 8, 2010.

  1. jetnet

    jetnet Active Member

    Joined:
    Jun 30, 2004
    Messages:
    28
    Likes Received:
    0
    Trophy Points:
    1
    Somewhere around the new year, all of our clients stopped being able to connect to the server via pop3 when using SSL. If they are not using SSL, everything works fine. So the question everyone is asking me is, "what happened". I have no idea. I have turned off all the firewalls, that does not solve it. I have tried restarting courier to no avail. I have verified that the SSL certificate is good, I can still send SMTP SSL traffic with no problem, I just can not check my email with SSL.

    Do you have any idea what would be causing the error:

    SSL3_GET_CLIENT_HELLO:length mismatch

    to show up in /var/log/maillog?
     
  2. jetnet

    jetnet Active Member

    Joined:
    Jun 30, 2004
    Messages:
    28
    Likes Received:
    0
    Trophy Points:
    1
    I got the problem solved. There was an update on December 31st, and it updated the config files, and did not have the correct settings for SSL. I compared them to one of our other CPanel servers, and everything was solved.
     
Loading...

Share This Page