Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Getting this message in easy apache

Discussion in 'Security' started by WebHostPro, Aug 7, 2017.

  1. WebHostPro

    WebHostPro Well-Known Member
    PartnerNOC

    Joined:
    Jul 28, 2002
    Messages:
    1,618
    Likes Received:
    11
    Trophy Points:
    318
    Location:
    LA, Costa RIca
    cPanel Access Level:
    Root Administrator
    Twitter:
    On a customers server we are getting:

    Recommendations for “PHP DSO” *
    PHP DSO runs as the user nobody by default. In a shared hosting environment, this is a security issue. Learn More

    • If you use suPHP, you will add some security, but may experience performance issues on your server.
    *These recommendations appear because you have “ea-php56-php” installed on your system.

    But we changed the DSO to CGI in the PHP handler. Is there something else we need to do to get rid of the security message?
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    38,658
    Likes Received:
    1,427
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello @WebHostPro,

    It's not possible to hide the message, but internal case EA-6219 is open to improve the recommendation message to account for cases where the DSO RPM is installed (but not enabled). I'll monitor this case and update this thread with more information as it becomes available.

    Thank you.
     
Loading...

Share This Page